Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 10-02-2011, 09:03 PM   #1
Jeanius


 
Jeanius's Avatar
 
Drives: Blk/Blk LS3 SS
Join Date: Dec 2006
Location: Golden State
Posts: 2,457
? For LS3 guys

When you have it in 4th/5th gear at around 2-3k RPM, will feel like its lugging the engine if you floor it?

I never noticed this before, maybe because I never tried it, I really don't know.... But mine is doing this. Up past 3k its fine though
__________________
2SS LS3 M6 - MGW - Dynatech LT's HF Cats - Magnaflow Street CB - ADM Race CAI - Pedders Xa Coilovers - Pfadt Sways
Jeanius is offline   Reply With Quote
Old 10-02-2011, 09:06 PM   #2
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
No, you won't experience lugging in 4th or 5th, you *might* in 6th gear. 6th should really only be used for cruising on a flat road. Need to drop down to 5th to go up hills and what not.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 10-02-2011, 09:08 PM   #3
Jeanius


 
Jeanius's Avatar
 
Drives: Blk/Blk LS3 SS
Join Date: Dec 2006
Location: Golden State
Posts: 2,457
Would you happen to know what could be the cause of this?

In 6th at the same RPM I dont have the same thing happening
__________________
2SS LS3 M6 - MGW - Dynatech LT's HF Cats - Magnaflow Street CB - ADM Race CAI - Pedders Xa Coilovers - Pfadt Sways
Jeanius is offline   Reply With Quote
Old 10-02-2011, 11:26 PM   #4
Inferno LSX
Supercharged LSX
 
Inferno LSX's Avatar
 
Drives: 2011 2SS/RS Black/Carbon Fiber
Join Date: Dec 2010
Location: City of Angels
Posts: 6,613
Yah, before the Whipple on mine I never had "lugging" in any gear except 6th. Unless you were under 1K RPMs. 2k-3k should be plenty of RPMs.
__________________
Inferno LSX is offline   Reply With Quote
Old 10-02-2011, 11:30 PM   #5
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,624
Quote:
Originally Posted by Jeanius View Post
Would you happen to know what could be the cause of this?

In 6th at the same RPM I dont have the same thing happening
I see you got a tune, It my not be that good or tuned for top end only.
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 10-03-2011, 09:30 PM   #6
bannonm

 
bannonm's Avatar
 
Drives: 2011 2SS/RS M6 VR
Join Date: Aug 2011
Location: Chicagoland
Posts: 1,337
Quote:
Originally Posted by 2SSRS View Post
I see you got a tune, It my not be that good or tuned for top end only.
Yeah that's a good point. A guy I know had headers, cats pulled, and a custom tune done. He was told by the tuner he gained 40 HP, however our club had a dyno day two weekends ago and he found out he was pulling 330 HP (L99) and he was running extremely lean. To the point they were afraid to do any more pulls on his car. He's working with another speed shop to have the tune redone.
bannonm is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey guys stopped in to say hi! Ex-stang Canada 3 09-25-2010 04:43 PM
Heres My Plan. Let me know what you guys think 2010Camaro2LTRS Member Car Journals 29 08-12-2009 04:58 AM


All times are GMT -5. The time now is 04:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.