Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
autoguy
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 4th Generation Camaros

4th Generation Camaros 1993-2002

Reply
 
Thread Tools
Old 04-08-2009, 12:11 PM   #1
BamTino024
 
BamTino024's Avatar
 
Drives: 2010 Camaro SS-RS
Join Date: Oct 2008
Location: NJ
Posts: 13
Fuel guage reads inaccurate - 1995 z28

I have a 1995 z28, with about 15,000 original miles on it. For most of the time that I've been the sole driver of the car (since about 2006), the fuel gauge has not been reading accurately. When I fill up the tank, the needle goes about 10º past the vertical FULL marker (so the gauge indicates that I'm more than full). When I'm coming up on empty, this means that I have to remember that when I have about 1/8 of a tank left, I'm most likely about to be running on fumes. I stupidly forgot about this one time, and actually ran out of gas on the highway. Has anyone else had this problem, and know what the cause is? Any help would be appreciated.
BamTino024 is offline   Reply With Quote
Old 04-09-2009, 12:30 AM   #2
Mason44
 
Mason44's Avatar
 
Drives: 1999 Hugger Orange Camaro
Join Date: Mar 2009
Location: Texas
Posts: 369
Mine did something like this to me. I would fill up and it would go all the way past the full mark and it would stay there all the time until it completely ran out of gas. My problem got fixed when i had to replace the fuel pump. So my best guess would be to have the fuel pump checked or replaced and if you dont want to go that way then just reset your trip gauge every time you fill up and go off of that.
Mason44 is offline   Reply With Quote
Old 04-09-2009, 12:40 AM   #3
Conflict
Loving the F body
 
Conflict's Avatar
 
Drives: 97 Firebird 3.8L 5 Speed
Join Date: Nov 2008
Location: Palm Desert, CA
Posts: 204
mine did the same thing to but I never fixed it, I never saw it as a major problem
__________________
My OLD Car 1995 V6 3.4L Camaro -K and N Air Filter
http://www.camaro5.com/forums/showthread.php?t=10174
Current Cars
-Modified 97 3.8L 5 speed Firebird
-2003 Toyota Highlander

Past Cars
-1985 2.8L 5 speed S10 Blazer
-1995 Chevy Camaro V6(130k miles)
-1990 Mercedes 300E(280k miles) RIP 6-08 due to a Mustang GT that did not pay attention
Conflict is offline   Reply With Quote
Old 04-09-2009, 08:33 AM   #4
CamaroSpike23
Mr. Nitpicky
 
CamaroSpike23's Avatar
 
Drives: anything I can get my hands on
Join Date: Sep 2006
Location: anywhere and everywhere
Posts: 22,856
Send a message via Yahoo to CamaroSpike23
the sending units on 4th gens are crap. plain and simple. you can replace it or learn to drive with it. I fill my car every 100 miles (i also only get about 10-12 mpg lol).

I've ran out of gas twice in the car cus I forgot about the gas gauge and was using my trip odo to count my miles..... till I found out that my trip odo wasnt reading correctly...lol
__________________
Never race anything you can't afford to light on fire and push off a cliff
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.

Quote:
Originally Posted by Bulldogwinters View Post
Read that link that Spike posted, it'll tell you everything you need to know.
Quote:
Originally Posted by WheelmanSS View Post
Post count is truly an accurate measure of how cool someone is on the Internet.
Quote:
Originally Posted by Greg Norris View Post
I piss excellence
and fart awesomeness
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.
"You can think I'm wrong, but that's no reason to quit thinking.”
Quote:
Originally Posted by Overflow View Post
But not all people were born awesome like you, Spike.
CamaroSpike23 is offline   Reply With Quote
Old 04-09-2009, 08:56 AM   #5
knowitman
Camaro fan since birth
 
knowitman's Avatar
 
Drives: 2013 ZL1
Join Date: Oct 2008
Location: Possum Trot, KY
Posts: 443
It's a common problem, and it happens on our 95' Z28 as well. I have heard that it has something to do with the shape of the fuel tank not having fully vertical walls, but don't quote me on that. That would mean that while the gauge may read linearly with respect to level, the volume remaining doesn't vary linearly with level.
knowitman is offline   Reply With Quote
Old 04-09-2009, 09:22 AM   #6
vladkgb
 
Drives: 2000 Camaro SS Pewter
Join Date: Mar 2009
Location: Miami
Posts: 179
Happened on my 95 as well. But it was even more messed up, if i was going up hill it the fuel gauge would increase temporarily, and if i went down hill the fuel gauge would fall. I had to fill up my tank everytime i saw 1/4 tank, learned the hard way when i tried to start the car oneday and it wouldnt fire, realized there was no gas even though gauge showed 1/4.
vladkgb is offline   Reply With Quote
Old 04-09-2009, 01:14 PM   #7
BamTino024
 
BamTino024's Avatar
 
Drives: 2010 Camaro SS-RS
Join Date: Oct 2008
Location: NJ
Posts: 13
Thanks for all the info guys. I was going to replace the fuel pump anyways, since I've been smelling fuel everytime I walk past the rear of the car...I'll see if that fixes the problem...if not I'll either try a new sender unit, or just deal with it and remember to fill up when I've got 1/4 tank left haha. I've also experienced the problem goin up and down hills too - the needle swings wildly. It also takes a nose dive anytime I punch it (especially at the track), and then comes back up when I let off the throttle and settle at a crusing speed.
BamTino024 is offline   Reply With Quote
Old 04-10-2009, 09:44 AM   #8
CamaroSpike23
Mr. Nitpicky
 
CamaroSpike23's Avatar
 
Drives: anything I can get my hands on
Join Date: Sep 2006
Location: anywhere and everywhere
Posts: 22,856
Send a message via Yahoo to CamaroSpike23
Quote:
Originally Posted by BamTino024 View Post
Thanks for all the info guys. I was going to replace the fuel pump anyways, since I've been smelling fuel everytime I walk past the rear of the car...I'll see if that fixes the problem...if not I'll either try a new sender unit, or just deal with it and remember to fill up when I've got 1/4 tank left haha. I've also experienced the problem goin up and down hills too - the needle swings wildly. It also takes a nose dive anytime I punch it (especially at the track), and then comes back up when I let off the throttle and settle at a crusing speed.
the smell of fuel is probably your evap canister or the solenoid going out.

http://shbox.com/1/evap_system.jpg
http://shbox.com/1/evap_sol.jpg
__________________
Never race anything you can't afford to light on fire and push off a cliff
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.

Quote:
Originally Posted by Bulldogwinters View Post
Read that link that Spike posted, it'll tell you everything you need to know.
Quote:
Originally Posted by WheelmanSS View Post
Post count is truly an accurate measure of how cool someone is on the Internet.
Quote:
Originally Posted by Greg Norris View Post
I piss excellence
and fart awesomeness
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.
"You can think I'm wrong, but that's no reason to quit thinking.”
Quote:
Originally Posted by Overflow View Post
But not all people were born awesome like you, Spike.
CamaroSpike23 is offline   Reply With Quote
Old 04-12-2009, 12:33 PM   #9
omarrakeen
Camaro Freak
 
Drives: 1998 Z28,1996 RS, 2005 Altima
Join Date: May 2008
Location: UAE-Dubai
Posts: 55
Send a message via MSN to omarrakeen Send a message via Yahoo to omarrakeen
same here... my guage reads ok when its full but when its empty is points at the last qurarter ...ran of gases couple of times but now am used to it lol i changed fule pump tho but i didnt find some other sending unit n no could fixed it...
omarrakeen is offline   Reply With Quote
Old 05-20-2009, 02:10 PM   #10
ucfbound1107
 
Drives: 1995 Chevy Camaro Z28 5.7L V8
Join Date: May 2009
Location: Orlando
Posts: 1
Mine is doing the same thing. I've had the car for over a year now, and only recently did the gas gauge really start to be off. I've run it out of gas once, but I've learned to count my mileage instead of going off the gas gauge.

But I'm also having a problem with every time it rains, if the car isn't warm or hasn't been running, it won't start if I leave to go anywhere. Has anyone else had this problem? A few people have told me its a problem with the distributor and the opti-spark/start in the design of this motor, but I also don't want to spend a lot more money that I need to to get it fixed. Can anyone help me?
ucfbound1107 is offline   Reply With Quote
Old 04-06-2011, 05:21 PM   #11
adamz37
 
Drives: 1995 camaro z/28 convertable
Join Date: Apr 2011
Location: chicago
Posts: 1
Bamtino,
You have a problem with the sending unit. Its attached to the pump in the tank. Two options,
1) drop the fuel tank which means removing the rear of the exhaust and lowering the rear end.
2) cut an access panel above the tank. I did number 2. most people do too. you can get direction off the internet.
adamz37 is offline   Reply With Quote
Old 04-06-2011, 11:55 PM   #12
Bulldogwinters
SS #2431
 
Bulldogwinters's Avatar
 
Drives: 2001 Pewter Camaro SS
Join Date: Jul 2009
Location: Missoula, MT
Posts: 1,224
Mine reads about a good 45 degrees past the vertival full line.. I don't even use my gas gage, I just fill up when my trip gets to about 230 Miles.. which is usually about 10-14 gallons

It's been attempted to be fixed by every possible shop in town. I just gave up on it.
__________________

2001 SS Lid, LT's, 3" Y to 4" Borla XR-1 dumped, LCA, LCA Brackets, Dbl. Adj. Panhard, Subframe Connectors, Shock Tower Brace, Eibach Prokit, Eddlebrock Shocks, C6 ZR1 Wheels 18x9.5
Bulldogwinters is offline   Reply With Quote
Old 04-07-2011, 07:21 AM   #13
Ant32894
Youjellybra?
 
Ant32894's Avatar
 
Drives: 95 3.4l V6
Join Date: Oct 2009
Location: Shirley, NY
Posts: 876
My tank never sees full... Im lucky if it sees half full :(
__________________
Animated Gif not allowed
Ant32894 is offline   Reply With Quote
Old 04-08-2011, 09:08 PM   #14
nascarnate326
Team Green
 
nascarnate326's Avatar
 
Drives: 1998 Chevrolet Camaro Z28
Join Date: May 2009
Location: Olivet, MI
Posts: 288
Send a message via AIM to nascarnate326
Mine is goofy as well. Part of the 4th gen character
__________________
'98 Camaro Z28 M6 -Toy
'07 HHR LT - DD
nascarnate326 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nitrous System ?????s PoleCat2SSRS2010 Forced Induction - V8 29 12-08-2010 05:55 PM
Possible new option packages changes wanted for '11 '12 model years PYROLYSIS 5th Gen Camaro SS LS LT General Discussions 91 09-15-2010 05:15 PM
Think about this and the Z28 5th gen 13F20 Camaro ZL1 Forum - ZL1 Specific Topics 41 09-04-2010 12:59 AM
Camaro ls3 news...true or false? Dark Knight Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 74 06-05-2008 05:29 PM


All times are GMT -5. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.