Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 4th Generation Camaros

4th Generation Camaros 1993-2002

Reply
 
Thread Tools
Old 11-03-2011, 10:41 AM   #1
Bulldogwinters
SS #2431
 
Bulldogwinters's Avatar
 
Drives: 2001 Pewter Camaro SS
Join Date: Jul 2009
Location: Missoula, MT
Posts: 1,224
Speedometer won't work..

So trying to install my new radio last night, kinda got it and my friend is helping me this weekend.. Weird thing though, my speedo and gauge lights no longer work. turn signal/hazards work, odometer does NOT work either. thought maybe I blew a fuse, but I can't find any blown ones.

Any help?
__________________

2001 SS Lid, LT's, 3" Y to 4" Borla XR-1 dumped, LCA, LCA Brackets, Dbl. Adj. Panhard, Subframe Connectors, Shock Tower Brace, Eibach Prokit, Eddlebrock Shocks, C6 ZR1 Wheels 18x9.5

Last edited by Bulldogwinters; 11-03-2011 at 11:13 AM.
Bulldogwinters is offline   Reply With Quote
Old 11-03-2011, 11:26 AM   #2
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
My guess is blown fuse. You checked every fuse right?
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-03-2011, 11:34 AM   #3
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
I would almost bet you shorted something out while dealing with electrical components. Id just take EVERY fuse out and look.
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-03-2011, 12:20 PM   #4
helmincamaro
Official Lounge BAMF
 
helmincamaro's Avatar
 
Drives: '97 Camaro
Join Date: Oct 2009
Location: Kannapolis, NC
Posts: 13,671
Send a message via AIM to helmincamaro Send a message via Yahoo to helmincamaro
have you tried checking your speedo while moving?
__________________
Quote:
Originally Posted by BowtieBelle View Post
I so didn't want to see poor dead white mouse butthole
helmincamaro is offline   Reply With Quote
Old 11-03-2011, 01:04 PM   #5
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
Quote:
Originally Posted by helmincamaro View Post
have you tried checking your speedo while moving?


check all the other connections down there, you might have unplugged something else by accident.
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-03-2011, 02:11 PM   #6
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
Quote:
Originally Posted by helmincamaro View Post
have you tried checking your speedo while moving?
This is true. The speedometer WILL NOT move if your car is NOT moving.
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-03-2011, 02:30 PM   #7
Revo1
Don't Like it? Suggit.
 
Revo1's Avatar
 
Drives: 2010 2SS/RS
Join Date: Aug 2008
Location: Fresno, CA
Posts: 14,805
I like the turn this thread took, you guys are terrible, LOL! Way to go Paul

That said, I don't have enough knowledge to provide any viable help... Good luck, keep us posted!
__________________

"Tops off, tach up baby- loud and proud!"
A Camaro lover from day one- 1996 3.8 V6 Camaro, to 1996 5.7 LT1 Camaro Z28, to the sold 2002 5.7 LS1 Camaro SS, and NOW, a [I]6.2 L99 VR 2SS/RS: XS Power stainless full exhaust, Airaid CAI, BMR drop springs and sways, custom tune by Cal Speed- 411rwhp
Revo1 is offline   Reply With Quote
Old 11-03-2011, 02:34 PM   #8
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
maybe your exhaust ate the cable? o.O
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-03-2011, 02:38 PM   #9
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
Does the RPMs work? Gas gauge? Volts? Oil Pressure? If nothing works my bet is a fuse or maybe you forgot to plug something back in afterwards
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-03-2011, 02:52 PM   #10
vroomapunk
[COTW 5/12/14]
 
vroomapunk's Avatar
 
Drives: 2012 CRT NF Cammed 2SS/RS
Join Date: Oct 2011
Location: New Orleans, Louisiana
Posts: 5,384
Id say fuse. Also, the dimmer switch could possibly blow, and some dash components run through that, its actually more than just a switch, has a heat sink, etc.

Check all accessory, interior, and dimmer switch fuses
__________________
vroomapunk is offline   Reply With Quote
Old 11-03-2011, 03:53 PM   #11
ya boy willz

 
ya boy willz's Avatar
 
Drives: 2011 IOM LS, 2011 CGM LS
Join Date: Oct 2010
Location: Orlando, Fl
Posts: 836
Quote:
Originally Posted by vroomapunk View Post
Id say fuse. Also, the dimmer switch could possibly blow, and some dash components run through that, its actually more than just a switch, has a heat sink, etc.

Check all accessory, interior, and dimmer switch fuses
+1. When one of the power wires for my stereo on my eclipse blew, the doors would no longer lock automatically, the clock pod stopped working, and a few other things were affected.

Make sure you didn't blow any fuses and that you hooked up all your wires properly.
__________________
2011 IOM LS - Drag DR 19s 18x7.5, Projector/Halo Fogs, Blacked out Gills, Red Calipers, Factory Spoiler, 15% Tint

2011 CGM LS- Injen CAI, Vmax Ported TB, Vmax Black Ice O'Lator, Carbon Fiber Bowties, Carbon Fiber Gills, Factory Spoiler, Stock SS Exhaust w/ Magnaflow x-pipe welded in & stock muffler delete, Miro 112 18x8.5 +35
ya boy willz is offline   Reply With Quote
Old 11-04-2011, 10:44 AM   #12
Bulldogwinters
SS #2431
 
Bulldogwinters's Avatar
 
Drives: 2001 Pewter Camaro SS
Join Date: Jul 2009
Location: Missoula, MT
Posts: 1,224
So my dimmer fuse was blown... but for some reason that didn't fix it, but when I turn the radio off my speedo and cruise work.. Oh well, I have to cruise without tunes until Tomorrow I guess
__________________

2001 SS Lid, LT's, 3" Y to 4" Borla XR-1 dumped, LCA, LCA Brackets, Dbl. Adj. Panhard, Subframe Connectors, Shock Tower Brace, Eibach Prokit, Eddlebrock Shocks, C6 ZR1 Wheels 18x9.5
Bulldogwinters is offline   Reply With Quote
Old 11-04-2011, 12:35 PM   #13
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
Quote:
Originally Posted by Bulldogwinters View Post
So my dimmer fuse was blown... but for some reason that didn't fix it, but when I turn the radio off my speedo and cruise work.. Oh well, I have to cruise without tunes until Tomorrow I guess
you really messed up something here...
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-04-2011, 02:31 PM   #14
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
Quote:
Originally Posted by dmginc View Post
you really messed up something here...
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-04-2011, 02:44 PM   #15
Bulldogwinters
SS #2431
 
Bulldogwinters's Avatar
 
Drives: 2001 Pewter Camaro SS
Join Date: Jul 2009
Location: Missoula, MT
Posts: 1,224
Quote:
Originally Posted by dmginc View Post
you really messed up something here...
I thougt that was normal.....
__________________

2001 SS Lid, LT's, 3" Y to 4" Borla XR-1 dumped, LCA, LCA Brackets, Dbl. Adj. Panhard, Subframe Connectors, Shock Tower Brace, Eibach Prokit, Eddlebrock Shocks, C6 ZR1 Wheels 18x9.5
Bulldogwinters is offline   Reply With Quote
Old 11-04-2011, 03:44 PM   #16
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
i only turn my radio off when i hit 88mph..hey...you never know
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-04-2011, 04:56 PM   #17
xXSilencerXx
Butter Bar!
 
xXSilencerXx's Avatar
 
Drives: 2011 SS, 1998 Trans Am
Join Date: Dec 2010
Location: Patrick AFB, FL
Posts: 1,357
Did you wire with a harness or ghetto rig?
__________________
2011 Camaro SS, White/Orange, LSR Short Throw, CAI
1998 Trans Am, Red, H/C/I, 3200 CircleD Stall, full suspension
2004 GSXR 1k, Matt Mladin Edition
xXSilencerXx is offline   Reply With Quote
Old 11-04-2011, 04:58 PM   #18
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
does your stereo get louder as you accelerate? lol!
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-04-2011, 05:10 PM   #19
Bulldogwinters
SS #2431
 
Bulldogwinters's Avatar
 
Drives: 2001 Pewter Camaro SS
Join Date: Jul 2009
Location: Missoula, MT
Posts: 1,224
Quote:
Originally Posted by xXSilencerXx View Post
Did you wire with a harness or ghetto rig?
Ghetto rig.. And I'm having my buddy fix it this weekend, he used to install stereos at best buy so He'll fix it
__________________

2001 SS Lid, LT's, 3" Y to 4" Borla XR-1 dumped, LCA, LCA Brackets, Dbl. Adj. Panhard, Subframe Connectors, Shock Tower Brace, Eibach Prokit, Eddlebrock Shocks, C6 ZR1 Wheels 18x9.5
Bulldogwinters is offline   Reply With Quote
Old 11-04-2011, 06:39 PM   #20
ya boy willz

 
ya boy willz's Avatar
 
Drives: 2011 IOM LS, 2011 CGM LS
Join Date: Oct 2010
Location: Orlando, Fl
Posts: 836
Quote:
Originally Posted by Bulldogwinters View Post
Ghetto rig.. And I'm having my buddy fix it this weekend, he used to install stereos at best buy so He'll fix it
That's probably your problem. You should've just bought a $20 harness at Best Buy, hooked it up to the stereo, soldered it (or just connect them VERY well and tape them, but soldering is alot better ) and then installed it.

Hopefully when your buddy fixes it everything works fine again
__________________
2011 IOM LS - Drag DR 19s 18x7.5, Projector/Halo Fogs, Blacked out Gills, Red Calipers, Factory Spoiler, 15% Tint

2011 CGM LS- Injen CAI, Vmax Ported TB, Vmax Black Ice O'Lator, Carbon Fiber Bowties, Carbon Fiber Gills, Factory Spoiler, Stock SS Exhaust w/ Magnaflow x-pipe welded in & stock muffler delete, Miro 112 18x8.5 +35
ya boy willz is offline   Reply With Quote
Old 11-04-2011, 08:20 PM   #21
xXSilencerXx
Butter Bar!
 
xXSilencerXx's Avatar
 
Drives: 2011 SS, 1998 Trans Am
Join Date: Dec 2010
Location: Patrick AFB, FL
Posts: 1,357
Quote:
Originally Posted by ya boy willz View Post
That's probably your problem. You should've just bought a $20 harness at Best Buy, hooked it up to the stereo, soldered it (or just connect them VERY well and tape them, but soldering is alot better ) and then installed it.

Hopefully when your buddy fixes it everything works fine again
Exactly, so much cleaner and never has problems. I think I actually got the harness cheaper from Kee Audio. Solder all the corresponding colors together and it's good to go.

Hope the dude can fix it. Probably missed the orange wire or something IIRC.
__________________
2011 Camaro SS, White/Orange, LSR Short Throw, CAI
1998 Trans Am, Red, H/C/I, 3200 CircleD Stall, full suspension
2004 GSXR 1k, Matt Mladin Edition
xXSilencerXx is offline   Reply With Quote
Old 11-04-2011, 08:30 PM   #22
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
Quote:
Originally Posted by xXSilencerXx View Post
Exactly, so much cleaner and never has problems. I think I actually got the harness cheaper from Kee Audio. Solder all the corresponding colors together and it's good to go.

Hope the dude can fix it. Probably missed the orange wire or something IIRC.
I had to look up what IIRC ment
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-04-2011, 09:14 PM   #23
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,669
Quote:
Originally Posted by insidethreat07 View Post
I had to look up what IIRC ment
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights, Big Worm
Tail Light/Third Brake Light/Side Marker Tint (Charcoal), Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 11-04-2011, 09:15 PM   #24
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 13,846
Quote:
Originally Posted by dmginc View Post
__________________
2001 Camaro 3.8 V6

Silver Hockey Stripes, Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s, MT ET Drag Radials, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops.


insidethreat07 is offline   Reply With Quote
Old 11-05-2011, 10:15 PM   #25
xXSilencerXx
Butter Bar!
 
xXSilencerXx's Avatar
 
Drives: 2011 SS, 1998 Trans Am
Join Date: Dec 2010
Location: Patrick AFB, FL
Posts: 1,357
Quote:
Originally Posted by insidethreat07 View Post
I had to look up what IIRC ment

It's all good, took me forever to figure out IMO and AFAIK.
__________________
2011 Camaro SS, White/Orange, LSR Short Throw, CAI
1998 Trans Am, Red, H/C/I, 3200 CircleD Stall, full suspension
2004 GSXR 1k, Matt Mladin Edition
xXSilencerXx is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5th Gen Suspension -- The Book JusticePete Suspension / Brakes / Chassis 148 09-04-2013 02:28 PM
Instrument Panel Dont Work On Hot Days... gadgetguru4life Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 5 03-17-2011 04:15 PM
PWA "The Lounge" DGthe3 Off-topic Discussions 143815 11-06-2010 11:00 AM
*WORST DEALER WORK EVER!!!*look at what they did to my baby* 2SSmeCamaro 5th Gen Camaro SS LS LT General Discussions 111 06-15-2010 02:25 PM
FAT32 40GB Portable HD Didn't Work Embalmer Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 26 05-07-2009 12:09 AM


All times are GMT -5. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.