Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 01-04-2012, 08:55 AM   #1
TRABlackCamaroSS
 
TRABlackCamaroSS's Avatar
 
Drives: '10 Blk Camaro SS/'08 Blk Silverado
Join Date: Feb 2011
Location: OKLA
Posts: 368
CEL after catch can install

Installed a new Elite catch can on my L99 and after a day got a lean code CEL. Had the GM mech clear it but a day later came back. Anyone have the same problem after installing a catch can?
Checked all install procedures again to make sure it was installed right......
Really wanted a CC on my engine but if it will carry a CEL all the time is it worth it?
Any suggestions?
TRABlackCamaroSS is offline   Reply With Quote
Old 01-04-2012, 09:25 AM   #2
hypurone
I'm not totally useless..
 
hypurone's Avatar
 
Drives: 2010 SIM 2SS/RS A6 SC LPO Rallies
Join Date: Sep 2009
Location: Cali - NorthBay
Posts: 2,010
Send a message via AIM to hypurone Send a message via MSN to hypurone Send a message via Yahoo to hypurone
Not familiar with the Elite but the first thing that comes to mind is, are the connections correct and tight/sealed? A leak in the system will def cause probs. FWIW, I have the RX can and no probs. So you can have a CC and no CEL....

If you can't get it sorted, return it and get an RX?
__________________
"You were really flyin' when I passed you back there!" - Born on 10/05/09 MyCamaroBuildInfo
hypurone is offline   Reply With Quote
Old 01-04-2012, 09:29 AM   #3
Camaro21


 
Camaro21's Avatar
 
Drives: 2010 2SS/RS M6
Join Date: Jul 2009
Location: DFW, TX
Posts: 5,031
I had the Elite Engineering Catch can before my latest upgrades and didn't have a check engine light. Like hypurone said, make sure to check all of your hose connections and make sure that nothing else came off while installing it...

Good Luck.. BTW, do you know what the code # is?
__________________
Camaro21 is offline   Reply With Quote
Old 01-04-2012, 09:35 AM   #4
gelboy1015

 
gelboy1015's Avatar
 
Drives: '10 2SS/RS, MKIII Supras
Join Date: May 2010
Location: Houston/Tulsa
Posts: 946
As everyone has said, check your connections. This guy had a code as well that they narrowed down to the catch can having a loosened drain.

http://www.camaro5.com/forums/showthread.php?t=172698
__________________


2010 Camaro 2SS/RS
- LS3, M6. -
Build Thread/Mods List



gelboy1015 is offline   Reply With Quote
Old 01-04-2012, 10:02 AM   #5
Parag

 
Drives: 2010 camaro 2SS LS3
Join Date: Aug 2011
Location: Denver
Posts: 1,335
Did you connect a breather, because if you did it will be pulling outsude air into the crank and then back into the intake
Parag is offline   Reply With Quote
Old 01-04-2012, 10:33 AM   #6
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,066
Check the connections where it's connects up to the intake plus check the drain plug. Don't know how the drain plug is on the elite but the RX can has twist one at the bottom. If it's even slightly loose it could suck in are and cause it to be lean.

As long as the can is sealed properly and all the connections are done properly it shouldn't give you a CEL.
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal
caverman is offline   Reply With Quote
Old 01-04-2012, 10:41 AM   #7
JDP Tech

 
JDP Tech's Avatar
 
Drives: 2010 CGM Camaro 2SS/RS 429 LSX/F1X
Join Date: Aug 2011
Location: Sandy, UT
Posts: 427
Yeah, just like everybody has stated, make sure all hoses are on tight, and the cup is on tight. We've never seen any problems with the Elite can and a check engine light, unless something went wrong during install.

An Elite can does not have a drain, it allows you to remove the cup and clean it out very easily, but if the cup is not installed all the way (with the seal in place), you could have problems. Ditto on the breather, if its not one with a check valve, you may have problems there.
Did you remove your throttle body, or intake pipe during installation? Check those if so.
A lean code usually indicates there is an unmetered amount of air entering the engine, so there's got to be a leak somewhere.

Feel free to call, email, or PM us anytime!
- Jeremy
JDP Tech is offline   Reply With Quote
Old 01-04-2012, 10:52 AM   #8
PAUL SS
The Mark of Excellence
 
PAUL SS's Avatar
 
Drives: 2010 ABM 1SS RS LS3
Join Date: Jan 2009
Location: Smallest State in the Union
Posts: 8,411
is your o-ring in place?
__________________
BMR, CAI, DynoMax, Elite Eng., Hurst, Jannetty, Clear Image Headers & Hi Flow cats, Jet Hot, LSR, TSW, Vredestein
PAUL SS is offline   Reply With Quote
Old 01-04-2012, 02:03 PM   #9
SC2150
Account Suspended
 
Drives: 2012 Camaro RS, RX supercharged
Join Date: Dec 2009
Location: Bradenton, FL
Posts: 6,080
If a breather is used the OEM fresh air line needs to be removed and the barbs/fittings capped. Then, if it is just an open breather you will throw CEL light due to the unmetered excess air entering confusing the ECU as it is using the data from the MAF & the upstream O2's then it adds or subracts fuel as needed. If you add a breather that is unrestricted then this data confuses the ECU and the fuel trims will go crzy trying to compensate. The RX breather has a flow calibrated checkvalve that only allows the proper flow that the ECU can adjust to. So that may be your issue.
SC2150 is offline   Reply With Quote
Old 01-04-2012, 03:50 PM   #10
TRABlackCamaroSS
 
TRABlackCamaroSS's Avatar
 
Drives: '10 Blk Camaro SS/'08 Blk Silverado
Join Date: Feb 2011
Location: OKLA
Posts: 368
Thanks everyone for the good info! will reinstall and check connections along with the CC seal.
TRABlackCamaroSS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Catch Can Driver Side larryt1026 Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 32 02-02-2012 06:20 PM
Elite Catch Can Install Smirnoff Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 8 12-22-2011 02:50 PM
Catch can install and error code NateSS Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 12 03-03-2011 06:03 PM
C.A.I. install and Elite Engeneering Catch Can install Brianskeet Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 16 02-24-2011 01:40 AM
Catch Can Install.... Rage Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 6 08-02-2010 11:15 PM


All times are GMT -5. The time now is 06:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.