Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Closed Thread
 
Thread Tools
Old 04-26-2009, 10:05 PM   #26
69 rs/ss
 
69 rs/ss's Avatar
 
Drives: 1969 rs/ss & 2010 L99 #3747 4/28/09
Join Date: Oct 2008
Location: Albion, NY
Posts: 326
Quote:
Originally Posted by Bumleb View Post
With less than 40 miles on my new 2010 Camaro 2SS , she broke already. Sad, but true. Not that I've wanted this car for 14 years or that I've wanted this particular car for over 2 years. Finally got one and barely got 20 minutes of driving time in. It just quit. We think it's an electrical problem. Help.... I can't find anything online about the car having any problems. It's so new..... Thankfully my husband was driving the car at the time, only going about 3-5 miles per hour, cruising through a parking lot. The car just shut down. He coasted as far as he could to be out of the way of traffic, OMG so many people saw her broke... I'm so sad about it. Keys were locked in the ignition and it wouldn't come out of gear (Park). FYI for those that have this happen to them. In the Owners Manual on page 8-23, Shift Lock Manual Release. If it weren't for me having the owners manual the tow truck driver may have drug my car onto the flat bed. With the car in gear the back wheels were locked. Drag it up the flat bed. Boy did my stomach hit the pavement when he suggested that. Needless to say the tow truck company stored my baby overnight, for her windows were down and the keys were in the ignition, I didn't want to have her sit outside the dealerships service department. She's there now and awaiting the fine knowledge of Chevrolets, hopefully, highly trained technicians. I hope to have her back real soon. Kinda like a tease ya know...... Sucks majorly...
I think it sounds like an electrical problem. May be something simple. Good luck.
69 rs/ss is offline  
Old 04-26-2009, 10:13 PM   #27
BackinBlackSS/RS
Go Blue!!!!!
 
BackinBlackSS/RS's Avatar
 
Drives: 2012 Cruze LT
Join Date: Mar 2009
Location: Indiana
Posts: 23,369
Same thing happened to my new Solstice a couple of years ago. Coudn't get key out, etc. Battery was bad. Got new battery. Never had a problem again. I got almost 200 miles on my new SS/RS. Running like a champ.
BackinBlackSS/RS is offline  
Old 04-26-2009, 10:15 PM   #28
Blue Joe
 
Drives: 2010 IBM/1SS
Join Date: Apr 2009
Location: Florida
Posts: 216
That is what happens when security shuts it down. Bad modules have happened on GM models the past couple yrs.They need to check manufactures on those modules.Getting too common.
Blue Joe is offline  
Old 04-26-2009, 10:18 PM   #29
lnsjr1
 
Drives: 02'Z28 07'CTS 03'HD Fatboy
Join Date: Apr 2009
Location: Glassboro, NJ
Posts: 270
Sorry

Quote:
Originally Posted by OUR72GTO View Post
You got past him.......... with yours 2 minutes apart.
My cpu locked up (I am @ work) Did not know if it posted or not..I promise it will never happen again...
lnsjr1 is offline  
Old 04-26-2009, 10:18 PM   #30
UHP-CAMARO
 
UHP-CAMARO's Avatar
 
Drives: Traded this for a 2013 ZL1
Join Date: Aug 2008
Location: Utah
Posts: 135
I also hope that it turns out to be something simple. Good Luck with it.

Kind of reminds me what happened to me when I picked up my 2002 from Young Chevrolet Fleet sales. The sales rep said here you go we made you a 3rd set of keys. So I walk out to the Camaro with 3 sets of keys in my hand. I open the car and go to start it and nothing. The camaro was DOA with the security system locked up. The real keys wouldn't work ether.

I was getting pretty bummed out. Turned out they put the wrong security chip on the 3rd set. Just glad I was at the dealership and not somewhere else.
UHP-CAMARO is offline  
Old 04-26-2009, 10:22 PM   #31
Tachometer
Body by Fisher
 
Tachometer's Avatar
 
Drives: 1972 Buick Skylark 350 Sport Coupe
Join Date: Feb 2009
Location: Medina, O.
Posts: 24
That's why NEW cars come with a warranty!
__________________
Buy AMERICAN!

"FASTER than most, SLOWER than some"
Tachometer is offline  
Old 04-26-2009, 10:26 PM   #32
SIK07GTSTANG
Team Fordpower
 
SIK07GTSTANG's Avatar
 
Drives: 2007 Mustang GT
Join Date: Dec 2008
Location: Purcellville, VA
Posts: 350
Wow that really sucks, I hope it's an isolated incident. Having said that I can't help but notice the irony...Found On Road Dead huh?
SIK07GTSTANG is offline  
Old 04-26-2009, 10:28 PM   #33
shevyman

 
Drives: 2010 Camaro SS IOM
Join Date: Feb 2009
Location: california
Posts: 1,741
ok sorry but have to laugh i always talked shit about chevy and ford not lasting and hearing the new camaro break down is funny cause even though i am buying one that is what i said watch i am going to get it and its going to break down after i leave. so i guess its a good thing mine is going to be a show car wont have to rely on it thats what toyotas for lol. its probably cause they rushed and some things were not done right but so far its the only one i have heard had problems. again i am sorry
shevyman is offline  
Old 04-26-2009, 10:32 PM   #34
CommandoSS
 
Drives: 05 Chevy Avalanche, 67 Camaro
Join Date: Oct 2008
Location: NJ
Posts: 132
Quote:
Originally Posted by Bumleb View Post
With less than 40 miles on my new 2010 Camaro 2SS , she broke already. Sad, but true. Not that I've wanted this car for 14 years or that I've wanted this particular car for over 2 years. Finally got one and barely got 20 minutes of driving time in. It just quit. We think it's an electrical problem. Help.... I can't find anything online about the car having any problems. It's so new..... Thankfully my husband was driving the car at the time, only going about 3-5 miles per hour, cruising through a parking lot. The car just shut down. He coasted as far as he could to be out of the way of traffic, OMG so many people saw her broke... I'm so sad about it. Keys were locked in the ignition and it wouldn't come out of gear (Park). FYI for those that have this happen to them. In the Owners Manual on page 8-23, Shift Lock Manual Release. If it weren't for me having the owners manual the tow truck driver may have drug my car onto the flat bed. With the car in gear the back wheels were locked. Drag it up the flat bed. Boy did my stomach hit the pavement when he suggested that. Needless to say the tow truck company stored my baby overnight, for her windows were down and the keys were in the ignition, I didn't want to have her sit outside the dealerships service department. She's there now and awaiting the fine knowledge of Chevrolets, hopefully, highly trained technicians. I hope to have her back real soon. Kinda like a tease ya know...... Sucks majorly...
That's horrible. Sorry to hear it

I agree with what others have said - sounds like electrical issue. Something caused the car to just shut off - maybe to protect itself?

I hope it gets fixed quickly.
__________________
CommandoSS is offline  
Old 04-26-2009, 10:32 PM   #35
Blue Joe
 
Drives: 2010 IBM/1SS
Join Date: Apr 2009
Location: Florida
Posts: 216
Its no big deal.Security locked it up.It happens.Just be glad it has a good security system unlike toyotas.
Blue Joe is offline  
Old 04-26-2009, 10:46 PM   #36
DevilKnightFalcon

 
DevilKnightFalcon's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Feb 2009
Location: Phoenix, AZ
Posts: 1,406
Send a message via AIM to DevilKnightFalcon Send a message via Yahoo to DevilKnightFalcon
Are we sure this guy isn't just screwing with us? His first posts on the board are stuff saying that his brand new Camaro broke down....idk just kinda seems a little fishy. Not saying it is impossible but I would like to see some pics of his ride. If he has his car already then it means that he was produced very early...I kinda doubt this would have made it through the quality control hold on the early vehicles....
__________________

MBRP Catback/Magnaflow Resonated X/Airraid V2 CAI/Dash ABL/Interior LEDs/Custom Paint/Jet Coated American Racing LT Headers/High Flow cats/Trifecta Tune
DevilKnightFalcon is offline  
Old 04-26-2009, 10:50 PM   #37
franknbeans
Whipped
 
franknbeans's Avatar
 
Drives: 2010 CAMARO
Join Date: Sep 2008
Location: Pittsburgh-ish - PA
Posts: 4,083
I'm calling TROLL
__________________
The "ManCard"

franknbeans is offline  
Old 04-26-2009, 10:52 PM   #38
DevilKnightFalcon

 
DevilKnightFalcon's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Feb 2009
Location: Phoenix, AZ
Posts: 1,406
Send a message via AIM to DevilKnightFalcon Send a message via Yahoo to DevilKnightFalcon
I think this thread should be locked unless there is some kind of proof that this guy even owns a Camaro.
__________________

MBRP Catback/Magnaflow Resonated X/Airraid V2 CAI/Dash ABL/Interior LEDs/Custom Paint/Jet Coated American Racing LT Headers/High Flow cats/Trifecta Tune
DevilKnightFalcon is offline  
Old 04-26-2009, 10:54 PM   #39
FxsX24
 
FxsX24's Avatar
 
Drives: S10 283 V8,Jimmy 4wd 4dr bk/bk
Join Date: Dec 2008
Location: Verona NY
Posts: 307
im calling BS on this topic

no vin, no info on what the car's package is

first post about it being broken? i would have been posting here before that


my guess is that somebody layed the smackdown on a mustang, and that is the OP who got beat by the mighty Camaro
FxsX24 is offline  
Old 04-26-2009, 10:59 PM   #40
francone13
 
francone13's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Nov 2008
Location: Toronto
Posts: 280
Im sorry but im having trouble believing this guy..First post he writes is "my Camaro broke down" how bout showing us some pics and vin?
francone13 is offline  
Old 04-26-2009, 11:00 PM   #41
2Scoops
 
2Scoops's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2009
Location: Aloha, Oregon
Posts: 374
Quote:
Originally Posted by DevilKnightFalcon View Post
Are we sure this guy isn't just screwing with us? His first posts on the board are stuff saying that his brand new Camaro broke down....idk just kinda seems a little fishy. Not saying it is impossible but I would like to see some pics of his ride. If he has his car already then it means that he was produced very early...I kinda doubt this would have made it through the quality control hold on the early vehicles....
I also am skeptical, but I'm not into accusations. If there really IS a problem than it's important that we all got the word... Isn't that what these forums are about??? To share knowledge of our beloved Camaro?

However, I will sit here and until there is a response from the OP
__________________
SGT Earl D. Werner - 28AUG2009, KIA, Ramadi, Iraq
SPC Taylor D. Marks - 28AUG2009, KIA, Ramadi, Iraq
CPT Bruno DeSollenni - 20SEP2008, KIA, Kandahar, Afghanistan
Rest in peace my Brothers.


2SS/RS MN6, Cyber Grey Metallic w/ Black Rally Stripes


http://twoscoopscamaro5.mybrute.com
2Scoops is offline  
Old 04-26-2009, 11:00 PM   #42
stovt001


 
stovt001's Avatar
 
Drives: 2006 Cobalt, 2004 Taurus wagon
Join Date: Oct 2007
Location: California
Posts: 3,817
Quote:
Originally Posted by DkknightX View Post
So much for quality control and quality assurance being used for the endless delays on this car. Time to think of another reason to justify more waiting by the public. For a touring car, it would sure suck to be afraid to take it out of your home city let alone cross country driving. Wow.
OK, so the mismatched front fascia paint tones, temporary weights on the Brembo brakes, and poor interior trim fit (later corrected) on the earliest Camaros are pretty normal early build issues, the reasons I wouldn't buy a first model year car and the kinds of things early buyers should know going in to this. But this problem is at an entirely different level. That's a quality/reliability issue, period. This has me very, very concerned. Wow, to just shut down in the middle of a parking lot, in front of so many people. Yup, GM, that's the way to change perceptions.
__________________
"It's kind of fun to do the impossible" - Walt Disney

There's a great big beautiful tomorrow
shining at the end of every day
There's a great big beautiful tomorrow
Just a dream away
stovt001 is offline  
Old 04-26-2009, 11:00 PM   #43
Bumleb
 
Bumleb's Avatar
 
Drives: 2010 Camaro 2SS Rally Yellow
Join Date: Apr 2009
Location: Lemoore
Posts: 41
Pic's of my baby

Here are some pictures.
Attached Images
   
Bumleb is offline  
Old 04-26-2009, 11:03 PM   #44
DevilKnightFalcon

 
DevilKnightFalcon's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Feb 2009
Location: Phoenix, AZ
Posts: 1,406
Send a message via AIM to DevilKnightFalcon Send a message via Yahoo to DevilKnightFalcon
Quote:
Originally Posted by Bumleb View Post
Here are some pictures.
Interesting that not a single one of those pics is taken outside of a dealership...come on man.
__________________

MBRP Catback/Magnaflow Resonated X/Airraid V2 CAI/Dash ABL/Interior LEDs/Custom Paint/Jet Coated American Racing LT Headers/High Flow cats/Trifecta Tune
DevilKnightFalcon is offline  
Old 04-26-2009, 11:05 PM   #45
FxsX24
 
FxsX24's Avatar
 
Drives: S10 283 V8,Jimmy 4wd 4dr bk/bk
Join Date: Dec 2008
Location: Verona NY
Posts: 307
maybe it is something really stupid ( bad PDI?????), i doubt this is a widespread issue (such as batt cables or something, not with this much testing, and so little mileage on the car to wear through a cable)
FxsX24 is offline  
Old 04-26-2009, 11:05 PM   #46
DevilKnightFalcon

 
DevilKnightFalcon's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Feb 2009
Location: Phoenix, AZ
Posts: 1,406
Send a message via AIM to DevilKnightFalcon Send a message via Yahoo to DevilKnightFalcon
Quote:
Originally Posted by stovt001 View Post
OK, so the mismatched front fascia paint tones, temporary weights on the Brembo brakes, and poor interior trim fit (later corrected) on the earliest Camaros are pretty normal early build issues, the reasons I wouldn't buy a first model year car and the kinds of things early buyers should know going in to this. But this problem is at an entirely different level. That's a quality/reliability issue, period. This has me very, very concerned. Wow, to just shut down in the middle of a parking lot, in front of so many people. Yup, GM, that's the way to change perceptions.
Yes, first year bugs are common. However a car randomly shutting down is not what I would consider a "bug". This car is based almost entirely on pieces from other cars...there really shouldn't be many of these first year issues. With that said I still don't believe the OP until I see some proof.
__________________

MBRP Catback/Magnaflow Resonated X/Airraid V2 CAI/Dash ABL/Interior LEDs/Custom Paint/Jet Coated American Racing LT Headers/High Flow cats/Trifecta Tune
DevilKnightFalcon is offline  
Old 04-26-2009, 11:07 PM   #47
DkknightX
Account Suspended
 
Drives: 2006 Chevrolet Cobalt SS/SC Stage 2
Join Date: Dec 2008
Location: Emerson, NJ
Posts: 1,394
Uhhh.....I don't think she's trolling.....I was thinking that myself but to post it like 4 times sounds more a desperate attempt to warn us, but what do I know. I know this kind of thing isn't uncommon. Hell, I had to jumpstart a brand spanking new Honda Accord that stalled and wouldn't start at an intersection. The part that bothers me is the hold up seemed like it was more for marketing purposes than it was for actual quality control. Almost like it was an intentional stall for the dealer rollout of the car. My heart goes to this woman and I would be devestated if that were my car. I'll bet dollars to law enforcement donuts that the technicians there will need at least a week to cross reference mechanical data to diagnose the problem. I'm taking bets and not happy about it either.
DkknightX is offline  
Old 04-26-2009, 11:07 PM   #48
stovt001


 
stovt001's Avatar
 
Drives: 2006 Cobalt, 2004 Taurus wagon
Join Date: Oct 2007
Location: California
Posts: 3,817
Quote:
Originally Posted by 69 rs/ss View Post
I think it sounds like an electrical problem. May be something simple. Good luck.
Heh, maybe it is just me, but I find it difficult to put "electrical problem" and "simple" in the same sentence. Those kinds of things always seem the most difficult to diagnose. True, the fix can be simple, but finding the source will make you want to rip your hair out.

I didn't think that this could be a prank. I mean, it is entirely plausible that someone who isn't a member here did indeed already get a Camaro. If I got a new car and it broke and I joined a forum to let people know about it, posting pics and VIN would be the last thing on my mind, but maybe that is just me. But man, imagine if it is some import fanboy trying to troll. How sad would that be? I don't even want to consider that possibility. Assuming the Camaro has an electrical problem is less depressing.
__________________
"It's kind of fun to do the impossible" - Walt Disney

There's a great big beautiful tomorrow
shining at the end of every day
There's a great big beautiful tomorrow
Just a dream away
stovt001 is offline  
Old 04-26-2009, 11:08 PM   #49
CommandoSS
 
Drives: 05 Chevy Avalanche, 67 Camaro
Join Date: Oct 2008
Location: NJ
Posts: 132
Quote:
Originally Posted by DevilKnightFalcon View Post
Interesting that not a single one of those pics is taken outside of a dealership...come on man.
What are you talking about? The pic of the camaro on the flat bed looks like it's outside of the dealership.
__________________
CommandoSS is offline  
Old 04-26-2009, 11:08 PM   #50
SIK07GTSTANG
Team Fordpower
 
SIK07GTSTANG's Avatar
 
Drives: 2007 Mustang GT
Join Date: Dec 2008
Location: Purcellville, VA
Posts: 350
Quote:
Originally Posted by DevilKnightFalcon View Post
Interesting that not a single one of those pics is taken outside of a dealership...come on man.
Right, so the 2010 Camaro on a tow truck isn't outside a dealership? Stop whining.
SIK07GTSTANG is offline  
 
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 47 02-19-2014 03:23 PM
Official Camaro Convertible CONCEPT Press Release Tran Camaro Convertible Forum 12 11-18-2009 07:05 PM
2010 Camaro Silver SS/RS Barrett Jackson Photos camaro5 Camaro Photos | Spyshots | Video | Media Gallery 43 06-03-2009 08:40 PM
Official Camaro Options & Standard Equipment for all Trim Levels headpunter Camaro Price | Ordering | Tracking | Dealers Discussions 300 02-18-2009 12:23 AM
2010 Stang vs Camaro (seems unbiased) MerF 5th Gen Camaro SS LS LT General Discussions 17 02-09-2009 10:11 AM


All times are GMT -5. The time now is 01:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.