Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HRE Wheels
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 03-06-2012, 06:24 PM   #1
2011 SS
 
2011 SS's Avatar
 
Drives: 2011 SS M6, LT's, CAI, SLP LM II's.
Join Date: Oct 2011
Location: Ok
Posts: 196
Normal oil pressure

are these readings normal at idle

Sent from my SPH-D710 using Tapatalk
2011 SS is offline   Reply With Quote
Old 03-06-2012, 07:21 PM   #2
p3jason
Allergic to stupid.
 
p3jason's Avatar
 
Drives: 2015 ZL1 #957 M6 AGM & 1990 Z24
Join Date: Aug 2010
Location: Jacksonville, FL
Posts: 344
Send a message via Yahoo to p3jason
No problem there.
__________________
p3jason is offline   Reply With Quote
Old 03-06-2012, 07:33 PM   #3
nomadicdogg

 
Drives: '10 2SS/RS Cyber Grey Camaro (sold)
Join Date: Nov 2010
Location: Western, PA
Posts: 1,773
I have since day one and still think my oil pressure is to low in my M6 SS.
I dont like anything below 40, especially in a brand new car.
I dont know if its the synthetic or by design but it bugs me everytime I see how low it is.
but your readings are on par with what Im used to in mine
nomadicdogg is offline   Reply With Quote
Old 03-06-2012, 07:46 PM   #4
HDRDTD


 
Drives: 2013 Triple Black ZL1 Vert M6 ECF
Join Date: Mar 2011
Location: Trenton, Michigan
Posts: 5,283
Normal
HDRDTD is online now   Reply With Quote
Old 03-06-2012, 07:49 PM   #5
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,763
Mine reads the same. For some reason I think the L99 has higher oil pressure
bajamoon is offline   Reply With Quote
Old 03-06-2012, 07:51 PM   #6
ChriSS
 
ChriSS's Avatar
 
Drives: Camaro 2SS/RS M6 Black and IOM
Join Date: Sep 2011
Location: Deep South Texas
Posts: 107
That's about normal on my 2SS M6 goes higher when u punch it
ChriSS is offline   Reply With Quote
Old 03-06-2012, 07:58 PM   #7
One-Bad-ZL1
So easy to love Camaros
 
One-Bad-ZL1's Avatar
 
Drives: 2013 ZL1 VR #3457
Join Date: Feb 2012
Location: Marlborough, CT
Posts: 3,420
Send a message via Yahoo to One-Bad-ZL1
Yup normal at idle.
__________________
One-Bad-ZL1 is offline   Reply With Quote
Old 03-06-2012, 08:06 PM   #8
BLU BY U
'69 Camaro's Rule
 
BLU BY U's Avatar
 
Drives: 2010 Aqua Blue Camaro SS/RS
Join Date: Nov 2009
Location: Camaro Land
Posts: 410
That's where mine is at, when idling, and at temperature. But, I swear it use to be at 30 when idling.
__________________
BLU BY U is offline   Reply With Quote
Old 03-06-2012, 08:08 PM   #9
2011 SS
 
2011 SS's Avatar
 
Drives: 2011 SS M6, LT's, CAI, SLP LM II's.
Join Date: Oct 2011
Location: Ok
Posts: 196
Quote:
Originally Posted by BLU BY U View Post
That's where mine is at, when idling, and at temperature. But, I swear it use to be at 30 when idling.

Me to coulda swore on it!
Sent from my SPH-D710 using Tapatalk
2011 SS is offline   Reply With Quote
Old 03-06-2012, 08:09 PM   #10
mhood
Orange Camaros Rule!
 
mhood's Avatar
 
Drives: 2010 1SS LS3 RS IOM
Join Date: Feb 2010
Location: Texas
Posts: 1,561
Isn't oil pressure higher when the engine is cold?
__________________

Mary - Orange Camaros Rule!
mhood is offline   Reply With Quote
Old 03-06-2012, 08:21 PM   #11
hightower
LS3 Black Widow
 
hightower's Avatar
 
Drives: 2012 45th 2SS LS3 and 1968 Mustang
Join Date: Nov 2011
Location: Madison, GA
Posts: 4,560
You're good.
__________________
hightower is offline   Reply With Quote
Old 03-06-2012, 09:20 PM   #12
BLU BY U
'69 Camaro's Rule
 
BLU BY U's Avatar
 
Drives: 2010 Aqua Blue Camaro SS/RS
Join Date: Nov 2009
Location: Camaro Land
Posts: 410
Quote:
Originally Posted by mhood View Post
Isn't oil pressure higher when the engine is cold?
That's correct, but, I thought mine was at 30 when it was up to temp.
__________________
BLU BY U is offline   Reply With Quote
Old 03-06-2012, 09:26 PM   #13
BLU BY U
'69 Camaro's Rule
 
BLU BY U's Avatar
 
Drives: 2010 Aqua Blue Camaro SS/RS
Join Date: Nov 2009
Location: Camaro Land
Posts: 410
Quote:
Originally Posted by 2011 SS View Post
Me to coulda swore on it!
Sent from my SPH-D710 using Tapatalk
It's seems like mine was at 30 idling before I did my oil change a week and a half ago.
__________________
BLU BY U is offline   Reply With Quote
Old 03-06-2012, 10:07 PM   #14
Coyotekiller
Account Suspended
 
Drives: 2012 AGM 2SS
Join Date: Feb 2012
Location: Beaufort, NC
Posts: 1,383
When I start mine cold, it spikes to about 60psi then gradually warms up and the pressure comes down to about 25psi once the engine is above 200*.

The console gauges are kinda misleading as to actual readings because they only show a few numerical graduations each. Like the voltmeter. Goes from I believe 6 to 12 to 19, all being equal distance apart. The temp gauge is graduated correctly and easily but the others are just odd.
Coyotekiller is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
best synthetic oil to use hollywoodjose Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 130 01-26-2014 08:51 AM
How to change your oil in V6 trooper182 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 20 12-16-2012 06:08 AM
AFM turned off by my dealer???? fastfreddie 5th Gen Camaro SS LS LT General Discussions 95 08-25-2012 02:55 PM
What kind of oil pump should I install? jeffny09 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 73 06-19-2012 05:06 AM


All times are GMT -5. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.