Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 03-16-2012, 03:21 PM   #1
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Clutch fluid leaking, pooling up slowly in husky mats!

Taking to dealer on Monday. Anyone else experience this? Can it be causing damage while driving? Is this linked to my break fluid, this affecting stopping?
jsherm007 is offline   Reply With Quote
Old 03-16-2012, 03:35 PM   #2
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
Check the master cylinder level. Both the clutch and brakes operate from the master. Haven`t heard of this happening before. Definitely take it in to get fixed. I know there have been problems with the cap leaking on the master.
__________________
Bo Tie 1 is offline   Reply With Quote
Old 03-16-2012, 03:42 PM   #3
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
Hey you want to be careful about not getting any brake fluid on any painted surfaces.
It will eat the paint. In case you didn`t know.
__________________
Bo Tie 1 is offline   Reply With Quote
Old 03-16-2012, 05:32 PM   #4
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Here are some pics of what I am seeing:





jsherm007 is offline   Reply With Quote
Old 03-16-2012, 05:45 PM   #5
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
Wow that is some major leak. I dont think i would be driving it.
Have you checked the fluid level?
__________________
Bo Tie 1 is offline   Reply With Quote
Old 03-16-2012, 05:49 PM   #6
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
I just took it to dealer today, on way home from picking up daughter at preschool. Got ride home with their curtsey shuttle. I didn't want to drive it like you said, and no point to drive home (past dealer) then park it all weekend, and drive back to dealer. So they have it and can do what they need to do Monday morning.

Now I have to drive my 02 vette all weekend :(
jsherm007 is offline   Reply With Quote
Old 03-16-2012, 05:50 PM   #7
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Actually what really sucks is my FARK came today, and I have all my audio stuff, and no car to install it in!
jsherm007 is offline   Reply With Quote
Old 03-16-2012, 05:55 PM   #8
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
Iam sure they will get you all fixed up and back on the road.
At least you have another awesome car to drive. Good Luck!
__________________
Bo Tie 1 is offline   Reply With Quote
Old 03-17-2012, 12:31 AM   #9
LimaCharlie


 
LimaCharlie's Avatar
 
Drives: 2011 Camaro SS/RS - 2004 Silverado
Join Date: Mar 2010
Location: Tucson, AZ
Posts: 2,602
Wow. How long has it been leaking? It looks like it has been for a while.
__________________
2011 Summit White Camaro 1SS/RS
-6.2 LS3, TR6060, 3.45, G80

2004 Black Silverado 1500 2WD Regular Cab, Short Bed
-5.3 LM7, 4L60E, 3.42, G80
LimaCharlie is offline   Reply With Quote
Old 03-17-2012, 06:52 AM   #10
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
It had a little drip Wed, that I though was just condensation cause weather here in MN is unusually warm and humid... Then Friday it let loose!
jsherm007 is offline   Reply With Quote
Old 03-19-2012, 08:58 AM   #11
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Update: dealer had to order a new clutch slave cylinder. Part not available till tomorrow.
jsherm007 is offline   Reply With Quote
Old 03-20-2012, 05:36 PM   #12
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Dealer couldn't 'get to my car today' because for some reason by 1p the 'technician had gone home'

Are you freaking kidding me? Never had a dealer give me that excuse before. So 'tomorrow by noon' they should have my car done.... ugh.
jsherm007 is offline   Reply With Quote
Old 03-20-2012, 05:47 PM   #13
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
Man that sucks! Hope they fix you up tomorrow.
__________________
Bo Tie 1 is offline   Reply With Quote
Old 03-21-2012, 10:12 AM   #14
jsherm007
Always drop the top
 
jsherm007's Avatar
 
Drives: 2014 Stingray Vert 2LT z51
Join Date: Feb 2012
Location: Jacksonville, FL
Posts: 158
Sooooo...Leak fixed! Apparently fluid didn't drip behind mat!

However, I did mention to them a shake in the steering wheel as well... Turns out both front tires were 'egg shaped' on the balancer. So they had to order 2 new 20" tires for me. I should get the car back tomorrow! That will be the 7th day without my car! But glad the dealer is being thorough!
jsherm007 is offline   Reply With Quote
Old 03-21-2012, 04:30 PM   #15
Bo Tie 1
 
Bo Tie 1's Avatar
 
Drives: 11 Camaro SS,05 Vette Z51,76 Camaro
Join Date: Feb 2011
Location: Joliet, IL
Posts: 369
At least they are taking care of you. I bet you will be putting some miles on it this weekend LOL.
__________________
Bo Tie 1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you think that the car needs a separate Clutch Fluid reservoir 2SSRS@Gen5diy V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 611 07-08-2014 01:15 PM
Understanding Brake Fluid: DOT 3, DOT 4, DOT 5.1 TAG UR IT Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 46 08-27-2013 12:08 PM
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 10:40 PM
Clutch "Sticking" Issue - Not Clutch Dust - Not Boiling Fluid Embalmer Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 1 09-11-2009 09:52 AM


All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.