Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nickey Chicago
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 03-18-2012, 09:45 AM   #1
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
Light pink fluid under my car!

I drove my car for the 1st time since October. I went for maybe a 3 mile cruise, When i got home i noticed what seem to be moisture under my car I ignored it. When i went out to move my vehicle today, there was a small soft ball size puddle of light pink fluid. Anyone have any ideas, Has this happened to anyone???? BTW my car only has 4213 miles on it.
Kevinshawnm is offline   Reply With Quote
Old 03-18-2012, 09:49 AM   #2
CFD



 
Drives: 2SS/RS L99 BLACK
Join Date: Apr 2010
Location: MASS.
Posts: 4,878
Quote:
Originally Posted by Kevinshawnm View Post
I drove my car for the 1st time since October. I went for maybe a 3 mile cruise, When i got home i noticed what seem to be moisture under my car I ignored it. When i went out to move my vehicle today, there was a small soft ball size puddle of light pink fluid. Anyone have any ideas, Has this happened to anyone???? BTW my car only has 4213 miles on it.
Sounds like coolant. Was it under the radiator or more under the engine?
CFD is online now   Reply With Quote
Old 03-18-2012, 09:53 AM   #3
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
About the middle of the engine.
Kevinshawnm is offline   Reply With Quote
Old 03-18-2012, 10:05 AM   #4
CFD



 
Drives: 2SS/RS L99 BLACK
Join Date: Apr 2010
Location: MASS.
Posts: 4,878
Quote:
Originally Posted by Kevinshawnm View Post
About the middle of the engine.
On the drivers side about mid engine is the temp sending unit, they have been known to leak. Perhaps take a quick look at that
CFD is online now   Reply With Quote
Old 03-18-2012, 10:07 AM   #5
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
Ok Thanks.
Kevinshawnm is offline   Reply With Quote
Old 03-18-2012, 10:40 AM   #6
ToolFan66

 
ToolFan66's Avatar
 
Drives: 2011 2SS 6.2L W/RS package
Join Date: Jan 2011
Location: Colorado
Posts: 2,146
This happened to me as well, it is coolant CFD has you on the right track..
ToolFan66 is offline   Reply With Quote
Old 03-18-2012, 12:06 PM   #7
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
Ok cool.
Kevinshawnm is offline   Reply With Quote
Old 03-19-2012, 02:32 PM   #8
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
Theyre now saying they cant find a leak! Any advice?
Kevinshawnm is offline   Reply With Quote
Old 04-30-2012, 05:40 PM   #9
fargomike
The Dude Abides
 
fargomike's Avatar
 
Drives: Black 2SS M6
Join Date: Apr 2010
Location: Fargo , ND
Posts: 490
I have same issue, where would I look ?
__________________
2010 Black 2SS/LS3/M6 Kooks 1 7/8 Ceramic Coated Headers, Borla ATAK CB , JRE Tune , Halltech Yellow Jacket CAI ,VMax Ported TB, PFADT Coilovers,Forgestar CF5's Textured Gunmetal w/Nitto Invo's 275/315 ,Hurst Billet Plus 2 Shifter AAC P13W Plasma LEDw/DRL Harness ,30% Tinting,
fargomike is offline   Reply With Quote
Old 05-08-2012, 11:52 PM   #10
Sarge742
 
Drives: 2010 Victory Red RS/2LT
Join Date: Sep 2011
Location: Henderson, NV
Posts: 4
Your heater core is probably gone bad. If your windshield has fogged up under dry conditions, have drops of fluid on your passenger side floor board then I would bet money that the heater core is/has gone out. The exact same thing happened to me. It took them 2 weeks, a dash pull, a new windshield, and serious carpet cleaning to get her back up and running. Have them do a pressure check on your system and they will be able to detect it that way. Good luck, and see the other posts "Heater Core Gone Bad"
Sarge742 is offline   Reply With Quote
Old 05-09-2012, 07:23 AM   #11
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 526
There are a bunch of places where coolant can leak from. As strange as this may sound, check the coolant lines near the oil cooler on the drivers side of the engine. Check all the hose entry and exit points on the motor as well. Given the location you've provided, these are the logical first places to look.

One other thing to consider. I have heard of a few of the SS cars boiling over after use. Did you happen to hear a boiling water sound near the grill? This may account for the dealer saying they cannot find a leak. Give the coolant level a check just to rule this out.

I don't think your heater core is bad. You would instantly know because of the coolant smell inside the car and the soaked carpet on the passenger floor.
Hannibal is offline   Reply With Quote
Old 05-09-2012, 07:34 AM   #12
MikeSS18
 
Drives: Red Jewel 2ss
Join Date: Apr 2011
Location: Massachusetts
Posts: 26
Did you install a K&N filter? I no longer have mine but shortly after installing it I had a similar puddle- it was the oil from the filter.
MikeSS18 is offline   Reply With Quote
Old 05-10-2014, 04:13 AM   #13
Kevinshawnm
Biggz
 
Drives: 2010 Camaro 2SS L99 Rally Yellow
Join Date: Jul 2011
Location: Richmond, Indiana
Posts: 556
I had this fixed almost 2years ago, now the problem has returned. I just hit 23,000 miles, am I still covered warranty wise?
Kevinshawnm is offline   Reply With Quote
Old 05-10-2014, 08:10 AM   #14
RobertRS

 
RobertRS's Avatar
 
Drives: 2014 2SS L99
Join Date: Mar 2014
Location: Corpus Christi Texas
Posts: 1,273
Quote:
Originally Posted by Kevinshawnm View Post
I had this fixed almost 2years ago, now the problem has returned. I just hit 23,000 miles, am I still covered warranty wise?
What exactly did you have fixed?
RobertRS is offline   Reply With Quote
Old 05-10-2014, 07:03 PM   #15
Avenging Orange

 
Avenging Orange's Avatar
 
Drives: 2010 Inferno Orange 2SS/RS
Join Date: Apr 2010
Location: Clermont, IN
Posts: 1,109
There is/was a tsb for oil cooler coolant leak. Look on the engine block on drivers side...bout 1/4 north of the tranny. There is a fitting on the block that tends to leak on the 2010 models. You'll prob see where coolant has leaked down the side of the block. Any good dealer should be aware of the tsb and get you fixed up free of charge. Good luck
__________________
2010 Inferno Orange 2SS/RS M6 Black Leather,Sun Roof, OBX Headers, Haltech CAI , non synthetic fluids, Mike Norris tuned 419/413
Avenging Orange: 36 years of not buying into the Hype........and damn proud of it!!
Avenging Orange is offline   Reply With Quote
Old 05-10-2014, 09:29 PM   #16
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,735
Hi Kevinshawnm,

We'd be happy to discuss your concerns further. Please reach out to us via PM with your VIN. We look forward to hearing from you.

Thank you,

Andraya R. (assisting William)
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
White Camaro ZL1 with Automatic Transmission... First Pics... BeckyD@RodgersChevrolet Camaro ZL1 Forum - ZL1 Specific Topics 182 08-12-2011 09:13 AM
Just for fun take a walk down memory lane Beandip2811 General Automotive + Other Cars Discussion 15 08-09-2009 09:26 AM
2010 Chevy Camaro SS Indy 500 Pace Car Drive linkwpc Camaro Photos | Spyshots | Video | Media Gallery 0 05-23-2009 09:47 PM


All times are GMT -5. The time now is 02:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.