Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-09-2012, 04:51 AM   #1
J666
 
Drives: Camaro
Join Date: Mar 2012
Location: Lower Mainland
Posts: 318
License Plate Lights Not Working Sometimes?

I have noticed that my lights will randomly stop working. I have to kick the housing lightly with my shoe, and it turns on. I have LED lights on order, so hopefully this stops once they're installed.

Anybody else ever have this issue? I did replace the bulbs a while back, and they are in tight.
J666 is offline   Reply With Quote
Old 04-09-2012, 04:56 AM   #2
mastertypodemon
Late Night Crew
 
mastertypodemon's Avatar
 
Drives: 2010 SIM 1LT
Join Date: Jun 2010
Location: Stafford, VA [Formerly Dallas, TX]
Posts: 1,095
I'll be honest, I don't typically look at my license plate when I'm driving.
mastertypodemon is offline   Reply With Quote
Old 04-09-2012, 07:50 AM   #3
pierre777
HT5 COTW 9/3/2012
 
pierre777's Avatar
 
Drives: Cyber Bullet
Join Date: Jun 2011
Location: lebanon
Posts: 4,548
Send a message via Skype™ to pierre777
I had the same problem with my LEDs installed then I took the led out and moved the pin a little and put it back and now everything works fine.
__________________
pierre777 is offline   Reply With Quote
Old 04-09-2012, 08:27 AM   #4
cowjazz
 
Drives: 2010 2SS
Join Date: Jul 2010
Location: Frisco, TX
Posts: 155
I'm not sure if I had the same problem, but here is my story...

License plate light stopped working, a few days later I noticed a perfect circle with a dimple in the center on my bumper, and a few days after that the dimple turned brown. Turns out the housing for the light was broken, and the bulb burned through my bumper. All covered under warranty.

My point is, check out that bulb and housing before you roast a bumper cover.
cowjazz is offline   Reply With Quote
Old 04-09-2012, 08:50 AM   #5
Blue10CamaroSS
L99 V8 400 HP 6.2L
 
Blue10CamaroSS's Avatar
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Jul 2011
Location: East Brunswick, New Jersey
Posts: 2,226
Quote:
Originally Posted by cowjazz View Post
I'm not sure if I had the same problem, but here is my story...

License plate light stopped working, a few days later I noticed a perfect circle with a dimple in the center on my bumper, and a few days after that the dimple turned brown. Turns out the housing for the light was broken, and the bulb burned through my bumper. All covered under warranty.

My point is, check out that bulb and housing before you roast a bumper cover.
I had a similar issue. One of my bulbs was out so I pulled the bulb to replace it, a chunk of glass was taken out and the housing itself was melted. The two tightening tabs on the housings broke off and the bulbs were flopping around:


Got them replaced under warranty with new LED lights:
__________________
Blue10CamaroSS is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LED license plate lights IronMike Cosmetics and Lighting Modification Discussions 7 03-15-2011 12:19 AM
License Plate Lights Pulse Red GTO Cosmetics and Lighting Modification Discussions 1 03-06-2011 06:42 PM
Front License Plate The Stig USA - Mid-Atlantic 9 06-18-2010 09:58 AM
NO MORE FRONT PLATE! SUPPORT NYS Bill A09426 LT1Jeep USA - NY / NJ / PA 17 05-04-2010 09:23 PM


All times are GMT -5. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.