Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
MPD1
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-11-2012, 11:29 AM   #1
Camaro588
 
Drives: 2012 camaro LS
Join Date: Mar 2012
Location: Albany N.Y.
Posts: 140
ALIGNMENT ISSUES?

1300 miles and need an alignment, After I had the alignment done I drove to work and the damn thing still pulls left. Contacted chevy told me not to bring it to the dealer and wait to here from some other person to call me. Im just worried about ruining my tires. Or could these camaro's suffer from the worst case of road crown I have ever seen. Anyone else have any issues. I have a 2012 LS by the way. thanks in advance.
Camaro588 is offline   Reply With Quote
Old 04-11-2012, 11:47 AM   #2
DJ_BigC
Rockin' Steady
 
DJ_BigC's Avatar
 
Drives: Camaro 2SS, Z06 Vette, ATS Turbo
Join Date: Apr 2012
Location: Timmins
Posts: 154
Just a heads up, it may not be the alignment that is off, you may be experiencing something called "tire pull". Have the dealer rotate your tires as specified in your owners manual, and have them road test it and pull might be gone.

Make sure they check your front end before the alignment, a bent strut or bent suspension component from factory may not have caused a pull when you bought it but now it may be causing a pull, I highly doubt you have a component that is worn out of spec but it is possible, they should check the front end for play, make sure all your tire pressure are at spec,

If the pull is still there after the tire rotation and the front end check, have them do an alignment, if everything checks out good, your car should drive straight. Your car might not also be pulling, it may be that the steering wheel is off center causing you to think the car is pulling when you put it straight.

When you get your printout of the specs after the alignment was performed post them up and I'll let you know if they did it properly. Last time I was in Albany the roads were not that crowned, well nothing abnormal but you never know.
__________________
Eric Carrier, proud GM Technician for over 5 yrs.

2013 Cadillac ATS, Black, 2.0L Turbo, Luxury package, 20" Strada's, Pirelli Pzeros, 5% tint.

2010 Camaro 2SS Black, L99, SLP headers, GMPP axle back, K&N CAI, JRE tune, 22" Boss 337's, Nitto Invos 5% tint.

2011 Z06 Corvette Black, LS7, Borla Cat Back, 5% tint.
DJ_BigC is offline   Reply With Quote
Old 04-11-2012, 11:57 AM   #3
Camaro588
 
Drives: 2012 camaro LS
Join Date: Mar 2012
Location: Albany N.Y.
Posts: 140
Dont have the sheet, but it was off.Not by much. didnt see the sheet after it was corrected though. seems to do it more at highway speed then anything. Drove it around the parking lot at work under 40 and it was fine. Have to let them know about the tire rotation. thanks
Camaro588 is offline   Reply With Quote
Old 04-25-2012, 10:33 AM   #4
unkillsam
 
Drives: 2012 Camaro LT
Join Date: Jan 2007
Location: Springfield, PA
Posts: 95
I had the same problem. Dealer told me the alightment was off just a touch from what it is supposed to be straight from the factory.

Told me he was surprised I noticed it because it was so slight, but I did.
unkillsam is offline   Reply With Quote
Old 04-26-2012, 12:38 AM   #5
themoneypit
 
Drives: 2012 45th convertible ss ls3
Join Date: Apr 2012
Location: CT
Posts: 215
my 2010 ss was not right from day one.. i finally took it in for an alignment (which is covered free of charge for first 7500 miles) and sure enough it was "way off" according to the tech. afterwards, was perfect. just traded it in yesterday on a 2012 ss convertible, so far that one feels ok.
themoneypit is offline   Reply With Quote
Old 05-22-2012, 05:00 PM   #6
myocum2008
 
myocum2008's Avatar
 
Drives: Inferno Orange 2LT V6 2010
Join Date: Jun 2011
Location: Cedar Park, Tx
Posts: 36
Thats funny I needed a alignment and they told me it wasnt cover under the warranty.
myocum2008 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5th Gen Suspension -- The Book JusticePete Suspension / Brakes / Chassis 148 09-04-2013 02:28 PM
GM doesn't care about my clutch issues O2BQIK Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 200 07-05-2012 01:23 AM
Vibration issues jam019 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 33 09-26-2011 11:24 PM
Camaro 2010 Issues Tim's.2010.Camaro.SS Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 57 06-04-2010 09:27 AM


All times are GMT -5. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.