Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Classic Design Concepts
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 09-19-2012, 09:40 AM   #1
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
noise coming from passenger side

i have a noise coming from passenger side, it sounds like it's coming from the passenger side rear tire. almost like the break is engaging a little bit and making it squeak going down the road. It only makes noise when the Camaro is in motion and it has to warm up first before it starts. I'm going to the dealership on thursday to get it checked out but i just wanted to see if anyone had any ideas. thanks for the help.
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 10:05 AM   #2
robotfighter
 
robotfighter's Avatar
 
Drives: Black 2011 Camaro 2LS
Join Date: Nov 2011
Location: Los Angeles
Posts: 222
Dude, I think it might be your wife...
robotfighter is offline   Reply With Quote
Old 09-19-2012, 10:07 AM   #3
bstregs
 
bstregs's Avatar
 
Drives: 2010 Camaro 2SS/RS LS3
Join Date: Sep 2012
Location: DFW, TX
Posts: 71
__________________
Vararam Intake, Long tube headers, high flow cats, Flow Master Cat back exhaust, 180 degree thermostat, custom tune, high performance plugs and wires, custom strips, 2 10" Alpine subs in custom boxes, Punch 1000 Watt amp

She likes to go fast....
bstregs is offline   Reply With Quote
Old 09-19-2012, 10:08 AM   #4
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
most of the time you would be right but she wasn't in the car. LMAO!!!
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 10:20 AM   #5
cmick
corey
 
cmick's Avatar
 
Drives: 2010 ss m6
Join Date: Feb 2012
Location: detroit
Posts: 7
check the rear seatbelt , thats were mine was making the same type of noise
cmick is offline   Reply With Quote
Old 09-19-2012, 10:24 AM   #6
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
will do. thanks for the info!
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 11:10 AM   #7
rforbes

 
rforbes's Avatar
 
Drives: IOM SS/RS
Join Date: Mar 2009
Location: The Colony, Texas
Posts: 767
Quote:
Originally Posted by robotfighter View Post
Dude, I think it might be your wife...
That is funny, I dont care who you are!
rforbes is offline   Reply With Quote
Old 09-19-2012, 11:15 AM   #8
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
Quote:
Originally Posted by rforbes View Post
That is funny, I dont care who you are!

it makes me want to show her this just so i can laugh more. LMAO!!!
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 11:32 AM   #9
braggnrights
 
Drives: 2010 Camaro 2SS/RS, CGM, GFX
Join Date: Dec 2010
Location: Elizabethtown, KY
Posts: 46
Take it to your dealership. Have them run your VIN for Service orders or Recalls. I had the same problem. My original dealership was going to make the repair under the valid service order because my VIN fell within the break point. However I moved before I could get it done. When I did, the less friendly chevy dealership in Kansas was not willing to cover the cost. Needless to say I no longer go to that dealership any more.

But definitely find a good local dealership and ask them to run your VIN!
__________________
Aaron S. Bragg
CPT, MI
Fort Leavenworth, Kansas



The Screamin' Eagles, 101st Airborne Division
Currahee 2-506 Infantry
Rakkasan 1-33 Cavalry

The BIG RED ONE, 1st Infantry Division
Ramrods 2-2 Infantry
Hellfighters HHC, 3/1 IBCT
braggnrights is offline   Reply With Quote
Old 09-19-2012, 11:33 AM   #10
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
will do! thanks!!
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 11:34 AM   #11
kmarshall2121
 
kmarshall2121's Avatar
 
Drives: 2012 45th Anniversary Edition
Join Date: Aug 2012
Location: San Diego, CA
Posts: 32
please post when you find out what it is... I also have a "vibration" noise in the same location. thought it was my spoiler which all the nuts were loose, tightened them, but wasnt the culprit.
kmarshall2121 is offline   Reply With Quote
Old 09-19-2012, 11:35 AM   #12
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,613
Quote:
Originally Posted by 1WILDSScmrg View Post
i have a noise coming from passenger side, it sounds like it's coming from the passenger side rear tire. almost like the break is engaging a little bit and making it squeak going down the road. It only makes noise when the Camaro is in motion and it has to warm up first before it starts. I'm going to the dealership on thursday to get it checked out but i just wanted to see if anyone had any ideas. thanks for the help.
Definitely let us know how your service appointment goes this Thursday. We are available at your convenience if you have any questions or comments!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 09-19-2012, 11:40 AM   #13
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
good or bad, i will let you all know that the out come is.
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 11:42 AM   #14
braggnrights
 
Drives: 2010 Camaro 2SS/RS, CGM, GFX
Join Date: Dec 2010
Location: Elizabethtown, KY
Posts: 46
It was a bad design on the Brembo brake pads that were only put on a certain number of SS's. I had to do ALOT of the leg work myself to figure this out, and STILL ended up paying out of my pocket. Good Luck!
__________________
Aaron S. Bragg
CPT, MI
Fort Leavenworth, Kansas



The Screamin' Eagles, 101st Airborne Division
Currahee 2-506 Infantry
Rakkasan 1-33 Cavalry

The BIG RED ONE, 1st Infantry Division
Ramrods 2-2 Infantry
Hellfighters HHC, 3/1 IBCT
braggnrights is offline   Reply With Quote
Old 09-19-2012, 11:47 AM   #15
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
thanks! I'm sure i'll have to pay.
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 12:53 PM   #16
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
Quote:
Originally Posted by braggnrights View Post
It was a bad design on the Brembo brake pads that were only put on a certain number of SS's. I had to do ALOT of the leg work myself to figure this out, and STILL ended up paying out of my pocket. Good Luck!

how much did you shellout to get the noise to stop?
1WILDSScmrg is offline   Reply With Quote
Old 09-19-2012, 12:59 PM   #17
NYJets77

 
Drives: 2013 2LT/RS Summit White
Join Date: Feb 2011
Location: NY
Posts: 1,278
mods - please merge with the GM designers rant thread, under the title "why wasn't an ejector seat included?!".
NYJets77 is offline   Reply With Quote
Old 09-19-2012, 01:13 PM   #18
Renegade
Banned
 
Drives: Camaro SS Edition
Join Date: Mar 2012
Location: New York
Posts: 14,059
Send a message via AIM to Renegade Send a message via MSN to Renegade Send a message via Yahoo to Renegade Send a message via Skype™ to Renegade
Quote:
Originally Posted by 1WILDSScmrg View Post
it makes me want to show her this just so i can laugh more. LMAO!!!
You'll get cool points and less fightin' from her
Renegade is offline   Reply With Quote
Old 09-19-2012, 05:31 PM   #19
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
Quote:
Originally Posted by Renegade View Post
You'll get cool points and less fightin' from her
I waited until after she made dinner (good call on my part) to show her and i put a spin on it. Now she doesn't like you guy's on this site... better shape up gents/ladies! LMAO!!!
1WILDSScmrg is offline   Reply With Quote
Old 09-20-2012, 11:52 AM   #20
Torrey J
 
Torrey J's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Apr 2012
Location: Ventura, CA
Posts: 49
Any update on the trip to the dealership? Have the same problem in my 2010
Torrey J is offline   Reply With Quote
Old 09-20-2012, 11:55 AM   #21
Shuffler
God Bless Dawson
 
Shuffler's Avatar
 
Drives: Synergy for my Daughter
Join Date: Feb 2010
Location: Texas
Posts: 3,091
Quote:
Originally Posted by 1WILDSScmrg View Post
i have a noise coming from passenger side, it sounds like it's coming from the passenger side rear tire. almost like the break is engaging a little bit and making it squeak going down the road. It only makes noise when the Camaro is in motion and it has to warm up first before it starts. I'm going to the dealership on thursday to get it checked out but i just wanted to see if anyone had any ideas. thanks for the help.
Well not what I thought..... read the title and thought Wife.
__________________
Shuffler is offline   Reply With Quote
Old 09-20-2012, 01:07 PM   #22
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
just got back from the dealership/running around looking for parts... it turns out that the front rotors and pads are shot. the dealership told me that they would not last another week and charged $45.00 to tell me that and said new rotors are $150 each and new pads would be over $200 for just the front breaks. i found all the stuff i needed at autozone for $196.00. the dealership said they would puteverything on for me friday morning for $75.00. over all I'm spending $316.00 to get it all fixed up. if i got all the parts from the dealership it would of been over $600.00.

I am by no means trashing the dealership. they were very helful and i totally understand why they would want me to buy there stuff but i couldn't pay double for the same parts.

I hope this info helps everyone and if you have any other questions just ask.
1WILDSScmrg is offline   Reply With Quote
Old 09-20-2012, 01:08 PM   #23
BowtieBelle
They see me trollin'...
 
BowtieBelle's Avatar
 
Drives: 217 ci of fury; Chauffeured by SS
Join Date: Jul 2011
Location: Oklahoma
Posts: 14,095
Quote:
Originally Posted by 1WILDSScmrg View Post
just got back from the dealership/running around looking for parts... it turns out that the front rotors and pads are shot. the dealership told me that they would not last another week and charged $45.00 to tell me that and said new rotors are $150 each and new pads would be over $200 for just the front breaks. i found all the stuff i needed at autozone for $196.00. the dealership said they would puteverything on for me friday morning for $75.00. over all I'm spending $316.00 to get it all fixed up. if i got all the parts from the dealership it would of been over $600.00.

I am by no means trashing the dealership. they were very helful and i totally understand why they would want me to buy there stuff but i couldn't pay double for the same parts.

I hope this info helps everyone and if you have any other questions just ask.
Front rotors and pads... yeah I had that issue at 30k with mine. Luckily they were able to turn them. Ouch! How many miles are on your 10?
__________________
"Never race anything you can't afford to light on fire and push off a cliff." -CamaroSpike

2011 Custom LT/RS: Bella's Build Thread
BowtieBelle is offline   Reply With Quote
Old 09-20-2012, 01:13 PM   #24
1WILDSScmrg
 
1WILDSScmrg's Avatar
 
Drives: 2010 Camaro SS inferno orange
Join Date: Dec 2010
Location: Jacksonville, NC
Posts: 193
I'm a little over 41,000 on mine. The dealership told me the rotors and the pads have to be changed at the sametime on the Camaro SS because they are not ment to last that long... Hmmmmm i might have to pull there punk card on that in the morning. Thanks for that info.
1WILDSScmrg is offline   Reply With Quote
Old 09-20-2012, 01:26 PM   #25
braggnrights
 
Drives: 2010 Camaro 2SS/RS, CGM, GFX
Join Date: Dec 2010
Location: Elizabethtown, KY
Posts: 46
I had about 32K on mine when I had the problem. Did they check your VIN? You are over 36K anyway, so there is probably little they could do anyway. You definitely paid less than I did. I had to have the rotors too. They could not turn mine any. Bet you are glad to get it fixed either way, I know I was!
__________________
Aaron S. Bragg
CPT, MI
Fort Leavenworth, Kansas



The Screamin' Eagles, 101st Airborne Division
Currahee 2-506 Infantry
Rakkasan 1-33 Cavalry

The BIG RED ONE, 1st Infantry Division
Ramrods 2-2 Infantry
Hellfighters HHC, 3/1 IBCT
braggnrights is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.