Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics

Camaro ZL1 Forum - ZL1 Specific Topics Camaro ZL1 specific topics

Reply
 
Thread Tools
Old 07-29-2014, 09:08 PM   #1
CalebZL1
 
CalebZL1's Avatar
 
Drives: 2013 VR M6 ZL1 #489.
Join Date: Apr 2013
Location: Capron, Illinois
Posts: 32
Replacement supercharger question.

I have a 2013 ZL1 with 4,000 miles and my supercharger had the rattle so I had it replaced a week ago. The rattle is gone and the engine is super quiet now but now I've noticed a new noise that's kinda bothering me. Whenever I engage my clutch to take off from a stop I get a grinding/rubbing/rattle noise for a split second, is this normal? It never made the noise before I got the supercharger replaced and I went back to the dealer that did the work and they had the mechanic that installed everything ride with me and he told me it was normal and that it was the downside to having a new supercharger and also printed out the TSB about the rattle or buzz at 800-900rpms or at high load with the 6 speed ZL1's with replacement superchargers.

Thanks everyone.
__________________
CalebZL1 is offline   Reply With Quote
Old 07-29-2014, 10:04 PM   #2
z28man2
 
z28man2's Avatar
 
Drives: 2013 Camaro ZL1 Coupe IOM
Join Date: Jul 2013
Location: PA
Posts: 180
He's correct it's normal
__________________
2013 Camaro ZL-1 #3553, IOM, Roto-Fab Intake, Vmax Ported TB, Apex Catch Can
z28man2 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.