Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Kraft Werks
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-21-2012, 06:29 PM   #1
11 Camaro IBM

 
Drives: Camaro IBM
Join Date: Aug 2011
Location: Tx
Posts: 1,007
Steering wheel squeaking

My steering wheel keeps squeaking when I turn it like sharp turning and it's pretty noticeable not smooth at all any ideas to why it might be doing that thanks everyone
11 Camaro IBM is offline   Reply With Quote
Old 04-22-2012, 01:00 AM   #2
11 Camaro IBM

 
Drives: Camaro IBM
Join Date: Aug 2011
Location: Tx
Posts: 1,007
anyone have any ideas im fully modded so dont wanna mess with the dealer
11 Camaro IBM is offline   Reply With Quote
Old 05-15-2012, 01:01 AM   #3
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 9,986
You get any answers to this? I have this problem now too :(
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
Old 09-05-2012, 10:14 PM   #4
ScorpionSingh
FlyingSingh
 
Drives: Camaro 2012 Black LS
Join Date: Jun 2012
Location: Manassas
Posts: 4
I have noticed same problem on my Steering. Especially on really humid days, when car starts for few minutes steering squeak. After 10 minutes its ok. But problem is intermittent and comes back now and then. Have you guys found any solutions. I found similar problems in Porsche's Thread. They are talking about some pin in the steering.
ScorpionSingh is offline   Reply With Quote
Old 09-06-2012, 08:33 AM   #5
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,659
Quote:
Originally Posted by ScorpionSingh View Post
I have noticed same problem on my Steering. Especially on really humid days, when car starts for few minutes steering squeak. After 10 minutes its ok. But problem is intermittent and comes back now and then. Have you guys found any solutions. I found similar problems in Porsche's Thread. They are talking about some pin in the steering.
I apologize for the dissatisfaction you may be experiencing with the steering wheel. Have you taken it to a dealership for this current issue? They should be able to pinpoint the concern.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 09-09-2012, 08:01 PM   #6
T3hlulzkiller
 
Drives: 2012 Camaro 2LT
Join Date: Oct 2010
Location: Croton-on-Hudson, N.Y.
Posts: 89
I'm having this exact issue as well. Going to bring it in to the dealership I guess.
T3hlulzkiller is offline   Reply With Quote
Old 09-09-2012, 08:57 PM   #7
frank1557
Account Suspended
 
frank1557's Avatar
 
Drives: 2011 Inferno Orange RS
Join Date: Jun 2011
Location: Bakersfield
Posts: 382
I had that prob.
Bad bearing.
frank1557 is offline   Reply With Quote
Old 09-13-2012, 06:25 PM   #8
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Mine just started doing that today, humid day and around 90'f. Steers fine but makes a slight noise when you turn the wheel at all. Power steering going out maybe.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-13-2012, 07:49 PM   #9
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 9,986
Anybody know what to do?
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
Old 09-14-2012, 01:18 AM   #10
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by lscamaro View Post
Anybody know what to do?
Mine is going to the dealer tomorrow. I will post on what they do and it better be something lol

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-14-2012, 01:28 AM   #11
TinyToasta
 
TinyToasta's Avatar
 
Drives: way too fast....
Join Date: May 2010
Location: Germany
Posts: 289
It's a bad clockspring I guess - needs replacing....
__________________
custom build forged LSA, 376ci, TVS2300@15psi, 675rwhp/676ft-lbs, built by Henrik Racing, Customkingz, tuned by Jannetty Racing
JRE rough idle cam, JRE ported lower intake manifold, OD cog drive, 6% OD crank pulley, ported ls3 heads, NW102mm TB, 1/2'' RDS spacer, IW 8-rib drive
Pfadt Cradle Bushings, Arms & Rods, Pedders Supercar w/FE4 conversion, ZL1 sways, HE Twin Carbon Street Slayer, DSS 1000hp Axles
CTS-V Brake upgrade, Street: 22'' Vossen CV1, Strip: 18'' Forgestar F14 on MT Street Radials
TinyToasta is offline   Reply With Quote
Old 09-14-2012, 08:32 AM   #12
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by TinyToasta View Post
It's a bad clockspring I guess - needs replacing....
Behind the air bag?

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-14-2012, 12:15 PM   #13
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,659
Quote:
Originally Posted by bajamoon View Post
Mine just started doing that today, humid day and around 90'f. Steers fine but makes a slight noise when you turn the wheel at all. Power steering going out maybe.

Outbound: I apologize for your frustrations. Have you had a diagnosis at a dealership? They would be in the best position to diagnose the issue you are experiencing.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 09-14-2012, 12:45 PM   #14
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Outbound: I apologize for your frustrations. Have you had a diagnosis at a dealership? They would be in the best position to diagnose the issue you are experiencing.

Brandon
Chevrolet Customer Service
No i haven't but its getting dropped off today to check it out

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-16-2012, 12:54 AM   #15
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Took the car to the dealer Friday and they said after a good test drive the steering pump was losing pressure. Should have the car back Tuesday

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-16-2012, 01:46 AM   #16
PM Designs
 
PM Designs's Avatar
 
Drives: 2011 Camaro, 99 Silverado , 69 C-10
Join Date: Jan 2011
Location: Louisiana
Posts: 256
My car has the squeak too, guess its time to bring it to the dealership.
PM Designs is offline   Reply With Quote
Old 09-16-2012, 11:00 AM   #17
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by PM Designs View Post
My car has the squeak too, guess its time to bring it to the dealership.
Check the fluid level first if you haven't. Might be something simple.

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-17-2012, 09:49 AM   #18
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,659
Quote:
Originally Posted by bajamoon View Post
Took the car to the dealer Friday and they said after a good test drive the steering pump was losing pressure. Should have the car back Tuesday

Sent from my phone using tapatalk.
Please let us know how your service went after you get your vehicle back!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 09-17-2012, 10:53 AM   #19
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Please let us know how your service went after you get your vehicle back!

Brandon
Chevrolet Customer Service
Ok. Service has been good so far, they call me with updates everyday because they know its my baby

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-17-2012, 11:11 AM   #20
mudchick_alicia
 
mudchick_alicia's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Sep 2011
Location: Benton, LA
Posts: 225
Just got mine back Friday because I had noise when turning and they replaced the rack and pinion said that there was an issue with the rack and pinion being noisy but not defected.
__________________
CAI, Borla Atak Axleback, Magnaflow xpipe, Solo's HF Cats, Nitto Invos on EuroTek Mesh Deep Concave 20x10 on all 4's
mudchick_alicia is offline   Reply With Quote
Old 09-18-2012, 10:56 AM   #21
dannykay
 
Drives: 2011 Camaro 2SS/RS Convertible
Join Date: Mar 2012
Location: Texas
Posts: 25
Ok I have taken mine to the dealership since I am experiencing the same problem as most of you say on here....the response from the dealership was "unable to duplicate problem".....any advice on what to do next?
dannykay is offline   Reply With Quote
Old 09-18-2012, 11:38 AM   #22
mudchick_alicia
 
mudchick_alicia's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Sep 2011
Location: Benton, LA
Posts: 225
Quote:
Originally Posted by dannykay View Post
Ok I have taken mine to the dealership since I am experiencing the same problem as most of you say on here....the response from the dealership was "unable to duplicate problem".....any advice on what to do next?
Mine was doing it all the time when I turned the steering wheel very annoying...sounded like a piece of plastic or something rubbing in steering wheel behind the air bag area. I couldn't find a TSB on it but the girl at my service dept said that they had another camaro coming in for the same thing and she said she just had the rack and pinion replaced in her traverse for the same noise issue. I would suggest one of the guys from your service dept getting in the car with you so you can let them hear noise.
__________________
CAI, Borla Atak Axleback, Magnaflow xpipe, Solo's HF Cats, Nitto Invos on EuroTek Mesh Deep Concave 20x10 on all 4's
mudchick_alicia is offline   Reply With Quote
Old 09-18-2012, 11:38 PM   #23
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Got mine back today. Changed the steering pump and it feels and sounds the same lol. If it gets worse I'll take it back again, it's not making the belt slip like it did before so maybe the pump was one of the problems.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
Old 09-19-2012, 02:13 AM   #24
TinyToasta
 
TinyToasta's Avatar
 
Drives: way too fast....
Join Date: May 2010
Location: Germany
Posts: 289
Again: Have the dealership check the clockspring on the stearing wheel - these are a known reason to cause weird sounds...

Try to identify the source of the squeeking - if it's right behind the airbag while turning in any given directiion it's most likely the clockspring
__________________
custom build forged LSA, 376ci, TVS2300@15psi, 675rwhp/676ft-lbs, built by Henrik Racing, Customkingz, tuned by Jannetty Racing
JRE rough idle cam, JRE ported lower intake manifold, OD cog drive, 6% OD crank pulley, ported ls3 heads, NW102mm TB, 1/2'' RDS spacer, IW 8-rib drive
Pfadt Cradle Bushings, Arms & Rods, Pedders Supercar w/FE4 conversion, ZL1 sways, HE Twin Carbon Street Slayer, DSS 1000hp Axles
CTS-V Brake upgrade, Street: 22'' Vossen CV1, Strip: 18'' Forgestar F14 on MT Street Radials
TinyToasta is offline   Reply With Quote
Old 09-19-2012, 08:38 AM   #25
bajamoon


 
bajamoon's Avatar
 
Drives: 2014 Subaru WRX
Join Date: Mar 2011
Location: Whittier CA
Posts: 13,741
Quote:
Originally Posted by TinyToasta View Post
Again: Have the dealership check the clockspring on the stearing wheel - these are a known reason to cause weird sounds...

Try to identify the source of the squeeking - if it's right behind the airbag while turning in any given directiion it's most likely the clockspring
My noise isn't coming from inside, to me i would guess its the rack.

Sent from my phone using tapatalk.
__________________
My Build Thread
http://camaro5.com/forums/showthread...=1#post5036900
Maureen@Rodgers Chevrolet...The best prices and customer service period!!(734)676-9600
Gen5Diy.com.....http://www.gen5diy.com/
Wretched Motorsports..www.wretchedms.com/
Pedders USA
...http://www.peddersusa.com/
bajamoon is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.