Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 04-22-2012, 11:22 AM   #1
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
My 2012 m6 dragstrip experience!!!!!

I just thought i would share my experience at the strip. Aside from the horrific wheel hop i had. The shifting was unreal way better then my 2010. I did change all the fluids out for Amsoil at 1,000 miles. I drove her very easy never went over 70 an constantly changed my speed but when i hit 1,000 i started asking for more but very subtle starting out and as i worked my way too 1,500 i was gettin on it fairly hard but not crazy. The track was the final breakin and not once in all that have i ground a gear. I talked with a fellow in the drivetrain dept and he said they have made considerable improvements on the 2012. I just thought id share my experience ty for reading.
MustangKiller is offline   Reply With Quote
Old 04-22-2012, 11:26 AM   #2
KDInTheWind63
 
KDInTheWind63's Avatar
 
Drives: 2SS/RS IOM, LS3 - 2SS SIM, L99
Join Date: Feb 2010
Location: TX
Posts: 209
Send a message via Yahoo to KDInTheWind63
Thanks for sharing the info.
KDInTheWind63 is offline   Reply With Quote
Old 04-22-2012, 11:29 AM   #3
2010 SSRS



 
2010 SSRS's Avatar
 
Drives: 3 V8 Camaros
Join Date: May 2009
Location: The Ocean State
Posts: 123,973
what times did you run at the track
__________________
Jannetty Racing JRE Street Package
2010 SSRS is offline   Reply With Quote
Old 04-22-2012, 11:53 AM   #4
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Quote:
Originally Posted by 2010 SSRS View Post
what times did you run at the track
13.3 i wasnt ringin the piss out of it either shiftin like 5,900 no power shifting my 60' time sucked but thats cuz it just wouldnt get off the line my best rt was .013 my first run was rt .046 60' was like 2.4 i deep staged one an was-.003 red lol
MustangKiller is offline   Reply With Quote
Old 04-22-2012, 12:21 PM   #5
Andy@AMSOIL
Account Suspended
 
Drives: 4 wheels
Join Date: Oct 2011
Location: Digging for OIL
Posts: 263
Good stuff.

Did you see improvements when changing to AMSOIL fluids ?
Andy@AMSOIL is offline   Reply With Quote
Old 04-22-2012, 12:48 PM   #6
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Snaped a pic gettin 28.4 mpg @ around the 1,200 mile mark doin 70 mph on I70 other then that Andy i dont have anythjng too compare it too.
MustangKiller is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.