Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-25-2012, 09:40 AM   #1
nicaraguanguy
 
Drives: 2011 Chevy Camaro LS
Join Date: Nov 2010
Location: Chatsworth
Posts: 67
Heater issue

When I swapped my dash to a metra kit my heater stopped working. I didn't really care because it was summer and the Scosche kit was suppose to come out. Well I finally got the Scosche kit and the heater still doesn't work. Any idea's on why?
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=34327&dateline=130280  9485
nicaraguanguy is offline   Reply With Quote
Old 04-25-2012, 10:00 AM   #2
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 526
Because you broke it.
Hannibal is offline   Reply With Quote
Old 04-25-2012, 12:15 PM   #3
Papa T
 
Papa T's Avatar
 
Drives: 2011 2LT RJT, 6A, 19" polished
Join Date: Jul 2010
Location: Vermont
Posts: 746
Quote:
Originally Posted by nicaraguanguy View Post
When I swapped my dash to a metra kit my heater stopped working. I didn't really care because it was summer and the Scosche kit was suppose to come out. Well I finally got the Scosche kit and the heater still doesn't work. Any idea's on why?
From a quick look through the 2011 Owners manual:
http://www.chevrolet.com/owners/chevy-manuals/

Looks like you have multiple beaker/fuses that could be an issue:


Page 10-47
Instrument Panel Fuse Block
F5 Heating Ventilation Air Conditioning Controller

Page 10-48
F28 Front Heater, Ventilation, and Air Conditioning


Another thought is if you have your original Radio/ heater control unit... you could try to re-install to see if it still works??

Hope this helps.
__________________

Last edited by Papa T; 04-25-2012 at 12:29 PM.
Papa T is offline   Reply With Quote
Old 05-02-2012, 10:46 PM   #4
nicaraguanguy
 
Drives: 2011 Chevy Camaro LS
Join Date: Nov 2010
Location: Chatsworth
Posts: 67
Fuse didn't help. I'm going to take it in but since it's an after market box I hope they will find a solution. Any other idea's on what it can be?
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=34327&dateline=130280  9485
nicaraguanguy is offline   Reply With Quote
Old 05-03-2012, 07:39 AM   #5
Papa T
 
Papa T's Avatar
 
Drives: 2011 2LT RJT, 6A, 19" polished
Join Date: Jul 2010
Location: Vermont
Posts: 746
Quote:
Originally Posted by nicaraguanguy View Post
Fuse didn't help. I'm going to take it in but since it's an after market box I hope they will find a solution. Any other idea's on what it can be?
When you say "Heater does not work" what part is not working?:
  • No Fan?
  • No heat?
  • Does AC work OK?
  • All dead?
  • Can you see anything on the heat/AC screen?
Essentially break down what is and is not working.


That may help narrow down to the issue.


Again if you have the original stereo heater unit you my need to have that reinstalled to see if that works.
  • If the original unit works... it's something with the 2 aftermarket units. (or compatibility)
  • If the original one does not work... it's something in the car... then Chevy should be able to trace it down.
Sorry that is all I've got. Good luck.
__________________
Papa T is offline   Reply With Quote
Old 05-03-2012, 01:58 PM   #6
nicaraguanguy
 
Drives: 2011 Chevy Camaro LS
Join Date: Nov 2010
Location: Chatsworth
Posts: 67
Quote:
Originally Posted by Papa T View Post
When you say "Heater does not work" what part is not working?:
  • No Fan?
  • No heat?
  • Does AC work OK?
  • All dead?
  • Can you see anything on the heat/AC screen?
Essentially break down what is and is not working.


That may help narrow down to the issue.


Again if you have the original stereo heater unit you my need to have that reinstalled to see if that works.
  • If the original unit works... it's something with the 2 aftermarket units. (or compatibility)
  • If the original one does not work... it's something in the car... then Chevy should be able to trace it down.
Sorry that is all I've got. Good luck.
Fan works, AC works, Everything works but the heater. God forbid it's not compatible, is there a work around that? Also why wouldn't it be compatible if other camaro's have it?
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=34327&dateline=130280  9485

Last edited by nicaraguanguy; 05-03-2012 at 03:00 PM.
nicaraguanguy is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.