Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nickey Chicago
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-29-2012, 10:23 PM   #1
lrh131
 
Drives: Cyber Grey Metallic 2LT/RS
Join Date: Dec 2011
Location: Jackson,MS
Posts: 9
Send a message via Yahoo to lrh131 Send a message via Skype™ to lrh131
Turn Signal Problem

Hi guys, I may need the help of you experts. So I got the messagein my 2010 camaro 2lt on the dic screen that says "check right turn signal" so I checked it and it wasnt working. Of the 2 lights on the passenger side, the one to the far right isn't blinking while the other one works fine. I replaced the bulb and the turn signal still doesn't work for that light, but the tail light comes on just fine at night. I am guessing the light for the turn signal and the actual tail light comes through the same bulb, so I have ruled out the bulb. Apparently its only the turn signal, when I press the unlock button and do my emergency flashers it doesnt work. I tried to be as detailed as possible. Any Ideas as to what this could be?
lrh131 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.