Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-01-2012, 09:37 AM   #1
Marcellon
 
Drives: 2011 Camaro Convertible SS 2LT
Join Date: Apr 2012
Location: Virginia
Posts: 1
HUD issues

My HUD just stopped working. Anyone have any tips? Thanks.
Marcellon is offline   Reply With Quote
Old 05-01-2012, 09:55 AM   #2
Edwin320
 
Drives: 2012 Camaro Convertible 2SS RS M6
Join Date: Mar 2012
Location: Miami, Fl
Posts: 491
Still under warranty?
__________________
Ed 2012 2SS RS M6 'Vert
Edwin320 is offline   Reply With Quote
Old 05-01-2012, 09:55 PM   #3
LonghornLove
My Grille so Icey
 
LonghornLove's Avatar
 
Drives: Black 2SS/RS
Join Date: Sep 2011
Location: Pearland, Tx
Posts: 217
your the 2nd person I've seen have this problem. IDK what ended up happening with the 1st one.

Go to the dealer in get a new one.
__________________
Kooks 1 7/8 LT headers and exhaust sytem, CAI. cai w/ADM scoop, JRE tune.

L99
LonghornLove is offline   Reply With Quote
 
Reply

Tags
electronics, heads up display, hud

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.