Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ModBargains
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-10-2012, 10:31 AM   #1
matteyp
 
matteyp's Avatar
 
Drives: 2010 Camaro 2SSRS Red JewelCoat
Join Date: Nov 2011
Location: Washington
Posts: 141
Headlight lense repair

Hey guys, I just bought a 2010 2ss rs and for some reason the headlight lenses seem to have a fog in the center right where the hid bulb is. It's almost like the heat from the bulb has clouded the lense right in the center. Also I have lots of tiny rock chips on the outside of the lense is there some way to repair this without having to buy new lights? Also My headlights make this odd clunking sound when I turn the brights on. Is that normal? Thanks

Matt
matteyp is offline   Reply With Quote
Old 05-10-2012, 02:44 PM   #2
Moorepheus

 
Drives: 2013 Dodge Charge R/T Plus AWD
Join Date: Jul 2009
Location: Niagara Falls, NY
Posts: 1,306
The clunking sound is normal. As for the haze/fog on the bulb, you can try to get it replaced under warranty. I know, when I had mine, I had, what looked like, finger prints on the HID glass bulb. They replaced the unit under warranty. However, I had only owned the car 2 months when I noticed it. Being that you have a 2010, you might be SOL. Also, for the rock chips, I believe there is lens protectors out there you can place over the headlight, but at this point it's too late, you already have the rock chips in it.
Moorepheus is offline   Reply With Quote
Old 05-15-2012, 12:49 PM   #3
momofsix
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2011
Location: Wellesley, Ontario
Posts: 77
Had the haze/fog on the lenses...have had the car since July 2010 and our lenses and bulbs got replaced under warranty just last month...they said the parts alone were about $3500...
__________________
momofsix is offline   Reply With Quote
Old 05-15-2012, 05:04 PM   #4
matteyp
 
matteyp's Avatar
 
Drives: 2010 Camaro 2SSRS Red JewelCoat
Join Date: Nov 2011
Location: Washington
Posts: 141
well maybe ill take it to another dealership then cuz the one by my house wouldnt do it. He said after 10k those "types of things" arent covered anymore. i have 21k on the car now not sure what your mileage was at the time of repair...
matteyp is offline   Reply With Quote
Old 05-15-2012, 05:40 PM   #5
momofsix
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2011
Location: Wellesley, Ontario
Posts: 77
We had 28k when they replaced them..there is a difference in dealers, we are in Ontario and heard other dealers are not replacing them or they want approval by a GM rep first...We have always dealt with the same dealer, which is the dealer we bought the car from, not sure if that makes a difference.
__________________
momofsix is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.