Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Classic Industries
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 05-10-2012, 05:20 PM   #1
InvaderMoose

 
InvaderMoose's Avatar
 
Drives: 2010 2SS/RS CGM
Join Date: Apr 2010
Location: N/A
Posts: 959
Deleted

Deleted
__________________

Engine/Appearance: 530 RWHP
Whipple supercharger, Full JBA Exhaust, Ported TB, Cold Air Inductions & ADM Scoop /Complete new paint, 20" Forgestar F14s, Sinister hood, SLP Spoiler, AAC Halos, P13W Fogs

Last edited by InvaderMoose; 03-06-2014 at 06:01 PM. Reason: Deleted
InvaderMoose is offline   Reply With Quote
Old 05-10-2012, 05:21 PM   #2
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
Back of the supercharger on the lower part of the manifold, hate to say it
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 05-10-2012, 05:22 PM   #3
InvaderMoose

 
InvaderMoose's Avatar
 
Drives: 2010 2SS/RS CGM
Join Date: Apr 2010
Location: N/A
Posts: 959
...I guess there's no easy way of doing it except to feel around. I'd almost see if I could unbolt the cowl area underneath the wipers.
__________________

Engine/Appearance: 530 RWHP
Whipple supercharger, Full JBA Exhaust, Ported TB, Cold Air Inductions & ADM Scoop /Complete new paint, 20" Forgestar F14s, Sinister hood, SLP Spoiler, AAC Halos, P13W Fogs
InvaderMoose is offline   Reply With Quote
Old 05-10-2012, 05:32 PM   #4
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
I don't think there is an easy way of doing that map sensor other than unbolting the blower and moving it forward, then getting at the map sensor, remove and replace and reinstall the top of the blower again. That's how I would approach it, maybe someone else has a "trick" for that???
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 05-10-2012, 05:53 PM   #5
InvaderMoose

 
InvaderMoose's Avatar
 
Drives: 2010 2SS/RS CGM
Join Date: Apr 2010
Location: N/A
Posts: 959
..Old map sensor just snapped in half and its now stuck in the hole in the supercharger... .. Any ideas what to do now..
__________________

Engine/Appearance: 530 RWHP
Whipple supercharger, Full JBA Exhaust, Ported TB, Cold Air Inductions & ADM Scoop /Complete new paint, 20" Forgestar F14s, Sinister hood, SLP Spoiler, AAC Halos, P13W Fogs
InvaderMoose is offline   Reply With Quote
Old 05-10-2012, 06:28 PM   #6
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
Not good, is the top half of the blower out? You will be able to see the nipple from the map sensor on the inside of the lower intake manifold, that has an O ring attached...make sure that you cover all of the intake ports and then push the nipple from the inside out. Those O Rings will stick, put some white lube on the new one before installing
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 05-10-2012, 07:33 PM   #7
InvaderMoose

 
InvaderMoose's Avatar
 
Drives: 2010 2SS/RS CGM
Join Date: Apr 2010
Location: N/A
Posts: 959
I didnt take the whipple off to put the MAP sensor on, I just reached behind to do all my work. I wound up fishing the o-ring and everything out with a fishing hook -ba dum tss-. Used gun oil to lube up the new MAP sensor and it went in with a bit of force. Okay, a lot of force. I had to sit on the front of my car and lay over the engine to get both hands behind it just so I could push it in.

No CEL anymore, and no service stabilitrak. After 7 months of guessing and fixing things that weren't broken, my car is FINALLY running correctly. Now I just have to decide If I want to still sell it for a GTR or an M3
__________________

Engine/Appearance: 530 RWHP
Whipple supercharger, Full JBA Exhaust, Ported TB, Cold Air Inductions & ADM Scoop /Complete new paint, 20" Forgestar F14s, Sinister hood, SLP Spoiler, AAC Halos, P13W Fogs
InvaderMoose is offline   Reply With Quote
Old 05-11-2012, 06:19 AM   #8
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
Good to hear that everything is working as it should now...and that's good for future reference for myself and others with a whipple. I know that the map is a real tight fit and would be a PIA to remove with the blower on, I wouldn't get rid of your car though, it's a sweet ride!! But can't argue with either of the other rides you are interested in either

__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 05-15-2012, 11:45 PM   #9
BLACK10

 
BLACK10's Avatar
 
Drives: 2010 CAMARO. 10.04@133mph, 1.4 60'
Join Date: Jul 2009
Location: Lafayette, Louisiana
Posts: 4,987
when would the service stabilitrak message come on?
BLACK10 is offline   Reply With Quote
Old 05-16-2012, 06:29 AM   #10
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
Quote:
Originally Posted by BLACK10 View Post
when would the service stabilitrak message come on?
There are several possible problems that could cause that to come on, wheel sensor problem, engine misfire problem, steering wheel angle sensor problem, and I actually had a weird one where my handheld scanner was causing a service stabilitrak issue, unplug the scanner no problem, plug it back in, code came back...did that several times and same results over and over, I am thinking that my scanner maybe blocking communications to the stablitrak system
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 05-19-2012, 10:51 AM   #11
johnntab
 
johnntab's Avatar
 
Drives: 2010 2SSRS, 11 CTS-V, 12 Denali HD
Join Date: Apr 2009
Location: KY
Posts: 50
Quote:
Originally Posted by MA2010SS View Post
There are several possible problems that could cause that to come on, wheel sensor problem, engine misfire problem, steering wheel angle sensor problem, and I actually had a weird one where my handheld scanner was causing a service stabilitrak issue, unplug the scanner no problem, plug it back in, code came back...did that several times and same results over and over, I am thinking that my scanner maybe blocking communications to the stablitrak system
I am just finishing up a procharger install with methanol injection. I am planning to run the Aeroforce interceptor gauge. When I start up the car with the gauge on thru the obd port, I get the abs and stabilitrak lights. The gauge essentially works like a scan tool. The guy who is going to put in the tune says it is likely due to the new map sensor in the methanol control kit. He says that once he puts in the tune, it should fix the problem. As the car will know how to deal with signals from the extra map and gauge.
__________________
ORDER # NDPPHT: 2010 2SS/RS Beltronics custom install radar detector STiR plus, Ofer's backup camera, Procharger D1SC, LG pro lt headers and midpipe, Borla S Type rear section, Comp Cam pushrods and springs, 65lb injectors, Alky meth kit, Aeroforce interceptor gauge mounted on SLP steering column gauge pod, tune by BLUECAT, and from bestwheeldeals.com: TSW Nurburgrings, Nitto 05r rear, Invo front.
johnntab is offline   Reply With Quote
Old 05-19-2012, 01:54 PM   #12
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 515
Quote:
Originally Posted by johnntab View Post
I am just finishing up a procharger install with methanol injection. I am planning to run the Aeroforce interceptor gauge. When I start up the car with the gauge on thru the obd port, I get the abs and stabilitrak lights. The gauge essentially works like a scan tool. The guy who is going to put in the tune says it is likely due to the new map sensor in the methanol control kit. He says that once he puts in the tune, it should fix the problem. As the car will know how to deal with signals from the extra map and gauge.
I think that it maybe a hit or miss thing with scanners in general, a friend of mine has a snapon scanner updated through 2011 cars, he does this for a living and for not rhyme or reason all different makes and models will act differently, a licoln navigator will get an abs light when diagnosing a CEL issue, or a toyota camery ends up getting an airbag light when checking a CEL....a couple of examples he gave me, fix the problem with the vehicle and remove the scanner no issues. The rep from snap on told him that it may stop communication with certain systems unless he was checking those particular systems, I chalk it up to being random
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 08-04-2013, 05:45 AM   #13
kj217
 
Drives: 09 CTS-V
Join Date: Aug 2013
Location: Jeddah
Posts: 57
anyone know where MAP goes in a maggie tvs2300?
kj217 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.