Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Apex Paul
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-12-2012, 10:03 PM   #1
1badtie

 
1badtie's Avatar
 
Drives: 2010 camaro 2ss rs
Join Date: Nov 2009
Location: Central AR
Posts: 910
is my clutch ok?

So on my third pass on the dragstrip, as i was attemping to do a small burnout to heat the tires up, i gas it some gas and let off the clutch and the wheels did not spin but the RPM shot up, then i put it in neutral and the clutch stuck to the floor for a moment then came back up. After that the cab reeked of that burnt clutch smell.
i made that last pass and everything seemed fine it just reeked of that smell for a while i stopped and took off lightly a few times even, but seems normal

does everything sounds fine?
1badtie is offline   Reply With Quote
Old 05-13-2012, 08:55 AM   #2
DJ_BigC
Rockin' Steady
 
DJ_BigC's Avatar
 
Drives: Camaro 2SS, Z06 Vette, ATS Turbo
Join Date: Apr 2012
Location: Timmins
Posts: 147
No, nothing sounds fine here, sound like you smoked your clutch. It might not be totally gone, but you may have glazed it over a good bit. The transmission would need to get pulled out and a good inspection of the disc, pressure plate and flywheel would need to be performed.

If it still drives OK, no big deal, keep driving it but by the description above it seems like you smoked it my friend.
__________________
Eric Carrier, proud GM Technician for over 4 yrs.

2013 Cadillac ATS, 2.0L Turbo, Luxury package, 20" Strada's, Pirelli Pzeros

2010 Camaro 2SS Black, L99, SLP headers, GMPP axle back, K&N CAI, JRE tune, 22" Boss 337's, Nitto Invos

2009 Z06 Corvette AOM, LS7, Borla Cat Back
DJ_BigC is offline   Reply With Quote
Old 05-13-2012, 01:23 PM   #3
1badtie

 
1badtie's Avatar
 
Drives: 2010 camaro 2ss rs
Join Date: Nov 2009
Location: Central AR
Posts: 910
drove her today and everything seems fine anybody else wanna give some input?
1badtie is offline   Reply With Quote
Old 05-14-2012, 09:33 AM   #4
Skyblu

 
Skyblu's Avatar
 
Drives: 2010 Aqua blue 2SS/RS M6
Join Date: Jul 2009
Location: Florida
Posts: 998
the clutch sticking to the floor is a common problem, mine has done it twice and the dealer claims it is my fault but it isn't if you read some of the other blogs on here it happens to alot of people. Some say it's because the clutch and brake master cylinder are one in the same and it's not a very good combo apparently. I can't believe it happens so ofter to so many but gm and the dealer claim it's the drivers style not the cars fault. B.S
Skyblu is offline   Reply With Quote
Old 05-14-2012, 07:31 PM   #5
1badtie

 
1badtie's Avatar
 
Drives: 2010 camaro 2ss rs
Join Date: Nov 2009
Location: Central AR
Posts: 910
seems fine now ill go easy on her for a while
1badtie is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.