Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-14-2012, 06:04 PM   #1
Kenmecca
Mecca SS
 
Drives: 2012 2SS/RS IBM M6/ '05 Hemi Magnum
Join Date: Jan 2012
Location: Bay Area - in the 925
Posts: 137
New Record for Failure?

Cant believe it- bought my dream car on Saturday- Brand New IBM SS/RS. I have spent the last 4 months on these boards learning so much from everyone of all the do's and dont's. On Sunday was just driving down the road and bam! sounded like I threw a rod of something- well it was a couple of valve springs that broke- @ 127 miles WTF! Im finding out what Chevy is going to do- I dont want a damaged engine with less than 24 hrs on it that is for sure. Wasnt even goosing the engine and I was in maybe 3/4th gear at the time.
Of course forgot my cell, my wife forgot hers and we had our 7 y.o. in the car. As I was using a call box that was 5 feet in front where I limped it, I remembered I had Onstar.
Kenmecca is offline   Reply With Quote
Old 05-14-2012, 06:34 PM   #2
Swacer

 
Drives: 2012 Camaro 2SS/RS
Join Date: Nov 2011
Location: Pittsburgh, PA
Posts: 2,190
Your story sounds like hell man.

First off, was the car brand new? How many miles? If under at least 1000, there is this thing called a break in, did you abide by it? If not, you dug your own grave.


Sorry to hear.
__________________
2012 2SS/RS Camaro
~Imperial Blue Metallic~LS3~M6~GM High Spoiler~GM Ground Effect~GM Tower Brace~Heritage Grill~Roto-Fab Cold Air Intake~Stainless Works Exhaust~Stainless Power Headers~VMAX Ported Throttle Body~Tuned By Frost~GEN5DYI Spare Clutch Reservior~Barton Short Throw~ShowStopper Side Markers
Swacer is offline   Reply With Quote
Old 05-14-2012, 06:55 PM   #3
InfernoSS454
 
InfernoSS454's Avatar
 
Drives: 2010 camaro ss
Join Date: Feb 2012
Location: houston,texas
Posts: 391
Break in break in that's no excuse the car shouldn't of fd up. Sorry bro I think u got a lemon.
__________________
Texas speeds 1 7/8 longtube headers and full exhaust vararam air intake. Lethal racings night fury cam and yank 3400 stall. Dyno tuned by lethal racing 465 rwhp 434 rwtq.
InfernoSS454 is offline   Reply With Quote
Old 05-14-2012, 10:35 PM   #4
Kenmecca
Mecca SS
 
Drives: 2012 2SS/RS IBM M6/ '05 Hemi Magnum
Join Date: Jan 2012
Location: Bay Area - in the 925
Posts: 137
It had 12 mies on it. Yes I was breaking it in correctly. Even if I smoked the tires it shouldn't do that.
Kenmecca is offline   Reply With Quote
Old 05-14-2012, 10:43 PM   #5
theragtopguy
Lifetime Phillies Fan
 
theragtopguy's Avatar
 
Drives: Silver/Black '12 2LT 'Vert 6-speed
Join Date: Mar 2012
Location: Eastern Penns Woods
Posts: 805
There's no way they can blame you for this one!!

Crap happens sometimes, even on brand new engines.

Good luck, hope they take care of you!!
__________________
Phillies Baseball, Hot Dogs, Apple Pie and Chevrolet!!!!

Ported TB, CAI induction, MRT V-2 Pipes
theragtopguy is offline   Reply With Quote
Old 05-15-2012, 10:11 AM   #6
Nessal


 
Drives: Lotus Exige
Join Date: Jun 2011
Location: CA, Bay Area
Posts: 2,269
I got you beat. My car broke a valve spring at 60 miles. Happened just as I pulled into my driveway after getting it from the dealers.


Oh the funny thing was that I was telling my fiance that this car was a good buy and that American cars have came a long way blah blah blah. Then this happens right as we got home...talk about embarassment. Then the week after, some sensor broke that caused the passanger side airbag light to go bonker. Then soon after that, there was an air leak that caused the car to run lean and throw the CEL. Turned out that the intake manifold was leaking on the #8 runner. Then I'm getting second gear grinds even when the transmission is warmed up. Actually, it just grinded this morning just as I pulled into my work place.

I don't know what to say...I have never had any car ever that had this many problems and I haven't even owned the car for a year yet. If I brought my car into the dealer to fix the second gear syncro, I could lemon law my Camaro since I would meet the requirements. But I don't want a new Camaro because they don't make them in CGM anymore.
Nessal is offline   Reply With Quote
Old 05-15-2012, 11:26 AM   #7
Kenmecca
Mecca SS
 
Drives: 2012 2SS/RS IBM M6/ '05 Hemi Magnum
Join Date: Jan 2012
Location: Bay Area - in the 925
Posts: 137
So it sounds like they just fixed your valve springs? They are talking full engine replacement, Im thinking I may just want to ask for a different one- it'll never be as good as new again. Ill at least ask for an extended warranty or something. Did you ask for any compensation for it dying so soon?


QUOTE=Nessal;4964844]I got you beat. My car broke a valve spring at 60 miles. Happened just as I pulled into my driveway after getting it from the dealers.


Oh the funny thing was that I was telling my fiance that this car was a good buy and that American cars have came a long way blah blah blah. Then this happens right as we got home...talk about embarassment. Then the week after, some sensor broke that caused the passanger side airbag light to go bonker. Then soon after that, there was an air leak that caused the car to run lean and throw the CEL. Turned out that the intake manifold was leaking on the #8 runner. Then I'm getting second gear grinds even when the transmission is warmed up. Actually, it just grinded this morning just as I pulled into my work place.

I don't know what to say...I have never had any car ever that had this many problems and I haven't even owned the car for a year yet. If I brought my car into the dealer to fix the second gear syncro, I could lemon law my Camaro since I would meet the requirements. But I don't want a new Camaro because they don't make them in CGM anymore.[/QUOTE]
Kenmecca is offline   Reply With Quote
Old 05-15-2012, 01:37 PM   #8
Nessal


 
Drives: Lotus Exige
Join Date: Jun 2011
Location: CA, Bay Area
Posts: 2,269
The dealer said that there was no PV contact so they just redid all the springs. He told me that the valve spring are double springs so if one broke, the other will still prevent the valve from dropping. Well that simply isn’t true because the stock valve spring are single springs. That does not instill much confidence in me when the dealer doesn’t even know WTF he is talking about. Trust me, I know how you feel. You just paid 36k for a brand new car only to have engine failure the first day then a bunch of problems right after. I should have jumped on the 135i when I had the chance but the Camaro won me over with its sexy looks. It’s a great car…don’t get me wrong. Just sucks that when I bought the car, my friends and family were telling me not to buy an American car because they are unreliable and I told them that they are wrong and that American cars have came a long way from what they used to be….and in the end, I only proved them right. LOL…quite embarrassing….especially so soon.

*

Good luck getting them to throw a new engine in there. Even if there was PV contact I still bet that they won’t give you a new engine. They’ll probably just replace the head, valve, springs, piston, and resleeve it. It sucks and the car will never feel right to you again. Honestly, with all the problems that I have had, I would not trust it on a long trip. I just don’t trust the car. At one point when all the problems were happening, every time I had to drive the car, the only thing that I’m wondering is “What’s going to screw up this time?”. It’s not a good feeling and does not give you a sense of confidence in your brand new vehicle. But I couldn’t let the car go because it does give me a lot of enjoyment....more than any other car that I have in the past. Just wish it wasn’t like this.

*

Everything is running well…for now. I can look past all the faults and enjoy the car for what it is. That’s the only thing that is preventing me from lemoning it. The only thing that bugs me is the second gear syncro. We do have a 5 year warranty on it so if it craps out within 5 years I’m still good.
Nessal is offline   Reply With Quote
Old 05-15-2012, 01:52 PM   #9
justa25thTA

 
justa25thTA's Avatar
 
Drives: 2011 Camaro SS/RS LS3
Join Date: Aug 2010
Location: Texas
Posts: 1,632
think you should talk to them about giving you an extended warranty. unless the 100,000 mile powertrain warranty will still cover it
__________________
Yeah, I'll get around to it...
justa25thTA is offline   Reply With Quote
Old 05-15-2012, 02:07 PM   #10
woodstock
 
woodstock's Avatar
 
Drives: 2012 Corvette Grand Sport
Join Date: Jan 2011
Location: martinez Ga.
Posts: 497
Parts can fail,new or old has nothing to do with break in.
woodstock is offline   Reply With Quote
Old 05-16-2012, 03:16 PM   #11
Kenmecca
Mecca SS
 
Drives: 2012 2SS/RS IBM M6/ '05 Hemi Magnum
Join Date: Jan 2012
Location: Bay Area - in the 925
Posts: 137
They are putting in a new motor- Im going to try and get them to pay for an extended warranty or at least part of it- I was going to wait until 11000 to get one - they already agreed to paying for 1st month's payment.... Thanks for the feedback. Im not gonna be scared to run the car after I break it in- still have my backup car
Kenmecca is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.