Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-14-2012, 09:31 PM   #1
2010abmss
 
2010abmss's Avatar
 
Drives: 2010 ABM SS
Join Date: Feb 2011
Location: TX
Posts: 599
My new camaro smells like a burning clutch.

I bought a new ss vert in the mornings when I start it and leave it has a strong clutch burning smell is this normal for a new car? The car is a manual
__________________
Sold 2010 ABM 2SS RS. Kooks, Corsa CB
2010abmss is offline   Reply With Quote
Old 05-14-2012, 11:03 PM   #2
Dan2510
 
Drives: 2012 LS3 2SS/RS IBM
Join Date: Mar 2009
Location: Chicago
Posts: 144
I have a new camaro ss as well and get that smell. I'm not sure if its just the smell of a new engine breaking in or what. I get wiffs of it during take off usually and hard acceleration, I have a manual.
Dan2510 is offline   Reply With Quote
Old 05-15-2012, 07:15 AM   #3
djm96z28

 
djm96z28's Avatar
 
Drives: 2012 Camaro 1SS LS3
Join Date: Jul 2008
Location: Jacksonville FL
Posts: 1,034
Mine did that when it was new. The smell went away after 200-300 miles.
djm96z28 is offline   Reply With Quote
Old 05-15-2012, 07:17 AM   #4
Tyler360
 
Tyler360's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jul 2011
Location: Wittenberg, Wisconsin
Posts: 701
Mine also did that when it was new. I read somewhere that a new clutch will do that but I can't remember where
__________________
Tyler360 is offline   Reply With Quote
Old 05-15-2012, 09:15 AM   #5
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,081
Quote:
Originally Posted by 2010abmss View Post
I bought a new ss vert in the mornings when I start it and leave it has a strong clutch burning smell is this normal for a new car? The car is a manual
Congrats on your new Camaro! If you feel like you are experiencing an issue with your Camaro the best thing to do is to contact your local dealership. Let us know your feedback!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 05-15-2012, 09:21 AM   #6
jmaynard
 
Drives: 2012 Camaro SS2
Join Date: Dec 2011
Location: Garland Tx
Posts: 453
Change the hoses. All of them. What you are smelling is NOT the clutch but a defect on the material used to manufacture the hoses which reacts to the radiator fluid. It will only get worse to the poin that you will never really like your car like you though you did. My wife still hates my car because of the smell we had for the first 3 months. There is a TSB on this. You will be without the car for at least a day while they flush (3 times) the system. But afterwards the smell goes away. Do it now before you start hating the car.

Last note: Have the dealer order all the hoses before you take it in/leave it. There is one that they will not stock and it takes at least a day to get. No sense in driving a rental while they wait for parts.
jmaynard is offline   Reply With Quote
Old 05-15-2012, 09:35 AM   #7
PAUL SS
The Mark of Excellence
 
PAUL SS's Avatar
 
Drives: 2010 ABM 1SS RS LS3
Join Date: Jan 2009
Location: Smallest State in the Union
Posts: 8,639
Did your 2010 abm stink when it was new? Typical of a new car for the first couple hundred miles or so.
__________________
BMR, CAI, DynoMax, Elite Eng., Hurst, Jannetty, Clear Image Headers & Hi Flow cats, Jet Hot, LSR, TSW, VMax, Vredestein
PAUL SS is offline   Reply With Quote
Old 05-15-2012, 11:16 AM   #8
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,095
bad hoses.

chilax everyone. What you are very likely smelling is the burning smell coming from all the part labels wrapped around the exhaust pipes. Go ahead, look under the car, you will see them on the pipes. The smell will go away after a few hundred miles.
ffrcobra_65 is offline   Reply With Quote
Old 05-15-2012, 11:25 AM   #9
christianmotox


 
christianmotox's Avatar
 
Drives: ( . )( . )
Join Date: Feb 2010
Location: San Diego, CA
Posts: 2,829
Oh the smell of a brand new car... i miss it.
__________________
christianmotox is offline   Reply With Quote
Old 05-15-2012, 12:01 PM   #10
thahemp
Geek
 
thahemp's Avatar
 
Drives: 2012 Black LS3
Join Date: Jan 2012
Location: Derby, KS
Posts: 4,327
Quote:
Originally Posted by ffrcobra_65 View Post
bad hoses.

chilax everyone. What you are very likely smelling is the burning smell coming from all the part labels wrapped around the exhaust pipes. Go ahead, look under the car, you will see them on the pipes. The smell will go away after a few hundred miles.
Actually, mine still smells like that after i run it hard. I'm over 3000 miles. My wife's infinity has the same smell after i run it hard. It does smell like the hoses to me. Even has a nasty radiator smell to it...

Thanks for the tip jmaynard... Although it would take more than a bad smell to make me hate this car
__________________
01000111011011110110111101100100001000000110110001 11010101100011011010110010000001110111011010010111 01000110100000100000011101000110100001101001011100 110010000001101111011011100110010100100001

x = ac97968bd3df8f968c8cd3df998a9c94d3df9c8a918bd3df9c 909c94df8c8a9c949a8dd3df92908b979a8ddf998a9c949a8d d3df8b968b8cd1
x = ~x
thahemp is offline   Reply With Quote
Old 05-15-2012, 04:25 PM   #11
2010abmss
 
2010abmss's Avatar
 
Drives: 2010 ABM SS
Join Date: Feb 2011
Location: TX
Posts: 599
I appreciate the feedback I'll check the hose tsb
__________________
Sold 2010 ABM 2SS RS. Kooks, Corsa CB
2010abmss is offline   Reply With Quote
Old 05-15-2012, 06:00 PM   #12
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 139
I've been going through the hoses/dexcool thing for five months.. Dealer has attempted to fix it 3-times! But it keeps coming back.. I'll find out next week what they are going to do? Most likely replace it with a new one or buy it back..

If it's the coolant/hoses problem, the engine compartment will have a foul stink, especially when it's hot.. You will also get a weird smell from the vents when at idle. The smell will continually get stronger to the point where it will stink up the garage if it's parked in one..
kfm237 is offline   Reply With Quote
Old 05-15-2012, 06:29 PM   #13
thahemp
Geek
 
thahemp's Avatar
 
Drives: 2012 Black LS3
Join Date: Jan 2012
Location: Derby, KS
Posts: 4,327
Quote:
Originally Posted by kfm237 View Post
I've been going through the hoses/dexcool thing for five months.. Dealer has attempted to fix it 3-times! But it keeps coming back.. I'll find out next week what they are going to do? Most likely replace it with a new one or buy it back..

If it's the coolant/hoses problem, the engine compartment will have a foul stink, especially when it's hot.. You will also get a weird smell from the vents when at idle. The smell will continually get stronger to the point where it will stink up the garage if it's parked in one..
Yep. That smells about right

It's not a huge deal... It's just that a fine looking automobile shouldn't smell like a 1960's school radiator.
__________________
01000111011011110110111101100100001000000110110001 11010101100011011010110010000001110111011010010111 01000110100000100000011101000110100001101001011100 110010000001101111011011100110010100100001

x = ac97968bd3df8f968c8cd3df998a9c94d3df9c8a918bd3df9c 909c94df8c8a9c949a8dd3df92908b979a8ddf998a9c949a8d d3df8b968b8cd1
x = ~x
thahemp is offline   Reply With Quote
Old 05-16-2012, 07:40 AM   #14
sloSS
 
sloSS's Avatar
 
Drives: 2012 Camaro 1SS RS LS3
Join Date: Feb 2012
Location: Atlanta
Posts: 254
My clutch smells bad, too. Just backing out of the garage with engine rpm at 1,000 or less will generate the burnt clutch smell. I've really been easy on the clutch (low rpm starts from stop) and now, with 6,000 miles on the car, the clutch smell is almost gone. Perhaps with a few good launches at the drag strip the smell would have gone away sooner lol!
sloSS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:46 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.