Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
MPD1
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-20-2012, 06:40 PM   #1
SPARTAN sui
PC Technician
 
SPARTAN sui's Avatar
 
Drives: 2011 VR Camaro 2LT
Join Date: May 2012
Location: North Dakota
Posts: 910
Sunroof windscreen violent pop when closing

Hey guys, I've seen a few threads about this, but not much resolution ever comes from them. Here's the issue, when I close the sunroof, the little plastic windscreen (with the mesh netting), does not go into place just right. This causes a loud pop than slips into place correctly. I can see exactly what's happening, the left side (driver side) lays flat without an issue, however if you stop the sunroof from closing at the right time you can see it's going into place crooked. The left side will be in place, but the right side (passenger side) is still up in the air.

I found a quick fix that resolves this issue for only a short while. Sometimes it will be fine for several days. Sometimes it will act up again that day. All I do to resolve the issue is pull up the metal tension bar that's attached to the right side of the windscreen. As the sunroof slides forward it applies pressure to these tension bars that in turns pushes the windscreen into the correct down position. However it's pushing the driver side down first, so I simply pull up on the passenger side bar (to sort of bend it back to shape) and then it goes into the down position correctly. It's really annoying. If it only made a little sound, no big deal. But it makes a violent pop.

Has anyone else dealt with this issue before? Like I said I found a few threads so I know I'm not alone. Is there a TSB or anything on it? Seems like an easy issue to resolve. I just want it resolved correctly so it doesn't come back again.

Right now it's working fine, when it acts up again I'll take video of the issue and post it.
__________________
SPARTAN sui is offline   Reply With Quote
Old 05-22-2012, 10:14 AM   #2
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,510
Quote:
Originally Posted by SPARTAN sui View Post
Hey guys, I've seen a few threads about this, but not much resolution ever comes from them. Here's the issue, when I close the sunroof, the little plastic windscreen (with the mesh netting), does not go into place just right. This causes a loud pop than slips into place correctly. I can see exactly what's happening, the left side (driver side) lays flat without an issue, however if you stop the sunroof from closing at the right time you can see it's going into place crooked. The left side will be in place, but the right side (passenger side) is still up in the air.

I found a quick fix that resolves this issue for only a short while. Sometimes it will be fine for several days. Sometimes it will act up again that day. All I do to resolve the issue is pull up the metal tension bar that's attached to the right side of the windscreen. As the sunroof slides forward it applies pressure to these tension bars that in turns pushes the windscreen into the correct down position. However it's pushing the driver side down first, so I simply pull up on the passenger side bar (to sort of bend it back to shape) and then it goes into the down position correctly. It's really annoying. If it only made a little sound, no big deal. But it makes a violent pop.

Has anyone else dealt with this issue before? Like I said I found a few threads so I know I'm not alone. Is there a TSB or anything on it? Seems like an easy issue to resolve. I just want it resolved correctly so it doesn't come back again.

Right now it's working fine, when it acts up again I'll take video of the issue and post it.
Though I cannot post any information about TSBs, the best thing to do with this issue persists, is to get it diagnosed by your local dealership. I can check your VIN for any applicable warranties via PM. If you have additional questions or concerns, please feel free to contact me via PM.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 05-22-2012, 12:41 PM   #3
SPARTAN sui
PC Technician
 
SPARTAN sui's Avatar
 
Drives: 2011 VR Camaro 2LT
Join Date: May 2012
Location: North Dakota
Posts: 910
Thanks for the reply Brandon, I know I have warranty, I just purchased it about 20 days ago, and it only has 12,700 miles.

It's only a minor (but annoying) issue, the dealership I bought it from is 3 hours away, so just popping in to have them check it isn't much of an option. But I'll take it in next time I'm in the area to get checked out.
__________________
SPARTAN sui is offline   Reply With Quote
Old 06-21-2012, 11:25 PM   #4
dogbytesman
 
dogbytesman's Avatar
 
Drives: 2011 Camaro 2LT
Join Date: Jun 2012
Location: Portland, OR
Posts: 10
Spartan, did you get this figured out? I have the same thing going on with my (new to me) 2011 LT.

Thanks!
Brad
dogbytesman is offline   Reply With Quote
Old 06-22-2012, 03:38 PM   #5
SPARTAN sui
PC Technician
 
SPARTAN sui's Avatar
 
Drives: 2011 VR Camaro 2LT
Join Date: May 2012
Location: North Dakota
Posts: 910
Brad,

I haven't used my sunroof in awhile, last few times I did use it, I didn't have the issue. I'll test it again, but I'm willing to bet it won't do it. I just played with the metal tension rods (bending them upwards) that make the windscreen flip up and push down as the sunroof either opens or closes.
__________________
SPARTAN sui is offline   Reply With Quote
Old 06-22-2012, 08:52 PM   #6
dogbytesman
 
dogbytesman's Avatar
 
Drives: 2011 Camaro 2LT
Join Date: Jun 2012
Location: Portland, OR
Posts: 10
Ah....very good. Makes sense. I'm a little nervous about messing with it, but will give it a shot.

Thanks for getting back to me on this!
Brad
dogbytesman is offline   Reply With Quote
Old 06-23-2012, 12:14 PM   #7
SPARTAN sui
PC Technician
 
SPARTAN sui's Avatar
 
Drives: 2011 VR Camaro 2LT
Join Date: May 2012
Location: North Dakota
Posts: 910
Sure enough, it didn't go down like it should have. So I pulled up on the tension bar (passenger side) a few times, since that's the side that doesn't pop down into position properly, and now it's working fine for now.

My dealer is a 3 hour drive away, so if you pop into yours for this issue, let me know how it goes. It's really minor, but it is super annoying for my year old car to be doing this.
__________________
SPARTAN sui is offline   Reply With Quote
Old 06-24-2012, 02:54 AM   #8
dogbytesman
 
dogbytesman's Avatar
 
Drives: 2011 Camaro 2LT
Join Date: Jun 2012
Location: Portland, OR
Posts: 10
Roger that, Spartan....will keep you posted.

Thanks!
Brad
dogbytesman is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.