Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-31-2012, 08:11 AM   #1
Jonzmaro
 
Jonzmaro's Avatar
 
Drives: 2013 RS M6
Join Date: May 2012
Location: Potomac Falls VA
Posts: 111
Does anyone else's break pedal /clunkthump when let up quickly?

When I am in traffic, and using the breaks frequently, my pedal makes an annoying thump/clunk when lifting my foot off quickly.

Anyone else experience this?

2012 1lt
Jonzmaro is offline   Reply With Quote
Old 05-31-2012, 08:14 AM   #2
Swacer


 
Drives: 2012 Camaro 2SS/RS
Join Date: Nov 2011
Location: Pittsburgh, PA
Posts: 2,307
Not quite sure if I have a break pedal....i do have a brake pedal tho! haha just messing

No I don't...only thump I ever get is when I have to push the clutch in really quick because the person in front of me felt the need to slam the brakes.

Dealership trip?
__________________
2012 2SS/RS Camaro
~Imperial Blue Metallic~LS3~M6~GM High Spoiler~GM Ground Effect~GM Tower Brace~Heritage Grill~Roto-Fab Cold Air Intake~Stainless Works Exhaust~Stainless Power Headers~VMAX Ported Throttle Body~Tuned By Frost~GEN5DYI Spare Clutch Reservior~Barton Short Throw~ShowStopper Side Markers~UMI Performance Trailing Arms~UMI Performance Tunnel Brace
Swacer is offline   Reply With Quote
Old 05-31-2012, 10:27 AM   #3
menendez1293
Emerald Coast Camaros
 
menendez1293's Avatar
 
Drives: 2010 Camaro 2LT/RS M6
Join Date: Nov 2009
Location: Tallahassee FL
Posts: 9,215
I believe I know the sound your talking about. If I'm a light and I just pushed the break in to the floor for some reason and I just let go kind of quickly I get a loud thumb/clicking sound. I think it's normal because I have gotten it out of not only the camaro but a corvette a cruze a hhr and a Nissan cube.
__________________
Proud owner of litho #179 Click Picture for Build Thread
menendez1293 is offline   Reply With Quote
Old 05-31-2012, 11:00 AM   #4
ShowSStopper
Account Suspended
 
Drives: 2012 Camaro 1SS Black Coupe
Join Date: May 2012
Location: Houston
Posts: 1,092
I get this as well...seems like there's just extra play in the brake pedal. I've also noticed I need to really press down on mine to get the car to slow. Just takes getting used to.
ShowSStopper is offline   Reply With Quote
Old 05-31-2012, 12:57 PM   #5
Jonzmaro
 
Jonzmaro's Avatar
 
Drives: 2013 RS M6
Join Date: May 2012
Location: Potomac Falls VA
Posts: 111
Wicked,

Same here....sometimes it feels like the car won't stop!

I wonder if I put one of those little, felt turniture pads on the stop if it would be ok? It really bugs me.......happy to say the only thing that does thus far.
Jonzmaro is offline   Reply With Quote
Old 05-31-2012, 05:50 PM   #6
Bonanza7
Account Suspended
 
Drives: 2010, Rally Yellow, Black stripes
Join Date: Jul 2010
Location: Phoenix
Posts: 2,364
yep
Bonanza7 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.