Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
MPD1
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-06-2012, 06:52 AM   #1
SSlim
 
Drives: 2011 Cyber Grey 1SS/RS A6
Join Date: Aug 2011
Location: Needville TX
Posts: 229
Steering Wheel Noise

Have a weird noise in my steering. When I turn the wheel it sounds like draging your fingernail on jeans. Have no idea what it is and just recently started. Hopefully you can make out the sound in this vid:

__________________
Whipple, GT9 cam, LS3 conversion, ZL1 pistons, ZL1 rods, Circle D converter, Stage 3 trans, Tuned by Pat G, CAI inc, TPS headers, posi mod, Dynomax bullet cat back, VMAX TB, ADM Scoop, RX catch can, Eibach prokit plus, Eurotek Mesh 33 wheels, P13w DRLs, Pioneer/Massive Audio/Vibe/JL interior goodies.
613 RWHP/596 TQ
SSlim is offline   Reply With Quote
Old 06-06-2012, 01:36 PM   #2
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,656
Quote:
Originally Posted by SSlim View Post
Have a weird noise in my steering. When I turn the wheel it sounds like draging your fingernail on jeans. Have no idea what it is and just recently started. Hopefully you can make out the sound in this vid:

I would like to take the time to address the concern you are having. Have you taken the vehicle to the dealership to get it diagnosed? Please feel free to contact me via PM if you are still having any concerns.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 06-06-2012, 06:22 PM   #3
SSlim
 
Drives: 2011 Cyber Grey 1SS/RS A6
Join Date: Aug 2011
Location: Needville TX
Posts: 229
Not yet. Still trying to decide if it is annoying enough to spend the day at the delership and to battle warranty question.
__________________
Whipple, GT9 cam, LS3 conversion, ZL1 pistons, ZL1 rods, Circle D converter, Stage 3 trans, Tuned by Pat G, CAI inc, TPS headers, posi mod, Dynomax bullet cat back, VMAX TB, ADM Scoop, RX catch can, Eibach prokit plus, Eurotek Mesh 33 wheels, P13w DRLs, Pioneer/Massive Audio/Vibe/JL interior goodies.
613 RWHP/596 TQ
SSlim is offline   Reply With Quote
Old 10-04-2012, 09:34 AM   #4
Neto1978
 
Drives: 2011 camaro ss victory red
Join Date: Jul 2012
Location: Sp-brazil
Posts: 166
very same thing happening to mine...did anybody found what it could be???
tks

Quote:
Originally Posted by SSlim View Post
Have a weird noise in my steering. When I turn the wheel it sounds like draging your fingernail on jeans. Have no idea what it is and just recently started. Hopefully you can make out the sound in this vid:

Neto1978 is offline   Reply With Quote
Old 10-04-2012, 09:37 AM   #5
sprangalang
 
sprangalang's Avatar
 
Drives: 2012 2SS
Join Date: May 2012
Location: United States
Posts: 35
I have it too. Sounds like a squeegee.
sprangalang is offline   Reply With Quote
Old 10-04-2012, 09:41 AM   #6
Neto1978
 
Drives: 2011 camaro ss victory red
Join Date: Jul 2012
Location: Sp-brazil
Posts: 166
Rich, any idea???
Neto1978 is offline   Reply With Quote
Old 10-04-2012, 09:58 AM   #7
z28racer

 
z28racer's Avatar
 
Drives: 12 SIM 2SS/ RS Sinergy M6,GMC2500HD
Join Date: Jan 2012
Location: San Diego, California
Posts: 1,545
Mine sounds just like that.They are replacing my R&P today. I told them about TSB for the fluid being changed to ATF and they said that it doesent apply to the Camaro. So I suggest you take it in to dealer. Mine is silent when cold but as soon it warms up the noise starts.
z28racer is offline   Reply With Quote
Old 10-04-2012, 04:07 PM   #8
dcplus14
 
dcplus14's Avatar
 
Drives: '12 Camaro 2SS/RS/Hurst
Join Date: Jan 2012
Location: San Diego
Posts: 480
I have that same noise too.
__________________
2012 Camaro 2SS/RS: Black on Black, Hurst
[AAC DRL LED's, AAC LED's for trunk, cabin, license plate, CAI Intake, RX Catch Can, Skip shift eliminator, Pedders Sub-Frame Inserts, Pedders Radius Rod Inserts, Pedders Rack & Pinion Bushing, 1LE front and rear sway bars]
dcplus14 is offline   Reply With Quote
Old 10-04-2012, 11:42 PM   #9
mudchick_alicia
 
mudchick_alicia's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Sep 2011
Location: Benton, LA
Posts: 225
I had the same noise in mine and had the rack and pinion replaced...no noise now!
__________________
CAI, Borla Atak Axleback, Magnaflow xpipe, Solo's HF Cats, Nitto Invos on EuroTek Mesh Deep Concave 20x10 on all 4's
mudchick_alicia is offline   Reply With Quote
Old 10-05-2012, 08:01 AM   #10
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,656
Quote:
Originally Posted by Neto1978 View Post
very same thing happening to mine...did anybody found what it could be???
tks

Have you tried taking it to a dealership for a proper diagnosis? They should be able to diagnose this for you. Please let us know! We are here for your convenience.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 10-06-2012, 09:28 PM   #11
Neto1978
 
Drives: 2011 camaro ss victory red
Join Date: Jul 2012
Location: Sp-brazil
Posts: 166
They always says its normal....i need a tsb about this...


Quote:
Originally Posted by Chevrolet Customer Svc View Post
Have you tried taking it to a dealership for a proper diagnosis? They should be able to diagnose this for you. Please let us know! We are here for your convenience.

Brandon
Chevrolet Customer Service
Neto1978 is offline   Reply With Quote
Old 10-06-2012, 10:17 PM   #12
z28racer

 
z28racer's Avatar
 
Drives: 12 SIM 2SS/ RS Sinergy M6,GMC2500HD
Join Date: Jan 2012
Location: San Diego, California
Posts: 1,545
Quote:
Originally Posted by Neto1978 View Post
They always says its normal....i need a tsb about this...
Its not normal! They replaced my R&P yesterday. No more noise.
z28racer is offline   Reply With Quote
Old 10-17-2012, 07:59 PM   #13
Neto1978
 
Drives: 2011 camaro ss victory red
Join Date: Jul 2012
Location: Sp-brazil
Posts: 166
well, mine stayed 3 days at the dealer, they drained the old steering fluid, flushed and put some dexron VI, noise decreased a lot, everyday its getting better as I drive the car longer...it seems to be a lubrication problem in the rack and pinion...The old fluid had a kind of contamination on it (gray kind of grease).
Neto1978 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.