Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-07-2012, 12:27 AM   #1
jonblaze
 
jonblaze's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Apr 2012
Location: Austin
Posts: 7
Dealership and warranty lingo

Fairly new here and looking for some tips when taking my Camaro SS in for service at Chevrolet dealership for the first time.

Bought my 2010 used a few months ago (19k miles now) and car fax doesn't show any dealer visits. It does have a clanky sound coming from front tires and I read about a tsb here for some part that gets bent in wheel. I will need to look for that thread to refresh but any other advice on other known issues would be much appreciated.

Enjoying my Camaro and hoping to have a good experience at my local dealership in Austin. Thanks for the great info on here.
jonblaze is offline   Reply With Quote
Old 06-07-2012, 06:17 AM   #2
TheHorse13

 
TheHorse13's Avatar
 
Drives: 2011 Black SS M6
Join Date: Oct 2010
Location: Harpers Ferry, WV
Posts: 863
Take pictures of the body before you leave it with them. You can then prove when they bang up the paint on your car when they have it in for service.
TheHorse13 is offline   Reply With Quote
Old 06-07-2012, 08:02 AM   #3
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,618
Quote:
Originally Posted by jonblaze View Post
Fairly new here and looking for some tips when taking my Camaro SS in for service at Chevrolet dealership for the first time.

Bought my 2010 used a few months ago (19k miles now) and car fax doesn't show any dealer visits. It does have a clanky sound coming from front tires and I read about a tsb here for some part that gets bent in wheel. I will need to look for that thread to refresh but any other advice on other known issues would be much appreciated.

Enjoying my Camaro and hoping to have a good experience at my local dealership in Austin. Thanks for the great info on here.
Please let us know how everything goes for the first time at your local dealership. Also, welcome to the Camaro family! I am sure you turn heads and you will love it during the summer.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 06-07-2012, 08:43 AM   #4
coloeb
 
coloeb's Avatar
 
Drives: 2012 2LT/RS 6L50 automatic TF-3
Join Date: Apr 2012
Location: Natchez, Ms.
Posts: 104
Things I have read about the SS problem wise are oil leaks at the rear main seal, oil pan and one other place that I don't recall at the moment. Rear end noise and a few tranny problems.
Not sure if any of these concern your particular model year or not, and I do not own the SS. Take any of this with a grain of salt! Its just what I have read here on this board.
__________________
Its better to burn out , than to fade away.
coloeb is offline   Reply With Quote
Old 06-07-2012, 07:22 PM   #5
jonblaze
 
jonblaze's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Apr 2012
Location: Austin
Posts: 7
It does make a sound when reversing out of driveway and turning wheel, kinda grinding sound. Is that common?

Seems like a/c should be cooler but I am in Texas. Also, not sure why a/c (and blue light) doesn't automatically turn on when temp is on max cold. Alignment seems a bit off, and some minor vibrations at about 20-30 mph.

Some minor things but otherwise , I'm loving my 2ss! Favorite thing has to be the halo lights when using remote start, and the rumble of course.
jonblaze is offline   Reply With Quote
Old 06-07-2012, 07:26 PM   #6
Easton091
 
Easton091's Avatar
 
Drives: 2011 Camaro SS
Join Date: May 2012
Location: Sterling Heights, MI
Posts: 426
Quote:
Originally Posted by jonblaze View Post
It does make a sound when reversing out of driveway and turning wheel, kinda grinding sound. Is that common?

Seems like a/c should be cooler but I am in Texas. Also, not sure why a/c (and blue light) doesn't automatically turn on when temp is on max cold. Alignment seems a bit off, and some minor vibrations at about 20-30 mph.

Some minor things but otherwise , I'm loving my 2ss! Favorite thing has to be the halo lights when using remote start, and the rumble of course.
I work at a dealer up here in MI. Alignments are not covered after 7,500. Vibrations would most likey be from tires either cupped or out of balance. If your a/c is blowing around 45-48 degrees at the vents, thats good. Grinding when backing out of a driveway could be rust on the rotors. I bet it happens after sitting for a while?
Easton091 is offline   Reply With Quote
Old 06-09-2012, 12:05 AM   #7
jonblaze
 
jonblaze's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Apr 2012
Location: Austin
Posts: 7
No, it's my dd and does the sound every morning when reversing out and turning wheel, sounds related to steering but my dad thought it could be brakes or rotors.
jonblaze is offline   Reply With Quote
Old 06-12-2012, 02:12 PM   #8
jonblaze
 
jonblaze's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Apr 2012
Location: Austin
Posts: 7
Dealership was nice enough but two techs (who appear to have had fun driving my car as mpg was down a bit said everything was functioning fine and normal. Guess I will just deal with it by cranking up my radio or revving more often.
jonblaze is offline   Reply With Quote
Old 06-12-2012, 06:01 PM   #9
TwistedEnergy
 
TwistedEnergy's Avatar
 
Drives: 2010 IOM 2SS/RS
Join Date: Feb 2012
Location: Brampton, Ontario
Posts: 333
Quote:
Originally Posted by TheHorse13 View Post
Take pictures of the body before you leave it with them. You can then prove when they bang up the paint on your car when they have it in for service.
Sound advice. Went to 2 different dealerships came back with scratches each time. First time was a disaster all over the upper right corner of my driver door. Second time was on the front corner of my bumper can almost grantee it was from a hose when my car was washed because I did the same thing about a month earlier .
__________________
TwistedEnergy is offline   Reply With Quote
Old 06-12-2012, 06:48 PM   #10
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 9,905
Is it a grinding/whining noise? Mine is doing that when i slowly turn the wheel. Going to take it in because its starting to get to me.

I saw a few threads where people stated it was a power steering problem and the dealership fixed it
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.