Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 06-22-2012, 05:19 PM   #1
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
best amp for non ba system

Hey guys I'm just looking for opinions on what you went for the your non BA sound system. I know the stock speakers aren't that great but a little better quality is what im looking for. thanks!
rare991 is offline   Reply With Quote
Old 06-22-2012, 06:14 PM   #2
Iwantone2
Voice Of The Voiceless
 
Iwantone2's Avatar
 
Drives: CGM 1SS RS
Join Date: Feb 2009
Location: OC Cali
Posts: 9,731
Not sure about the non-BA, but on what used to be my BA system I replaced the stock amp with a JL Audio XD400. It made the stock BA speakers sound WAY better
__________________
Iwantone2 is offline   Reply With Quote
Old 06-22-2012, 06:39 PM   #3
flyer08
Tri-County Camaros
 
flyer08's Avatar
 
Drives: 2010 2SS/RS
Join Date: Jun 2009
Location: St Pete
Posts: 2,520
I have jl audio hd 900/5
flyer08 is offline   Reply With Quote
Old 06-22-2012, 06:44 PM   #4
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
Quote:
Originally Posted by flyer08 View Post
I have jl audio hd 900/5
was it a pain to install? I read the non ba amps have to wired up cause they dont have a harness?
rare991 is offline   Reply With Quote
Old 06-22-2012, 08:44 PM   #5
jeepguy_1980

 
jeepguy_1980's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: May 2010
Location: Newport News
Posts: 1,311
Quote:
Originally Posted by rare991 View Post
was it a pain to install? I read the non ba amps have to wired up cause they dont have a harness?
I'm in Newport News too. I have an extra harness pre-wired for the non-BA Camaro.

http://camaro5.com/forums/showthread...1&postcount=16

http://www.camaro5.com/forums/showthread.php?t=230255
jeepguy_1980 is offline   Reply With Quote
Old 06-22-2012, 08:51 PM   #6
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
Quote:
Originally Posted by jeepguy_1980 View Post
I'm in Newport News too. I have an extra harness pre-wired for the non-BA Camaro.

http://camaro5.com/forums/showthread...1&postcount=16

http://www.camaro5.com/forums/showthread.php?t=230255

thats awesome man! what amp did you go with?
rare991 is offline   Reply With Quote
Old 06-22-2012, 08:55 PM   #7
jeepguy_1980

 
jeepguy_1980's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: May 2010
Location: Newport News
Posts: 1,311
Quote:
Originally Posted by rare991 View Post
thats awesome man! what amp did you go with?
JL HD900/5

http://camaro5.com/forums/showthread...7&postcount=32


Quote:
Originally Posted by jeepguy_1980 View Post
Pics of my install thus far. I'm still waiting on my speakers to come in, so I can finish this off. As you can see, I'm still sporting the stock speakers. Any suggestions or feedback for improvement are always welcome.

Completed Trunk:

Subthump amp mount, could be lined up a tad bit better I think:


Naked, my amp kit didn't include enough black wire but it had excess red wire. This will be a quick easy fix:

Audio Integrations Sub box with JL Audio 10w6v2-D4:


Speaker wiring and stock speakers:
jeepguy_1980 is offline   Reply With Quote
Old 06-22-2012, 08:57 PM   #8
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
thats a clean install. Im still thinking about going with a sub.
rare991 is offline   Reply With Quote
Old 06-22-2012, 09:01 PM   #9
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
whoa... that amp is almost a grand on crutchfield. jeez
rare991 is offline   Reply With Quote
Old 06-22-2012, 09:08 PM   #10
jeepguy_1980

 
jeepguy_1980's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: May 2010
Location: Newport News
Posts: 1,311
Quote:
Originally Posted by rare991 View Post
whoa... that amp is almost a grand on crutchfield. jeez
I watched it for a couple months on Al-Eds and SonicElectronix (both authorized resellers). I wound up getting it for about $700. You can get it for under $700 on eBay. But yes, it is more than some people might be willing to spend. Others will say that JL is overpriced. In the end, just figure out what you want, your budget, and what makes the most sense.

Either way, they all wire up the same way.
jeepguy_1980 is offline   Reply With Quote
Old 06-22-2012, 09:22 PM   #11
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
Quote:
Originally Posted by jeepguy_1980 View Post
I watched it for a couple months on Al-Eds and SonicElectronix (both authorized resellers). I wound up getting it for about $700. You can get it for under $700 on eBay. But yes, it is more than some people might be willing to spend. Others will say that JL is overpriced. In the end, just figure out what you want, your budget, and what makes the most sense.

Either way, they all wire up the same way.

good point. Im sure it sounds great! I figure most any amp is gonna be better then stock. Ive always had good luck with rockford.
rare991 is offline   Reply With Quote
Old 06-23-2012, 11:23 AM   #12
flyer08
Tri-County Camaros
 
flyer08's Avatar
 
Drives: 2010 2SS/RS
Join Date: Jun 2009
Location: St Pete
Posts: 2,520
I got mine on ebay for 550 shipped, brand new. it made a huge difference in stock speakers and has an output for a sub
flyer08 is offline   Reply With Quote
Old 06-23-2012, 12:09 PM   #13
darkrider01
Aural Assault Vehicle
 
darkrider01's Avatar
 
Drives: 2010 IBM 2SS/RS, 2014 Cruze 1LT/RS
Join Date: Jun 2011
Location: Garner, NC
Posts: 685
I'm a big fan of Rockford myself. Check out the Power T400-4 ($350-370). It's a great amp.

If you're just looking to amplify the factory speakers and you're on a tight budget, you could look into the Punch PBR300X4 ($190) or Prime R300-4 ($140). All good amps, all Rockford.

I can only speak for the T400-4, but it has been awesome so far.
__________________
My amplifier pop/click/thump solution thread
Power Mods * K&N Typhoon CAI, Flowmaster American Thunder cat-back exhaust, Hurst Short Throw Shifter Visual Mods * Black Phantom Grille Suspension Mods * BC Racing Coilovers * Lakewood Strut Tower Brace
Audio Mods * Stinger SPP 2250 Battery * Pioneer DEX-P99RS * Pioneer AVH-X7500BT * Scosche Dash Kit * 2 - Mosconi AS200.4 * 2 - JL Audio 13W6v2 * Focal 165KRX2 Power (active) * Mosconi Gladen One 240.2 * Rockford Fosgate Power T1692
darkrider01 is offline   Reply With Quote
Old 06-23-2012, 01:19 PM   #14
=Stephens=


 
=Stephens='s Avatar
 
Drives: 2011 LS
Join Date: Feb 2011
Location: Kearney, Nebraska
Posts: 3,455
I have Alpine PDX amps. Run really cool and very quite.
__________________
=Stephens= is offline   Reply With Quote
Old 06-23-2012, 02:09 PM   #15
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
Quote:
Originally Posted by darkrider01 View Post
I'm a big fan of Rockford myself. Check out the Power T400-4 ($350-370). It's a great amp.

If you're just looking to amplify the factory speakers and you're on a tight budget, you could look into the Punch PBR300X4 ($190) or Prime R300-4 ($140). All good amps, all Rockford.

I can only speak for the T400-4, but it has been awesome so far.
im gonna go with the PBR300X4. where did you see that price?
rare991 is offline   Reply With Quote
Old 06-23-2012, 02:13 PM   #16
rare991

 
rare991's Avatar
 
Drives: 2014 SS 1LE
Join Date: Apr 2012
Location: Newport News VA
Posts: 1,544
nevermind just ordered it from amazon. 166 bucks!
rare991 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.