Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-26-2012, 06:06 PM   #1
=Stephens=


 
=Stephens='s Avatar
 
Drives: 2011 LS
Join Date: Feb 2011
Location: Kearney, Nebraska
Posts: 3,456
How many have used your warranty?

Our cars are still fairly new, but some have had issues and some have not. I am at 31,000 miles and my 36k warranty will be up, just wondered who had redeemed on their warranty and what was it for?
__________________
=Stephens= is offline   Reply With Quote
Old 06-26-2012, 06:06 PM   #2
Gigachip
Yea...
 
Gigachip's Avatar
 
Drives: Depends on game
Join Date: May 2010
Location: My Computer
Posts: 10,509
Send a message via AIM to Gigachip
warranty voided less than a year after I got it

well it was voided, but I forgot to add I did have warranty work for a fog light that went out last year Nov.
__________________
Gigachip is offline   Reply With Quote
Old 06-26-2012, 06:07 PM   #3
Steve Dallas
Commits weekly crime
 
Steve Dallas's Avatar
 
Drives: 2014 Stingray Z51 NPP MRC, Audi Q5
Join Date: Nov 2009
Location: Durham, NC
Posts: 8,607
I used my warranty, but it was the Extended one I bought, not the one that comes with the car. Was for a corroded fusebox. Covered the rental too for 3 days.
__________________
2014 LBT Stingray Z51, Mag Ride, Perf Exhst, Comp Seats
I fire up the willing engine, responding with a roar. Tires spitting gravel I commit my weekly crime.
Steve Dallas is offline   Reply With Quote
Old 06-26-2012, 06:08 PM   #4
hawkfe
 
hawkfe's Avatar
 
Drives: 2014 Stingray 3LT
Join Date: Nov 2009
Location: TX
Posts: 743
Had to replace the radiator at 800 miles, since then been trouble free.
hawkfe is offline   Reply With Quote
Old 06-26-2012, 06:19 PM   #5
kjkjr27
COTW 9/16/13
 
kjkjr27's Avatar
 
Drives: 2011 2LT/RS Camaro IOM
Join Date: Jan 2012
Location: Syracuse
Posts: 9,361
At around 7000 miles my breaks were squeeling real bad, brought them in to have them looked at, other than that I haven't used the warranty. I wonder though if you voided your factory warranty with at tune or something if you could still get an extended warranty, prob not.
__________________
kjkjr27 is online now   Reply With Quote
Old 06-26-2012, 06:22 PM   #6
Dirtdog
Pro Hide n Seek Player
 
Dirtdog's Avatar
 
Drives: 2010 IOM SS/RS LS3
Join Date: May 2009
Location: Tucson, AZ
Posts: 663
Send a message via AIM to Dirtdog
Money shif.... I mean, something happened to my valvetrain and they fixed it for free
__________________

Borla S Cat-Back, PFADT Tri-Y Headers, Roto-Fab CAI, PFADT Swaybars, Springs, Links, 20x10 20x11 Forgestar F14s, Lots of AAC Goodies
Dirtdog is offline   Reply With Quote
Old 06-26-2012, 06:23 PM   #7
Jason@JacFab
Mad Scientist

 
Jason@JacFab's Avatar
 
Drives: 2014 1LT Camaro; 72 Chevelle
Join Date: Apr 2008
Location: Central Point, OR
Posts: 3,678
Send a message via AIM to Jason@JacFab Send a message via MSN to Jason@JacFab
Stabilitrac problems at ~6k... Clutch/flywheel/Pressure plate/TOB/Slave replaced at 9k miles. Big exhaust leak at manifold to exhaust pipe (stud came out, I couldn't get threads to start myself after trying for an hour, took it in) at ~12k. At about 21k now, and been fine so far since the last issue.
__________________

Specializing in attractive "no drill" front license plate brackets for the 2010+ Camaro Check out our new website! www.jacfab.com
2010 Camaro 1SS RJT w/ SIM Stripes; M6. 12.535 @ 112.33mph SOLD!
2014 Camaro 1LT RRM; A6.JacFab No-Drill front license plate bracket... More to come...
Jason@JacFab is offline   Reply With Quote
Old 06-26-2012, 06:38 PM   #8
kalimus

 
kalimus's Avatar
 
Drives: '14 Z51 3LT Stingray and '13 Cruze
Join Date: Feb 2010
Location: US of A
Posts: 1,232
32k miles, no warranty issues. Although my seat levers don't work that well, so I'll probably take it in soon to have them fix that issue.
kalimus is offline   Reply With Quote
Old 06-26-2012, 06:44 PM   #9
007s 'Vert
Formerly Lil'BlueCoupe
 
007s 'Vert's Avatar
 
Drives: '13 2LT/RS Vert, Summit White
Join Date: Jul 2009
Location: Vegas Baby!!!!!!!!
Posts: 1,519
My dome light didnt work correctly right of the showroom floor, had it repaired within a week, since then.............not one freakin problem
__________________
007s 'Vert is offline   Reply With Quote
Old 06-26-2012, 06:45 PM   #10
5150 Maro
 
5150 Maro's Avatar
 
Drives: 2012 SS 45th Anniversary
Join Date: Nov 2009
Location: Manteca, CA
Posts: 249
oil leak at 6,000 miles, replaced rear seal
5150 Maro is offline   Reply With Quote
Old 06-26-2012, 06:47 PM   #11
5150 Maro
 
5150 Maro's Avatar
 
Drives: 2012 SS 45th Anniversary
Join Date: Nov 2009
Location: Manteca, CA
Posts: 249
Not on the 12 but on my SW 2010 SS
5150 Maro is offline   Reply With Quote
Old 06-26-2012, 06:52 PM   #12
molsonbrador

 
Drives: 2010 Camaro SS, 99 Silverado
Join Date: Nov 2009
Location: NJ
Posts: 1,689
Used mine to have dealer deposit a spoiler nut inside my trunk lid. I still haven't fished it out.
molsonbrador is offline   Reply With Quote
Old 06-26-2012, 06:53 PM   #13
Rangore

 
Rangore's Avatar
 
Drives: 2010 Camaro 2LT Cyber Gray
Join Date: Oct 2011
Location: Minnesota
Posts: 2,013
Timing chain replaced at 35k and the small strips of leather that hold the driver and passenger seat belts had some threads coming loose. Entire leather seat covers for both driver and passenger replaced at 35k miles too.


Sent from my iPhone using Tapatalk
__________________
Current: 2010 Camaro 2LT - Current Mods: EGA on left and right windows - Solo CAT Back - Black CAI - Black Carbon Fiber Bow-tie Vinyl - Switchback LED Turn Signal bulbs - HOD Headlight bulbs - Aqua interior LED bulb - Phoenix Gold iAMP-GM1 sub box w/amp, Lorenzo WL27 wheels
No longer owned: 1993 Camaro Z-28
Rangore is offline   Reply With Quote
Old 06-26-2012, 06:53 PM   #14
The Magic Man
Now u see me..now u dont!
 
The Magic Man's Avatar
 
Drives: Blue Magic '11 IBM 2LT/RS M6
Join Date: Mar 2010
Location: West Covina, CA
Posts: 129
Just before 36k. Font driver side caliper sticking. replaced, new brakes on both sides plus rental for 3 days
The Magic Man is offline   Reply With Quote
Old 06-26-2012, 07:04 PM   #15
ihaveacamaro
I like teeth.
 
ihaveacamaro's Avatar
 
Drives: #198
Join Date: Oct 2009
Location: Ft. Lauderdale, Florida
Posts: 4,595
Jeez, I've used my warranty around 6 times already... all before 36K. I'm at 45K right now and haven't used warranty in last 9K. Maybe our cars age well?
__________________
Please check out my youtube detailing channel: http://www.youtube.com/user/roshan517

"When you want to succeed as bad as you want to breathe, then you will be successful."
ihaveacamaro is offline   Reply With Quote
Old 06-26-2012, 07:37 PM   #16
Dizzy82

 
Dizzy82's Avatar
 
Drives: 2011 1LT/RS A6 RJT
Join Date: Mar 2011
Location: Corpus Christi, TX
Posts: 1,254
Squeaky fan replaced under warranty.
__________________
Power is worthless without control.
Dizzy82 is offline   Reply With Quote
Old 06-26-2012, 07:45 PM   #17
two_wheel_mayhem
Would rather be riding
 
two_wheel_mayhem's Avatar
 
Drives: 2012 SS LS3
Join Date: Jul 2009
Location: Indiana
Posts: 1,846
I took my car in for warranty work last Thursday, they did the HVAC update and ordered a part to fix the trunk light. My heated seat complaint they could not duplicate.

Then I found out the bumper-to-bumper expired 9 days earlier, but they still honored it. I thought it should have been the day I closed the deal on the car, but apparantly it isn't.
two_wheel_mayhem is offline   Reply With Quote
Old 06-26-2012, 08:02 PM   #18
dmwhiteman
 
dmwhiteman's Avatar
 
Drives: 2SS Black w/ Inferno Orange Stripes
Join Date: Sep 2010
Location: PA
Posts: 565
My airbag light kept coming on for weeks. Took it in twice to get reprogrammed. Turned out to be a bad passenger sensor from setting a heavy back pack on it.
__________________
dmwhiteman is offline   Reply With Quote
Old 06-26-2012, 08:08 PM   #19
h2oplay
Winners find a way
 
h2oplay's Avatar
 
Drives: 2010 2LT/RS M6
Join Date: Jun 2010
Location: NE Ohio
Posts: 1,137
Rear oil seal and switch for TC at 7k, 18k now with no worries.
__________________
Injen LT | Magnaflows | BBK LT & HFC | Mace 25mm & P Spacer |Richmond 3.73 | Trifecta Tune
RX Catch Can & Breather | Pedders Inserts | IDEALG Clutch MC & GTO Reservoir | JDP Colorshift Halos | Drake Bowtie Delete |
h2oplay is offline   Reply With Quote
Old 06-26-2012, 08:10 PM   #20
14pilot
Original Bumblebee Owner
 
14pilot's Avatar
 
Drives: 265hp ZX-14, 500hp Silverado, V-ROD
Join Date: Apr 2009
Location: Arizona
Posts: 1,388
At 0 miles, my trunk lid wouldn't unlatch every time. It took 3-4 presses to get it to open. Dealer adjusted the latch and all is good.
__________________
Quote:
Quote:
#5 - 2010 2SS/RS MN6 ABM #142-Silver Rallys-GFX / Med Titanium
My previous Camaros:
#4 - 1994 Z/28 6M Black over Arctic White / Graphite-Red Inserts - traded
#3 - 1981 Z/28 Bright Blue Metallic / Black - sold
#2 - 1970.5 RS Mulsanne Blue / Blue - endo crashed it and parted it out
#1 - 1967 RS Butternut Yellow w/ Black Bumblebee Stripe-RPO D91 / Parchment-Black - sold
14pilot is offline   Reply With Quote
Old 06-26-2012, 08:18 PM   #21
wabibito
 
wabibito's Avatar
 
Drives: 2013 2SS RS
Join Date: Mar 2012
Location: Orange County, CA
Posts: 195
replace the whole BCM due to the service stabilitrak issue (this was a pain, have to bring it back and forth 4 times), replaced a rim (paint pealing off), replacing broken 3rd brake light. The car has 6600 miles on it.
wabibito is offline   Reply With Quote
Old 06-26-2012, 08:22 PM   #22
cmb74656

 
cmb74656's Avatar
 
Drives: 2011 Camaro 2SS/RS CGM/BLI A6
Join Date: Jul 2011
Location: Palmetto, FL
Posts: 978
1. Four-pack gauges plugged in. AC belt realigned. Loaner (never driven because they sold it while I had it.)
2. AC belt replaced.
3. AC belt, and harmonic balancer replaced. Check valve installed in heater hose. Differential fluid changed twice on same visit. Four day rental at no cost to me.
4. Transmission occasionally misses 3-4 upshift. Not taking it in until it becomes more frequent.
__________________
Dan Wheldon (1978-2011)

MODS: RX Performance catch can, Jegs CAI, ZL1 grille, chrome license plate frame, GM locking gas cap, Defender Worx chrome DRL bezels, GM molded splash guards, Oracle LED side markers, DRLs, tag lights and reverse lamps, Technostalgia Rapid Fire tail lamps, Vitesse shift paddle extenders, MBRP cat back.
FUTURE: long tube headers, front splitter, slotted/drilled rotors, leather console and e-brake handle boot, remote fuel door and rear seat release, sway bars and bushings.
WISH LIST: Edelbrock E-Force SC, LS3 conversion
cmb74656 is offline   Reply With Quote
Old 06-26-2012, 09:11 PM   #23
infernometallicSS
 
infernometallicSS's Avatar
 
Drives: 2012 Camaro SS Best Run - 10.93@125
Join Date: Feb 2012
Location: Laveen, AZ
Posts: 541
Warranty?? What's that. Voided mine 2 months into having it.
__________________
infernometallicSS is offline   Reply With Quote
Old 06-26-2012, 09:16 PM   #24
Grey Ghost

 
Grey Ghost's Avatar
 
Drives: 2013 HWSE 2SS
Join Date: Jun 2012
Location: Nokomis, FL
Posts: 1,305
Glove box wouldn't close without being pushed hard the day I bought it. They ordered a new one and replaced it 11 miles on the odometer.
__________________
2013 Hot Wheels 2SS
Grey Ghost is offline   Reply With Quote
Old 06-26-2012, 09:20 PM   #25
heRS


 
heRS's Avatar
 
Drives: IBM 2010 2LT RS M6
Join Date: Jul 2010
Location: Spokane, WA
Posts: 6,047
I noticed one day that my windshield wiper arm endcap was missing, they replaced it under warranty.
__________________
Tori
click the sig pic to view my build thread


heRS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.