Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-26-2012, 06:06 PM   #1
=Stephens=


 
=Stephens='s Avatar
 
Drives: 2011 LS
Join Date: Feb 2011
Location: Kearney, Nebraska
Posts: 3,460
How many have used your warranty?

Our cars are still fairly new, but some have had issues and some have not. I am at 31,000 miles and my 36k warranty will be up, just wondered who had redeemed on their warranty and what was it for?
__________________
=Stephens= is offline   Reply With Quote
Old 06-26-2012, 06:06 PM   #2
Gigachip
Yea...
 
Gigachip's Avatar
 
Drives: Depends on game
Join Date: May 2010
Location: My Computer
Posts: 10,265
Send a message via AIM to Gigachip
warranty voided less than a year after I got it

well it was voided, but I forgot to add I did have warranty work for a fog light that went out last year Nov.
__________________
2011 Camaro RJT 2SS/RS - Mods: Cold Air Inductions(CAI) Intake, TSP Long Tube Headers w/high flow cats + Magnaflow Catback, Jannetty Racing Tune
2003 4.8L Silverado White 2WD Ext. Cab - Mods: Intake(self made), BBK Throttle Body, Pacesetter Shorty Headers, Magnaflow Catback, Cam(forgot specs), tune (forgot company)
2012 Raptor Black SCAB - Mods: Throttle Body Spacer (lol wut?) <--actually only thing my wife agreed to because of $40. Taking full advantage whether or not any performance increase
Gigachip is offline   Reply With Quote
Old 06-26-2012, 06:07 PM   #3
Steve Dallas
Commits weekly crime
 
Steve Dallas's Avatar
 
Drives: 2016 Corvette Z06/Z07, AudiQ53.0T
Join Date: Nov 2009
Location: Camano Island, WA
Posts: 9,101
I used my warranty, but it was the Extended one I bought, not the one that comes with the car. Was for a corroded fusebox. Covered the rental too for 3 days.
__________________
'16 Corvette Z06/Z07, '13 Audi Q5 S-Line 3.0T
I fire up the willing engine, responding with a roar. Tires spitting gravel I commit my weekly crime.
Steve Dallas is offline   Reply With Quote
Old 06-26-2012, 06:08 PM   #4
hawkfe
 
hawkfe's Avatar
 
Drives: 2014 Stingray 3LT
Join Date: Nov 2009
Location: TX
Posts: 740
Had to replace the radiator at 800 miles, since then been trouble free.
hawkfe is offline   Reply With Quote
Old 06-26-2012, 06:19 PM   #5
kjkjr27
COTW 9/16/13
 
kjkjr27's Avatar
 
Drives: 2011 2LT/RS Camaro IOM
Join Date: Jan 2012
Location: Syracuse
Posts: 10,073
At around 7000 miles my breaks were squeeling real bad, brought them in to have them looked at, other than that I haven't used the warranty. I wonder though if you voided your factory warranty with at tune or something if you could still get an extended warranty, prob not.
__________________
kjkjr27 is offline   Reply With Quote
Old 06-26-2012, 06:22 PM   #6
Dirtdog
Pro Hide n Seek Player
 
Dirtdog's Avatar
 
Drives: 2010 IOM SS/RS LS3/LSA 550/510
Join Date: May 2009
Location: Tucson, AZ
Posts: 894
Send a message via AIM to Dirtdog
Money shif.... I mean, something happened to my valvetrain and they fixed it for free
__________________

550whp/510tq. ADM LSA Conversion, PFADT Tri-Y Headers into Borla S, PFADT Swaybars, Springs, Links, 20x10 20x11 Forgestar F14s, Lots of AAC
Dirtdog is offline   Reply With Quote
Old 06-26-2012, 06:23 PM   #7
Jason@JacFab
www.jacfab.com

 
Jason@JacFab's Avatar
 
Drives: 2016 1LT RS Camaro; 72 Chevelle
Join Date: Apr 2008
Location: Central Point, OR
Posts: 4,580
Send a message via AIM to Jason@JacFab Send a message via MSN to Jason@JacFab
Stabilitrac problems at ~6k... Clutch/flywheel/Pressure plate/TOB/Slave replaced at 9k miles. Big exhaust leak at manifold to exhaust pipe (stud came out, I couldn't get threads to start myself after trying for an hour, took it in) at ~12k. At about 21k now, and been fine so far since the last issue.
__________________

Specializing in attractive "no drill" front license plate brackets for the 2010+ Camaro Check out our new website! www.jacfab.com
2016 Camaro 1LT RS; NGM; 2.0T A8.
Jason@JacFab is offline   Reply With Quote
Old 06-26-2012, 06:38 PM   #8
kalimus

 
kalimus's Avatar
 
Drives: '14 Z51 3LT Stingray and '13 Cruze
Join Date: Feb 2010
Location: US of A
Posts: 1,331
32k miles, no warranty issues. Although my seat levers don't work that well, so I'll probably take it in soon to have them fix that issue.
kalimus is offline   Reply With Quote
Old 06-26-2012, 06:44 PM   #9
007s 'Vert
Formerly Lil'BlueCoupe
 
007s 'Vert's Avatar
 
Drives: '13 2LT/RS Vert, Summit White
Join Date: Jul 2009
Location: Vegas Baby!!!!!!!!
Posts: 1,771
My dome light didnt work correctly right of the showroom floor, had it repaired within a week, since then.............not one freakin problem
__________________
007s 'Vert is offline   Reply With Quote
Old 06-26-2012, 06:45 PM   #10
5150 Maro
 
5150 Maro's Avatar
 
Drives: 2012 SS 45th Anniversary
Join Date: Nov 2009
Location: Manteca, CA
Posts: 298
oil leak at 6,000 miles, replaced rear seal
5150 Maro is offline   Reply With Quote
Old 06-26-2012, 06:47 PM   #11
5150 Maro
 
5150 Maro's Avatar
 
Drives: 2012 SS 45th Anniversary
Join Date: Nov 2009
Location: Manteca, CA
Posts: 298
Not on the 12 but on my SW 2010 SS
5150 Maro is offline   Reply With Quote
Old 06-26-2012, 06:52 PM   #12
molsonbrador

 
molsonbrador's Avatar
 
Drives: 2010 Camaro SS, 99 Silverado
Join Date: Nov 2009
Location: NJ
Posts: 2,098
Used mine to have dealer deposit a spoiler nut inside my trunk lid. I still haven't fished it out.
molsonbrador is offline   Reply With Quote
Old 06-26-2012, 06:53 PM   #13
Rangore

 
Rangore's Avatar
 
Drives: 2012 Camaro 2SS 45th Anniversary Ed
Join Date: Oct 2011
Location: Minnesota
Posts: 2,236
Timing chain replaced at 35k and the small strips of leather that hold the driver and passenger seat belts had some threads coming loose. Entire leather seat covers for both driver and passenger replaced at 35k miles too.


Sent from my iPhone using Tapatalk
__________________
2012 Camaro 2SS 45th Anniversary Edition - No longer owned: 2010 Camaro 2LT, 1993 Camaro Z-28
Rangore is offline   Reply With Quote
Old 06-26-2012, 06:53 PM   #14
The Magic Man
Now u see me..now u dont!
 
The Magic Man's Avatar
 
Drives: Blue Magic '11 IBM 2LT/RS M6
Join Date: Mar 2010
Location: West Covina, CA
Posts: 131
Just before 36k. Font driver side caliper sticking. replaced, new brakes on both sides plus rental for 3 days
The Magic Man is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:28 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.