Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-02-2012, 08:54 PM   #1
caligrown562
 
Drives: 2012 1SS
Join Date: May 2011
Location: so cal
Posts: 318
2012 ss feels sluggish

I bought a 12 ls3 a couple months ago and it's starting to feel real slow. I am pretty sure the dealer put 87 in it so I did a fuse pull awhile back but I only let it sit for a couple hours. should I try again and how long should I let it sit?
caligrown562 is offline   Reply With Quote
Old 07-02-2012, 09:09 PM   #2
ckaram

 
ckaram's Avatar
 
Drives: 2011 2SS RS, 1968 ragtop
Join Date: Apr 2009
Location: Indiana
Posts: 1,630
Let it sit overnight. Easiest way. Pull the fuses before nighty-night.
__________________
1968 Camaro convertible, LS1 & T56, Texas Speed 228R cam, 3.42 posi, 17" Torque Thrusts
2011 2SS/RS, LS3, M6, IOM in and out, factory Hurst short throw, GMPP axleback exhaust
ckaram is offline   Reply With Quote
Old 07-02-2012, 09:13 PM   #3
midnighter
Account Suspended
 
Drives: nothing
Join Date: Nov 2010
Location: a hole
Posts: 21,173
Time to trade up to the V10.
midnighter is offline   Reply With Quote
Old 07-02-2012, 09:19 PM   #4
ec1990

 
Drives: 2012 AGM SS
Join Date: Jun 2012
Location: Las Vegas
Posts: 1,412
Is there 93 in the tank? If you did the fuse pull with 87 in the tank it won't reset. I've also heard of people doing a battery unplug overnight to somewhat reset the ECM, don't know the validity of it though.
ec1990 is offline   Reply With Quote
Old 07-02-2012, 09:22 PM   #5
PonyKiller74
 
PonyKiller74's Avatar
 
Drives: 2012 Triple Black ZL1 M6
Join Date: Jun 2010
Location: San Antonio, TX
Posts: 583
Send a message via AIM to PonyKiller74 Send a message via Yahoo to PonyKiller74
Quote:
Originally Posted by midnighter View Post
Time to trade up to the V10.
__________________
CenterForce DYAD Dual Disc Clutch, more to come...
Build Thread for my Z is in the works.....
PonyKiller74 is offline   Reply With Quote
Old 07-02-2012, 10:16 PM   #6
caligrown562
 
Drives: 2012 1SS
Join Date: May 2011
Location: so cal
Posts: 318
to me feels like something's holding it back. when I first bought it you would barely touch the gas and it goes but now you really got to get on it. I have been having issues with my clutch so maybe its starting to slip alittle. is their a tsb for the rear ends on the 12s for changing the fluid. cause every morning you can hear it groan alittle like the plates are sticking?
caligrown562 is offline   Reply With Quote
Old 07-06-2012, 10:17 AM   #7
EasyT442
 
Drives: 2012 45th ed SS/RS Camaro
Join Date: Jul 2012
Location: Charleston, SC
Posts: 11
Pulling Fuse to reset ECU

This may be a dumb question, but I have a 2012 SS and it doesn't seem to have the get up and go the demo I drove had. I see others talking about pulling fuses to reset the system, but exactly which fuses are they?
EasyT442 is offline   Reply With Quote
Old 07-06-2012, 10:21 AM   #8
TheHorse13

 
TheHorse13's Avatar
 
Drives: 2011 Black SS M6
Join Date: Oct 2010
Location: Harpers Ferry, WV
Posts: 871
Fuse #5 and #20.

You can find a diagram on this site if you search for fuse pull.


Quote:
Originally Posted by EasyT442 View Post
This may be a dumb question, but I have a 2012 SS and it doesn't seem to have the get up and go the demo I drove had. I see others talking about pulling fuses to reset the system, but exactly which fuses are they?
TheHorse13 is offline   Reply With Quote
Old 07-06-2012, 10:26 AM   #9
Juiced1
JUICED MOTORSPORTS

 
Juiced1's Avatar
 
Drives: 2012 2SS CAMARO 45th
Join Date: Apr 2011
Location: IL
Posts: 10,807
Quote:
Originally Posted by caligrown562 View Post
I bought a 12 ls3 a couple months ago and it's starting to feel real slow. I am pretty sure the dealer put 87 in it so I did a fuse pull awhile back but I only let it sit for a couple hours. should I try again and how long should I let it sit?

Fill it up with some 93 and do a fuse pull. If that doesn't wake her up give us a call and we'll take it from there.
__________________
Get more Power per Dollar!!!! We carry all the hot new products for your 5th gen! CAI, Roto-Fab, Solo, Corsa, MBRP, ARH, Stainless Works, MRT, SLP, Procharger, Whipple, BMR, Diablosport, Superchips, Street Scene, VFN Fiberglass and much more. Contact us for your Camaro5 discount today!
Call us at 224-63-JUICE - 224-400-5793
Juiced1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.