Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 07-05-2012, 10:29 AM   #1
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 464
Normal to get condensation on the inside of the radio display?

Getting condensation on the inside of the radio display. Usually happens when it's humid and have the ac running, then decide to put down the window. I know condensation itself is normal but just worried about it being on the inside....



Sent from my DROID RAZR using Tapatalk 2
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 10:30 AM   #2
alanhurst
Master Chief
 
alanhurst's Avatar
 
Drives: 2011 Camaro SS RS L99
Join Date: May 2012
Location: Shippensburg, PA
Posts: 416
i've never had it yet,gonna have to say no.
__________________
alanhurst is offline   Reply With Quote
Old 07-05-2012, 10:36 AM   #3
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 464
Yeah I'm thinking there's some type of gasket or sealant that failed...
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 12:29 PM   #4
Grey Ghost

 
Grey Ghost's Avatar
 
Drives: 2013 HWSE 2SS
Join Date: Jun 2012
Location: Nokomis, FL
Posts: 1,304
I run my ac non stop in my car and have never seen that. Get that serviced.
__________________
2013 Hot Wheels 2SS
Grey Ghost is offline   Reply With Quote
Old 07-05-2012, 02:00 PM   #5
ravensjeff
100% Chevy & Harley Man
 
ravensjeff's Avatar
 
Drives: 2010 2SS: Blown LSX 376-B15
Join Date: Feb 2009
Location: Eldersburg,MD
Posts: 2,201
Never had that, but I did get my radio head unit replaced due to black lines showing up where it should have been blue.
__________________
LSX 376-B15, TVS2300 SC, Harland Sharp Rockers with Trunion Bearing, ATI Balancer/keyed, AR Headers/Borla Catback Exhaust, DSS 1400 HP Axles, 3.70, Hotchkis Springs/Sway bars, Forgeline SO3P Aluminum Wheels (20x9.5 F/20x11 R)with Hidden Lightweight Titanium Hardware, Nitto NT05 Tires (27540ZR20 F/31535ZR20 R), Billet LPE brake/gas pedals, Escort 9500ci Radar Detector Laser Jammer, Roto Fab CAI with Ice Silver box, Carbon fiber tube/MAF Housing Assy, LPE Aluminum coil covers, SS9 Sleeper Fiber Glass Hood (ACS), Carbotech 1521 ceramic brake pads, Elite catch can.
ravensjeff is offline   Reply With Quote
Old 07-05-2012, 02:04 PM   #6
GibbyGil
 
GibbyGil's Avatar
 
Drives: 2011 Camaro LS
Join Date: Dec 2011
Location: Houston, Texas
Posts: 251
I had condensation in my radio also, but after awhile it disappeared on its own

I wouldn't worry about it.
__________________
My Build Thread
GibbyGil is offline   Reply With Quote
Old 07-05-2012, 02:07 PM   #7
camarofreak
 
camarofreak's Avatar
 
Drives: 2011 Silverado LT
Join Date: Jun 2009
Location: United States
Posts: 168
Same type of thing happened in my silverado took it to local dealership and they couldnt find anything wrong with it.
camarofreak is offline   Reply With Quote
Old 07-05-2012, 02:22 PM   #8
IamJacksCamaro
 
IamJacksCamaro's Avatar
 
Drives: Camaro LS M6, Fiero, Ford F100
Join Date: May 2010
Location: Ohio
Posts: 638
i would say that is not normal. Hasn't happened to mine.
IamJacksCamaro is offline   Reply With Quote
Old 07-05-2012, 02:50 PM   #9
ShowSStopper
Account Suspended
 
Drives: 2012 Camaro 1SS Black Coupe
Join Date: May 2012
Location: Houston
Posts: 1,092
Hasn't happened to mine yet. Wouldn't hurt to have it checked out.
ShowSStopper is offline   Reply With Quote
Old 07-05-2012, 02:58 PM   #10
enjoyingtheride
 
Drives: 2010 Camaro
Join Date: Jul 2011
Location: Wisconsin
Posts: 9
Bring it to the dealer!
enjoyingtheride is offline   Reply With Quote
Old 07-05-2012, 03:01 PM   #11
bradshaw
 
bradshaw's Avatar
 
Drives: 2010 LS3 2SS M6
Join Date: Mar 2010
Location: Lafayette, La
Posts: 153
Lowering your window lets in hot humid air which is then condensing on the ice cold parts in the radio.
bradshaw is offline   Reply With Quote
Old 07-05-2012, 04:21 PM   #12
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 464
Quote:
Originally Posted by bradshaw View Post
Lowering your window lets in hot humid air which is then condensing on the ice cold parts in the radio.
Yeah but shouldn't it condense on the outside? Inside doesn't sound right...
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 04:47 PM   #13
Duflar
 
Duflar's Avatar
 
Drives: 2011 Camaro 2SS RS
Join Date: Aug 2010
Location: Massachusetts
Posts: 383
Looks to me like there is a leak in the air duct blowing cold air onto the radio chassis.
Have the dealer/mechanic check it out. Condensation on the back side of the plastic window can't be good for the LCD or whaterver tech the display is.
__________________
<img src=http://www.camaro5.com/forums/image.php?type=sigpic&userid=31288&dateline=1309279779 border=0 alt= />
Duflar is offline   Reply With Quote
Old 07-05-2012, 04:49 PM   #14
clg_98ta


 
clg_98ta's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2010
Location: Austin, TX
Posts: 2,704
Quote:
Originally Posted by IamJacksCamaro View Post
i would say that is not normal. Hasn't happened to mine.

+1
__________________
Black 2SS ordered 1/4/2010, received 2/19/2010



clg_98ta is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.