Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 07-05-2012, 10:29 AM   #1
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 461
Normal to get condensation on the inside of the radio display?

Getting condensation on the inside of the radio display. Usually happens when it's humid and have the ac running, then decide to put down the window. I know condensation itself is normal but just worried about it being on the inside....



Sent from my DROID RAZR using Tapatalk 2
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 10:30 AM   #2
alanhurst
Master Chief
 
alanhurst's Avatar
 
Drives: 2011 Camaro SS RS L99
Join Date: May 2012
Location: Shippensburg, PA
Posts: 416
i've never had it yet,gonna have to say no.
__________________
alanhurst is offline   Reply With Quote
Old 07-05-2012, 10:36 AM   #3
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 461
Yeah I'm thinking there's some type of gasket or sealant that failed...
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 12:29 PM   #4
Grey Ghost

 
Grey Ghost's Avatar
 
Drives: 2013 HWSE 2SS
Join Date: Jun 2012
Location: Nokomis, FL
Posts: 1,305
I run my ac non stop in my car and have never seen that. Get that serviced.
__________________
2013 Hot Wheels 2SS
Grey Ghost is offline   Reply With Quote
Old 07-05-2012, 02:00 PM   #5
ravensjeff
100% Chevy & Harley Man
 
Drives: 650 HP Forged Internals-549 HP rear
Join Date: Feb 2009
Location: Eldersburg,MD
Posts: 2,050
Never had that, but I did get my radio head unit replaced due to black lines showing up where it should have been blue.
__________________
Forged & Tuned by Lingenfelter!
ravensjeff is offline   Reply With Quote
Old 07-05-2012, 02:04 PM   #6
GibbyGil
 
GibbyGil's Avatar
 
Drives: 2011 Camaro LS
Join Date: Dec 2011
Location: Houston, Texas
Posts: 252
I had condensation in my radio also, but after awhile it disappeared on its own

I wouldn't worry about it.
__________________
My Build Thread
GibbyGil is offline   Reply With Quote
Old 07-05-2012, 02:07 PM   #7
camarofreak
 
camarofreak's Avatar
 
Drives: 2011 Silverado LT
Join Date: Jun 2009
Location: United States
Posts: 168
Same type of thing happened in my silverado took it to local dealership and they couldnt find anything wrong with it.
camarofreak is offline   Reply With Quote
Old 07-05-2012, 02:22 PM   #8
IamJacksCamaro
 
IamJacksCamaro's Avatar
 
Drives: Camaro LS M6, Fiero, Ford F100
Join Date: May 2010
Location: Ohio
Posts: 639
i would say that is not normal. Hasn't happened to mine.
IamJacksCamaro is offline   Reply With Quote
Old 07-05-2012, 02:50 PM   #9
ShowSStopper
Account Suspended
 
Drives: 2012 Camaro 1SS Black Coupe
Join Date: May 2012
Location: Houston
Posts: 1,092
Hasn't happened to mine yet. Wouldn't hurt to have it checked out.
ShowSStopper is offline   Reply With Quote
Old 07-05-2012, 02:58 PM   #10
enjoyingtheride
 
Drives: 2010 Camaro
Join Date: Jul 2011
Location: Wisconsin
Posts: 9
Bring it to the dealer!
enjoyingtheride is offline   Reply With Quote
Old 07-05-2012, 03:01 PM   #11
bradshaw
 
bradshaw's Avatar
 
Drives: 2010 LS3 2SS M6
Join Date: Mar 2010
Location: Lafayette, La
Posts: 116
Lowering your window lets in hot humid air which is then condensing on the ice cold parts in the radio.
bradshaw is offline   Reply With Quote
Old 07-05-2012, 04:21 PM   #12
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 461
Quote:
Originally Posted by bradshaw View Post
Lowering your window lets in hot humid air which is then condensing on the ice cold parts in the radio.
Yeah but shouldn't it condense on the outside? Inside doesn't sound right...
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 04:47 PM   #13
Duflar
 
Duflar's Avatar
 
Drives: 2011 Camaro 2SS RS
Join Date: Aug 2010
Location: Massachusetts
Posts: 376
Looks to me like there is a leak in the air duct blowing cold air onto the radio chassis.
Have the dealer/mechanic check it out. Condensation on the back side of the plastic window can't be good for the LCD or whaterver tech the display is.
__________________
<img src=http://www.camaro5.com/forums/image.php?type=sigpic&userid=31288&dateline=1309279779 border=0 alt= />
Duflar is offline   Reply With Quote
Old 07-05-2012, 04:49 PM   #14
clg_98ta


 
clg_98ta's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2010
Location: Austin, TX
Posts: 2,701
Quote:
Originally Posted by IamJacksCamaro View Post
i would say that is not normal. Hasn't happened to mine.

+1
__________________
Black 2SS ordered 1/4/2010, received 2/19/2010



clg_98ta is offline   Reply With Quote
Old 07-05-2012, 04:50 PM   #15
PQ
1st State Chevy supporter
 
PQ's Avatar
 
Drives: Hybrid SS Camaro
Join Date: Apr 2008
Location: Mobile, AL
Posts: 36,912
Send a message via Yahoo to PQ
Interesting. I had that happen to me too a couple years ago. Car was sitting up on jackstands while my piece of shit Savini wheels were on one of their standard trips to California and it was really humid and hot in the garage.

It dried out and never did it again.
__________________
PQ is online now   Reply With Quote
Old 07-05-2012, 05:23 PM   #16
GRRRRAH
 
GRRRRAH's Avatar
 
Drives: 2012 AGM Camaro Convertible
Join Date: May 2012
Location: Silver Spring, MD
Posts: 7
This has happened to mine too--a brand new 2012. But only once--I had the two center vents blowing down (like you do in your photo). Once I redirected the vents, the dew slowly disappeared.
GRRRRAH is offline   Reply With Quote
Old 07-05-2012, 07:11 PM   #17
hightower
LS3 Black Widow
 
hightower's Avatar
 
Drives: 2012 45th 2SS LS3 and 1968 Mustang
Join Date: Nov 2011
Location: Madison, GA
Posts: 4,561
Quote:
Originally Posted by GibbyGil View Post
I had condensation in my radio also, but after awhile it disappeared on its own

I wouldn't worry about it.
I agree.


OP, give it some time and see if it goes away. If not, then be concerned.
__________________
hightower is offline   Reply With Quote
Old 07-05-2012, 08:50 PM   #18
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 461
Quote:
Originally Posted by hightower View Post
I agree.


OP, give it some time and see if it goes away. If not, then be concerned.
Well, it isn't the first time its happened. The first time it did I was going to wait and see, but its happening more often now...
BaldCamaroStud is offline   Reply With Quote
Old 07-05-2012, 10:29 PM   #19
MrGood

 
MrGood's Avatar
 
Drives: Broken palmghetto test car
Join Date: Oct 2009
Location: Balm, FL
Posts: 1,034
Send a message via Yahoo to MrGood
Had it. Lost it.
MrGood is offline   Reply With Quote
Old 07-06-2012, 07:56 AM   #20
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,729
Quote:
Originally Posted by DieHardBattery View Post
Getting condensation on the inside of the radio display. Usually happens when it's humid and have the ac running, then decide to put down the window. I know condensation itself is normal but just worried about it being on the inside....



Sent from my DROID RAZR using Tapatalk 2
I am sorry to hear of the concern you are having. Depending if you’re A/C is on recirculation or not may be the cause of the condensation. Nonetheless, it may be best to take it to your dealership for diagnosis to see exactly why this is happening. Please contact me with any details and I look forward to your updates.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 07-06-2012, 09:15 AM   #21
BaldCamaroStud
Camaro Owner & Enthusiast
 
BaldCamaroStud's Avatar
 
Drives: 2013 Camaro 2SS/RS
Join Date: May 2011
Location: Houston, TX
Posts: 461
Hey Brandon. I talked to a couple dealers this morning, one pointed me to a bulletin that says the condition can occur if the center vents are pointed down toward the radio (which they are). So I'll try that and see if it goes away. I normally blast it too so, the bulletin also said to turn down the blower once the interior gets cool. I'll try those suggestions and keep an eye on it.
BaldCamaroStud is offline   Reply With Quote
Old 07-06-2012, 09:25 AM   #22
strych9
Gone Euro!
 
strych9's Avatar
 
Drives: 6spd Manual Mercedes
Join Date: Apr 2012
Location: Omaha, NE
Posts: 3,032
Mine does it too. It clears up after the A/C gets all the humidity out of the car. I've heard others say the same thing. It's normal.
__________________
Bye bye, Bumblebee!
---------------------------------------------------------------------------------------
strych9 is offline   Reply With Quote
Old 07-06-2012, 09:31 AM   #23
Shu71

 
Drives: 2011 Camaro RS M6
Join Date: Jan 2011
Location: Illinois
Posts: 788
What a crack up! You should be able to point vents anywhere in their range of motion and not cause another problem like this! Also seriously "turn the blower down" is their second advice? The seal between lens and the LCD is not working. They should replace the stereo but they don't want to because A LOT are having this same problem. Mine does this too and it's is frustrating to hear GM pull a weak move like they did to you.
__________________
Shu71 is offline   Reply With Quote
Old 07-06-2012, 10:17 AM   #24
All Star
I'm an Engineer
 
All Star's Avatar
 
Drives: 2012 Camaro 2LS
Join Date: Feb 2012
Location: Ocean County, New Jersey
Posts: 669
Send a message via AIM to All Star
Don't freak out over it...see if it dries out after a few days, if not, have your dealer look at it.
__________________

All Star is online now   Reply With Quote
Old 07-06-2012, 10:20 AM   #25
orangejuice
H1 OFCR
 
orangejuice's Avatar
 
Drives: 2013 ZL1 Blue Ray Metallic
Join Date: Jun 2011
Location: Shelby Twp., Michigan
Posts: 1,342
Quote:
Originally Posted by DieHardBattery View Post
Getting condensation on the inside of the radio display. Usually happens when it's humid and have the ac running, then decide to put down the window. I know condensation itself is normal but just worried about it being on the inside....



Sent from my DROID RAZR using Tapatalk 2


Yeah definitely not normal. Should not have condensation on the inside of your radio.
__________________
Corsa
Rotofab
BBK
ZL1 Hood/Fascia
AAC Afterburners/Sidemarkers
Havoc Black Chrome
5% Tint/20% Smoked Taillights


orangejuice is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.