Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 07-06-2012, 07:10 PM   #1
Topnation
 
Topnation's Avatar
 
Drives: White 2012 Camaro 2Lt RS
Join Date: Jun 2012
Location: Dallas Texas
Posts: 30
Ground For Amplifier

Just curious but where did yall ground yalls amplifier to for your audio systems? Im having a hard time finding a good ground spot and looks like I might have to drill
Topnation is offline   Reply With Quote
Old 07-06-2012, 07:19 PM   #2
jeepguy_1980

 
jeepguy_1980's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: May 2010
Location: Newport News
Posts: 1,311
My battery
jeepguy_1980 is offline   Reply With Quote
Old 07-06-2012, 07:23 PM   #3
CWI
Helping Build America
 
CWI's Avatar
 
Drives: 2010 2SS/RS,LS3 2013 Duramax 3500HD
Join Date: Aug 2008
Location: Nationwide
Posts: 3,761
If you take out the trunk trim, you will find a hole in the chassis structure just below the rear deck. Make sure to sand off the paint and use a star washer to ensure a good connection. Make sure to use wire at least as heavy as your power cable.

I used this location because it was convenient and quite adequate. I am running a 1/0 cable from there to a block for three high power amps and have no problems whatsoever. No power issues, even with the BA head unit, there isn't even any detectable hiss between songs at high volume
__________________
Life's journey is not to arrive at the grave safely in a well preserved body, but rather to skid in sideways, totally worn out, shouting "Holy shit, what a ride!"
CWI is offline   Reply With Quote
Old 07-06-2012, 07:35 PM   #4
jeepguy_1980

 
jeepguy_1980's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: May 2010
Location: Newport News
Posts: 1,311
Quote:
Originally Posted by CWIweldace View Post
even with the BA head unit
a.k.a. The only head unit. 2013 models not withstanding.
jeepguy_1980 is offline   Reply With Quote
Old 07-06-2012, 07:51 PM   #5
Topnation
 
Topnation's Avatar
 
Drives: White 2012 Camaro 2Lt RS
Join Date: Jun 2012
Location: Dallas Texas
Posts: 30
CWI I will check that spot and Jeepguy ill do battery if all other possibilities dont work. Thank you
Topnation is offline   Reply With Quote
Old 07-06-2012, 08:55 PM   #6
CWI
Helping Build America
 
CWI's Avatar
 
Drives: 2010 2SS/RS,LS3 2013 Duramax 3500HD
Join Date: Aug 2008
Location: Nationwide
Posts: 3,761
That spot is on either side below the rear deck but above the fender well. It's maybe a 3/8"-7/16" hole in the sheet metal. I think I used a 5/16" bolt. Very solid ground. Like I said, just be sure to clean the paint and I recommend a star washer for better contact.
__________________
Life's journey is not to arrive at the grave safely in a well preserved body, but rather to skid in sideways, totally worn out, shouting "Holy shit, what a ride!"
CWI is offline   Reply With Quote
Old 07-06-2012, 10:15 PM   #7
yzark99
 
yzark99's Avatar
 
Drives: 2012 Silver Ice 1LT
Join Date: Oct 2011
Location: Yunkjun Zity, UrEgun
Posts: 354
I used one of the protruding studs under the rear deck, next to a 6x9 speaker. I think it is a 5 or 6mm nut, fine thread. I sanded the stud area, used a flat washer, a copper electrical lug that is attached to a 4-gauge ground wire, a star washer, another flat washer and a nylock nut to hold the whole mess together and prevent it from vibrating loose.
__________________
yzark99 is offline   Reply With Quote
Old 07-07-2012, 12:25 AM   #8
Topnation
 
Topnation's Avatar
 
Drives: White 2012 Camaro 2Lt RS
Join Date: Jun 2012
Location: Dallas Texas
Posts: 30
I just wired it to my battery and sups play good! thanks for the help and the Ideas.
Topnation is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.