Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
SDPC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 07-10-2012, 07:47 AM   #1
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 618
WTH is this smell?

Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox

Last edited by MustangKiller; 07-10-2012 at 11:15 AM.
MustangKiller is offline   Reply With Quote
Old 07-10-2012, 01:22 PM   #2
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 527
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
Hannibal is offline   Reply With Quote
Old 07-10-2012, 04:34 PM   #3
C5RocksC5
Banned
 
C5RocksC5's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Jul 2009
Location: Sin City
Posts: 697
its the Mustang you killed.
C5RocksC5 is offline   Reply With Quote
Old 07-10-2012, 04:50 PM   #4
ChrisBlair
Buick 455 Fan
 
Drives: 1970 Buick, 2012 1SS LS3
Join Date: Jun 2010
Location: Boston MA
Posts: 5,692
Ain't smelled nothing but rubber and the clutch
__________________
ChrisBlair is offline   Reply With Quote
Old 07-10-2012, 06:43 PM   #5
dcplus14
 
dcplus14's Avatar
 
Drives: '12 Camaro 2SS/RS/Hurst
Join Date: Jan 2012
Location: San Diego
Posts: 481
Quote:
Originally Posted by Hannibal View Post
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
What is the TSB for that, I can't seem to find it on here.
__________________
2012 Camaro 2SS/RS: Black on Black, Hurst
[AAC DRL LED's, AAC LED's for trunk, cabin, license plate, CAI Intake, RX Catch Can, Skip shift eliminator, Pedders Sub-Frame Inserts, Pedders Radius Rod Inserts, Pedders Rack & Pinion Bushing, 1LE front and rear sway bars]
dcplus14 is offline   Reply With Quote
Old 07-10-2012, 08:12 PM   #6
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 618
Quote:
Originally Posted by pdari View Post
its the Mustang you killed.
Lol
MustangKiller is offline   Reply With Quote
Old 07-10-2012, 08:52 PM   #7
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 139
Quote:
Originally Posted by MustangKiller View Post
Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox
It's the Dexcool & rubber hoses causing a chemical reaction! GM had to give me a new car due to not being able to get rid of the stink.. They changed the hoses and coolant out 3 times but it kept comming back! But there have been others that had it go away with the same fix... GOOD LUCK! I never did get to enjoy the new car smell with that car!!
kfm237 is offline   Reply With Quote
Old 07-11-2012, 05:42 AM   #8
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 527
I don't know the TSB number but I have seen it posted here and it involves replacing all hoses and coolant.
Hannibal is offline   Reply With Quote
Old 07-11-2012, 05:53 AM   #9
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 139
The bulletin #pip4988: Objectionable underhood odor from coolant - Flush cooling system and replace all rubber hoses (Dec 20,2011)
kfm237 is offline   Reply With Quote
Old 07-11-2012, 09:45 AM   #10
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,231
Quote:
Originally Posted by MustangKiller View Post
Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox
Please let us know if you have the option of taking this to the dealership for a proper diagnosis. Also, if you could update me if the service department was able to address the issue we would definitely appreciate the feedback!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 07-13-2012, 04:56 PM   #11
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 618
Is it going too go away with time? Why didnt i have this problem with my previous 2010?
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 04:58 PM   #12
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 618
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Please let us know if you have the option of taking this to the dealership for a proper diagnosis. Also, if you could update me if the service department was able to address the issue we would definitely appreciate the feedback!

Brandon
Chevrolet Customer Service
I PMed you months ago for your help with my prev camaro and never got a reply
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 04:59 PM   #13
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 618
Quote:
Originally Posted by Hannibal View Post
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
lol no not dirty socks more like rotting flesh
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 05:10 PM   #14
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 1,648
Since the combination of hoses and coolant is not exactly new technology, one wonders what is going on here!

Are Camaros being fitted with bogus Chinese hoses?
Rock-It Man is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.