Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-10-2012, 08:47 AM   #1
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
WTH is this smell?

Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox

Last edited by MustangKiller; 07-10-2012 at 12:15 PM.
MustangKiller is offline   Reply With Quote
Old 07-10-2012, 02:22 PM   #2
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 526
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
Hannibal is offline   Reply With Quote
Old 07-10-2012, 05:34 PM   #3
C5RocksC5
Banned
 
C5RocksC5's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Jul 2009
Location: Sin City
Posts: 697
its the Mustang you killed.
C5RocksC5 is offline   Reply With Quote
Old 07-10-2012, 05:50 PM   #4
ChrisBlair
Buick 455 Fan
 
Drives: 1970 Buick, 2012 1SS LS3
Join Date: Jun 2010
Location: Boston MA
Posts: 4,125
Ain't smelled nothing but rubber and the clutch
__________________
ChrisBlair is offline   Reply With Quote
Old 07-10-2012, 07:43 PM   #5
dcplus14
 
dcplus14's Avatar
 
Drives: '12 Camaro 2SS/RS/Hurst
Join Date: Jan 2012
Location: San Diego
Posts: 480
Quote:
Originally Posted by Hannibal View Post
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
What is the TSB for that, I can't seem to find it on here.
__________________
2012 Camaro 2SS/RS: Black on Black, Hurst
[AAC DRL LED's, AAC LED's for trunk, cabin, license plate, CAI Intake, RX Catch Can, Skip shift eliminator, Pedders Sub-Frame Inserts, Pedders Radius Rod Inserts, Pedders Rack & Pinion Bushing, 1LE front and rear sway bars]
dcplus14 is offline   Reply With Quote
Old 07-10-2012, 09:12 PM   #6
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Quote:
Originally Posted by pdari View Post
its the Mustang you killed.
Lol
MustangKiller is offline   Reply With Quote
Old 07-10-2012, 09:52 PM   #7
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 140
Quote:
Originally Posted by MustangKiller View Post
Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox
It's the Dexcool & rubber hoses causing a chemical reaction! GM had to give me a new car due to not being able to get rid of the stink.. They changed the hoses and coolant out 3 times but it kept comming back! But there have been others that had it go away with the same fix... GOOD LUCK! I never did get to enjoy the new car smell with that car!!
kfm237 is offline   Reply With Quote
Old 07-11-2012, 06:42 AM   #8
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 526
I don't know the TSB number but I have seen it posted here and it involves replacing all hoses and coolant.
Hannibal is offline   Reply With Quote
Old 07-11-2012, 06:53 AM   #9
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 140
The bulletin #pip4988: Objectionable underhood odor from coolant - Flush cooling system and replace all rubber hoses (Dec 20,2011)
kfm237 is offline   Reply With Quote
Old 07-11-2012, 10:45 AM   #10
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,772
Quote:
Originally Posted by MustangKiller View Post
Well since day 1 its smelled like somthing has died under my hood. I havnt taken it in yet but im guessing its either the dexcool or the rubber hoses. Does anyone else experience this? It seems like its stronger on the passenger side an for the longest time i thought i had a dead mouse or somthin inside the fusebox
Please let us know if you have the option of taking this to the dealership for a proper diagnosis. Also, if you could update me if the service department was able to address the issue we would definitely appreciate the feedback!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 07-13-2012, 05:56 PM   #11
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Is it going too go away with time? Why didnt i have this problem with my previous 2010?
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 05:58 PM   #12
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Please let us know if you have the option of taking this to the dealership for a proper diagnosis. Also, if you could update me if the service department was able to address the issue we would definitely appreciate the feedback!

Brandon
Chevrolet Customer Service
I PMed you months ago for your help with my prev camaro and never got a reply
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 05:59 PM   #13
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
Quote:
Originally Posted by Hannibal View Post
Does it smell like dirty socks? There is a TSB out this. The dexcool reacts with the rubber hoses and produces a stink that is in line with a sewage treatment plant.
lol no not dirty socks more like rotting flesh
MustangKiller is offline   Reply With Quote
Old 07-13-2012, 06:10 PM   #14
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 1,162
Since the combination of hoses and coolant is not exactly new technology, one wonders what is going on here!

Are Camaros being fitted with bogus Chinese hoses?
Rock-It Man is offline   Reply With Quote
Old 07-13-2012, 06:20 PM   #15
strych9
Gone Euro!
 
strych9's Avatar
 
Drives: 6spd Manual Mercedes
Join Date: Apr 2012
Location: Omaha, NE
Posts: 3,031
The TSB states that the hoses aren't fully cured, and that's what causes the smell. My 2012 doesn't stink, but it was built in December and I got it in April. Therefore, it will likely go away over time as the hoses cure.

A 2012 Malibu loaner I had smelled really bad that way. I empathize.

Edit: added a copy of the bulletin.
Attached Images
File Type: pdf PIP4988.pdf (78.2 KB, 88 views)
__________________
Bye bye, Bumblebee!
---------------------------------------------------------------------------------------

Last edited by strych9; 07-13-2012 at 06:27 PM. Reason: Added file
strych9 is offline   Reply With Quote
Old 07-13-2012, 10:56 PM   #16
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 465
come too think of it.... it smells exactly like the cheap rubber tires and tractor supply. I guess ill give it a little more time but it would be nicw too hear from some one that has been through this before.
MustangKiller is offline   Reply With Quote
Old 07-14-2012, 07:06 AM   #17
TheHorse13

 
TheHorse13's Avatar
 
Drives: 2011 Black SS M6
Join Date: Oct 2010
Location: Harpers Ferry, WV
Posts: 895
One guy on here with a 45th anniversary car had the smell so bad that GM bought the car back. The smell never went away for him. I hope you have better luck.
TheHorse13 is offline   Reply With Quote
Old 07-14-2012, 07:19 AM   #18
HorsePower-Freak
 
HorsePower-Freak's Avatar
 
Drives: 2011 Camaro 2SS M6
Join Date: Jun 2012
Location: Fort Worth, TX
Posts: 163
Quote:
Originally Posted by ChrisBlair View Post
Ain't smelled nothing but rubber and the clutch
TRUF!
__________________
Quote:
Originally Posted by HorsePower-Freak View Post
I know when I punch the gas pedal it makes ma D!#* move, and since that's a muscle.....I consider it a muscle car
HorsePower-Freak is offline   Reply With Quote
Old 07-14-2012, 09:47 AM   #19
Storm T
Can't slow down
 
Storm T's Avatar
 
Drives: 2013 SS Dusk Edition (Insain Bolt)
Join Date: Apr 2012
Location: Oklahoma
Posts: 324
I had that smell after about a week or so of owning my car. It was mainly when first starting up. I've had it now a few months and it's went away. I described it as mildewed clothes smell.
Storm T is offline   Reply With Quote
Old 09-01-2012, 02:19 AM   #20
GMTool

 
GMTool's Avatar
 
Drives: AGM 2012 Camaro 2SS/RS L99
Join Date: Mar 2012
Location: Southwest Illinois
Posts: 1,249
Quote:
Originally Posted by MustangKiller View Post
come too think of it.... it smells exactly like the cheap rubber tires and tractor supply. I guess ill give it a little more time but it would be nicw too hear from some one that has been through this before.
MustangKiller, did the smell ever go away? My car stinks up my garage on hot days. Cooler days, not so much. I guess maybe Ill take it to the dealer. See if they will change hoses and a coolant flush under warranty if it gets any worse.
__________________
CAI Cold Air Kit. Dynatech Headers. High Flow Cats. Corsa Catback. JRE Tune. OEM Strut Tower Brace

Last edited by GMTool; 09-01-2012 at 02:32 AM.
GMTool is offline   Reply With Quote
Old 09-01-2012, 08:19 AM   #21
kfm237
 
Drives: 2012 Camaro SS
Join Date: Jan 2012
Location: New Jersey
Posts: 140
I'm the one that got My 45th anniversary bought back due to the Dexcool smell.. Open the coolant reservoir tank and if it stinks, you have the rubber hose/coolant problem! My car would stink up a garage when hot and the foul smell would come through the vents at idle with the heat or a/c on. They replaced the hoses 3 times but the smell would slowly return everytime.. They finally bought it back and I got another Camaro.. Check out My posts for more info & good luck!
kfm237 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.