Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Dyno Max
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LFX Engine, Exhaust, and Bolt-Ons

Camaro V6 LFX Engine, Exhaust, and Bolt-Ons For all LFX related parts

Reply
 
Thread Tools
Old 08-06-2012, 10:38 AM   #1
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
Has anyone had to go in to get some warranty work done?

If so what was the problem? Thxs
C-redfly is offline   Reply With Quote
Old 08-06-2012, 10:41 AM   #2
JohnnyBfromPeoria

 
JohnnyBfromPeoria's Avatar
 
Drives: 2012 LS M6, Black
Join Date: May 2009
Location: Phoenix, AZ
Posts: 2,037
5K+ miles and not one issue. I'll avoid the dealer like the Plague.

John B.
__________________
12 LS M6, IPF S/C, ASA GT-5 wheels, VMax PTB
1995 Mitsubishi Montero SR
1987 Dodge Raider Turbo Project
1986 Mitsubishi Montero 2.4l FI Transplant
JohnnyBfromPeoria is offline   Reply With Quote
Old 08-06-2012, 11:30 AM   #3
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
Same here, I got 3k and no issues.
C-redfly is offline   Reply With Quote
Old 08-06-2012, 12:58 PM   #4
Jameg1011
 
Jameg1011's Avatar
 
Drives: 2012 2LT 45th anniversary
Join Date: Aug 2011
Location: New Jersey
Posts: 739
Had to have a few seals in the engine redone. Apparently they didn't install one of the main seals on the timing belt cover from the factory and it was leaking down the front of the engine block all over at 3500 miles. Had to go to the dealer 4 times before they agreed to take a look and fix it. Terrible customer service, and if i didn't love Camaro's so much i would have sold the car by now. Needless to say I'm still not happy and will hesitate before buying another chevy. Ive had a few more problems with the car which still arnt fixed, i just haven't had the time to get to another dealer as I will never return to my dealer.
Jameg1011 is offline   Reply With Quote
Old 08-06-2012, 01:40 PM   #5
323RSTX
 
323RSTX's Avatar
 
Drives: 2012 2LT/RS Victory Red
Join Date: Aug 2012
Location: Texas
Posts: 35
9335 miles & no problems. knock on wood.
323RSTX is offline   Reply With Quote
Old 08-06-2012, 01:51 PM   #6
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
Quote:
Originally Posted by Jameg1011 View Post
Had to have a few seals in the engine redone. Apparently they didn't install one of the main seals on the timing belt cover from the factory and it was leaking down the front of the engine block all over at 3500 miles. Had to go to the dealer 4 times before they agreed to take a look and fix it. Terrible customer service, and if i didn't love Camaro's so much i would have sold the car by now. Needless to say I'm still not happy and will hesitate before buying another chevy. Ive had a few more problems with the car which still arnt fixed, i just haven't had the time to get to another dealer as I will never return to my dealer.
I'm sorry to hear to hear my fellow camaro brother. Yea these camaro's are awesome cars but it's unfortunate you had to experience this. I REALLY hope the dealer takes some pride in thier jobs and the Chevy name and resolves the issues your having.
C-redfly is offline   Reply With Quote
Old 08-06-2012, 02:02 PM   #7
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
Quote:
Originally Posted by 323RSTX View Post
9335 miles & no problems. knock on wood.
Exactly. That's what I expect.
C-redfly is offline   Reply With Quote
Old 08-06-2012, 02:52 PM   #8
PalmerGA


 
PalmerGA's Avatar
 
Drives: 2013 SIM 1SS/RS L99
Join Date: May 2012
Location: Southwest GA
Posts: 6,100
Had to have the sunroof airdam replaced - it was out of alighnment and hanging up on the roof opening. No problem since.

Had the torque converter replaced - engine was pulsing at slow constant speeds (30-50 mph). No problem since.

Lost engine power while on vacation a month ago. Limped into a local dealership and they had TSB to reprogram the Fuel Pressure Sensor. No problem since.

It hasn't been a "perma-grin", but it's been a most-of-the-time grin.
__________________
2013 1SS/RS Coupe L99
CAI Air Intake w/ Apex Scoop
VMAX CNC Ported Throttle Body
Solo Axle-Back Exhaust w/ J-pipes
RX Catch Can
Husky Splash Guards
Heritage Grille
Oracle Chrome Turn Signal Bulbs
Emblem Pros Retro SS Badges
Emblem Pros Custom Retro SS Kickplates
Emblem Pros Under-hood Bowtie
PalmerGA is offline   Reply With Quote
Old 08-06-2012, 02:58 PM   #9
Horriblecreation
 
Horriblecreation's Avatar
 
Drives: 2012 1LT/RS
Join Date: Nov 2011
Location: Savannah, GA
Posts: 148
I'm about to break 20k miles and so far so good other than the airbag TSB...
Horriblecreation is offline   Reply With Quote
Old 08-06-2012, 03:21 PM   #10
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
[QUOTE=PalmerGA;5400169]Had to have the sunroof airdam replaced - it was out of alighnment and hanging up on the roof opening. No problem since.

Had the torque converter replaced - engine was pulsing at slow constant speeds (30-50 mph). No problem since.

Lost engine power while on vacation a month ago. Limped into a local dealership and they had TSB to reprogram the Fuel Pressure Sensor. No problem since.

It hasn't been a "perma-grin", but it's been a most-of-the-time grin.[/QUOTE

"Most of the time", nice one.
But yea I heard a lot about the torque converter, do they give us the same part as a replacement or is it a improved part to avoid repeated failure?
C-redfly is offline   Reply With Quote
Old 08-06-2012, 03:30 PM   #11
C-redfly

 
C-redfly's Avatar
 
Drives: 2012 completely Red Camaro
Join Date: Aug 2012
Location: Los Angeles
Posts: 893
Quote:
Originally Posted by Horriblecreation View Post
I'm about to break 20k miles and so far so good other than the airbag TSB...
Ok sweet. Thxs for the feedback
C-redfly is offline   Reply With Quote
Old 08-06-2012, 05:30 PM   #12
PalmerGA


 
PalmerGA's Avatar
 
Drives: 2013 SIM 1SS/RS L99
Join Date: May 2012
Location: Southwest GA
Posts: 6,100
Quote:
Originally Posted by C-redfly View Post
But yea I heard a lot about the torque converter, do they give us the same part as a replacement or is it a improved part to avoid repeated failure?
Perhaps ecko04 can shed some light on this for you. I would think GM would just keep replacing them with the same intermittently defective part and hope you get a good one.
__________________
2013 1SS/RS Coupe L99
CAI Air Intake w/ Apex Scoop
VMAX CNC Ported Throttle Body
Solo Axle-Back Exhaust w/ J-pipes
RX Catch Can
Husky Splash Guards
Heritage Grille
Oracle Chrome Turn Signal Bulbs
Emblem Pros Retro SS Badges
Emblem Pros Custom Retro SS Kickplates
Emblem Pros Under-hood Bowtie

Last edited by PalmerGA; 08-06-2012 at 06:03 PM.
PalmerGA is offline   Reply With Quote
Old 08-07-2012, 07:10 AM   #13
trav76457
 
trav76457's Avatar
 
Drives: 2012 LS2 Orange with white stripes
Join Date: Feb 2012
Location: Texas
Posts: 22
17K miles now, had to get my torque converter replaced at around 16K. It's a know issue with this car and the catalac with the same enging trans setup. Other than that, all is well. Car runs like a champ now. After torque converter fix, I finally beat my wifes 2013 mustang in a race.
trav76457 is offline   Reply With Quote
Old 08-07-2012, 04:28 PM   #14
Omaha
Living life in the curves
 
Omaha's Avatar
 
Drives: 2011 2SS/RS VR M6
Join Date: Jun 2012
Location: Mount Joy, PA
Posts: 117
2900 ECM update for a fuel rail pressure sensor.

Last edited by Omaha; 08-09-2012 at 02:26 PM.
Omaha is offline   Reply With Quote
Old 08-12-2012, 01:19 PM   #15
trganey
 
Drives: 1979 Z28-Retired, 2012 RS
Join Date: Oct 2011
Location: Alabama
Posts: 103
Front end aligned
Torque Converter replaced
15k miles. 2012 2lt RS Auto
trganey is offline   Reply With Quote
Old 08-12-2012, 01:20 PM   #16
VenomInside
Just Grazing
 
VenomInside's Avatar
 
Drives: 2003 EB Corvette Z06
Join Date: Jun 2011
Location: Chicago
Posts: 644
Old 11' Vert:

Top issues x 7
A/C compressor

Current 12'
Dash bubbling.
__________________
2003 Corvette Z06
1984 Mustang GT350 - 1 of 670 Made (current)
2012 Camaro 45th Anniversary 2SS/RS 6MT (Sold)
2011 Camaro 2SS/RS Vert 6MT (Lemon-Sold)
2003 Sonic Blue Cobra 458rwhp/458rwtq (Sold)
1996 Mystic Cobra 455rwhp/400rwtq (sold)
1999 BGC T/A 377rwhp/360rwtq (sold)
2004 Silver Cobra 600rwhp/540rwtq (sold)
Quote:
Originally Posted by big hammer View Post
2012 zl1... the new 99 cobra?
VenomInside is offline   Reply With Quote
Old 08-12-2012, 02:04 PM   #17
ecko04
 
Drives: Too many to list
Join Date: Dec 2011
Location: East Coast Runner
Posts: 318
10k no issues. Change oil every 3-4k (Mobil 1 full synthetic). Changed differential fluid about 2k ago (Royal Purple). Will change tyranny fluid on the next oil change.

I haven't even gone in for the airbag TSB because the local dealer have horrible customer service...which is the reason I drove 3 hrs to purchase my Camaro.

Quote:
Originally Posted by PalmerGA View Post
Perhaps ecko04 can shed some light on this for you. I would think GM would just keep replacing them with the same intermittently defective part and hope you get a good one.
I would think it would be right up your alley...after all you expect GM to re-engineer a TB that owners can't collectively say is an issue.
__________________
In My Garage

'12 Volkswagen Jetta SE
'12 Chevrolet Camaro
'11 Harley Fat Bob
'11 Honda Accord Coupe EX-L
'05 Mercedes E500 W211
'01 BMW 328xi
'89 Chevrolet Suburban

Last edited by ecko04; 08-12-2012 at 02:49 PM.
ecko04 is offline   Reply With Quote
Old 08-12-2012, 02:56 PM   #18
20121lt
 
20121lt's Avatar
 
Drives: 1LE SS/RS 2013
Join Date: Jun 2012
Location: oswego ny
Posts: 184
air bag update ,dash bubbles but other than that ...
20121lt is offline   Reply With Quote
Old 08-12-2012, 02:58 PM   #19
PalmerGA


 
PalmerGA's Avatar
 
Drives: 2013 SIM 1SS/RS L99
Join Date: May 2012
Location: Southwest GA
Posts: 6,100
Quote:
Originally Posted by ecko04 View Post
I would think it would be right up your alley...after all you expect GM to re-engineer a TB that owners can't collectively say is an issue.
Is that what it takes for GM to admit there is a problem... 100% customer dissatisfaction?

I think GM should contract with VMax (or whomever) to provide the correctly designed and manufactured TBs and, after owner reported dissatisfaction is validated through TB testing, replace the original with a VMax one - free of charge.

Again, just my opinion - not speaking for every Camaro owner.
__________________
2013 1SS/RS Coupe L99
CAI Air Intake w/ Apex Scoop
VMAX CNC Ported Throttle Body
Solo Axle-Back Exhaust w/ J-pipes
RX Catch Can
Husky Splash Guards
Heritage Grille
Oracle Chrome Turn Signal Bulbs
Emblem Pros Retro SS Badges
Emblem Pros Custom Retro SS Kickplates
Emblem Pros Under-hood Bowtie
PalmerGA is offline   Reply With Quote
Old 08-12-2012, 04:02 PM   #20
Bobaloo
Member "O'l Farts"
 
Drives: 2012 SS Coupe/Automatic/Sunroof
Join Date: May 2012
Location: Pueblo West, Colorado
Posts: 271
4400 miles.............PERFECT !
__________________
Bobaloo is offline   Reply With Quote
Old 08-12-2012, 07:55 PM   #21
ecko04
 
Drives: Too many to list
Join Date: Dec 2011
Location: East Coast Runner
Posts: 318
Quote:
Originally Posted by PalmerGA View Post
Is that what it takes for GM to admit there is a problem... 100% customer dissatisfaction?

I think GM should contract with VMax (or whomever) to provide the correctly designed and manufactured TBs and, after owner reported dissatisfaction is validated through TB testing, replace the original with a VMax one - free of charge.

Again, just my opinion - not speaking for every Camaro owner.
Torque converter issue...well documented with many drivers. Airbag issue...well documented and appears within a certain range of VINs.

TB issue, not well documented. Some would say it doesn't even exist. Not related to any specific range of VIN, not verifiable on a dyno, not specific to any year...too much lack of uniformity to warrant what you suggest.

Just my opinion BUT that's neither here nor there, we've gone down this road. It's best to agree to disagree on this one.
__________________
In My Garage

'12 Volkswagen Jetta SE
'12 Chevrolet Camaro
'11 Harley Fat Bob
'11 Honda Accord Coupe EX-L
'05 Mercedes E500 W211
'01 BMW 328xi
'89 Chevrolet Suburban

Last edited by ecko04; 08-12-2012 at 08:32 PM.
ecko04 is offline   Reply With Quote
Old 08-13-2012, 02:23 PM   #22
PalmerGA


 
PalmerGA's Avatar
 
Drives: 2013 SIM 1SS/RS L99
Join Date: May 2012
Location: Southwest GA
Posts: 6,100
Quote:
Originally Posted by ecko04 View Post
Torque converter issue...well documented with many drivers. Airbag issue...well documented and appears within a certain range of VINs.

TB issue, not well documented. Some would say it doesn't even exist. Not related to any specific range of VIN, not verifiable on a dyno, not specific to any year...too much lack of uniformity to warrant what you suggest.

Just my opinion BUT that's neither here nor there, we've gone down this road. It's best to agree to disagree on this one.
Good idea. I think that's the best we can hope for.
__________________
2013 1SS/RS Coupe L99
CAI Air Intake w/ Apex Scoop
VMAX CNC Ported Throttle Body
Solo Axle-Back Exhaust w/ J-pipes
RX Catch Can
Husky Splash Guards
Heritage Grille
Oracle Chrome Turn Signal Bulbs
Emblem Pros Retro SS Badges
Emblem Pros Custom Retro SS Kickplates
Emblem Pros Under-hood Bowtie
PalmerGA is offline   Reply With Quote
Old 08-13-2012, 03:47 PM   #23
Magilla gorilla

 
Magilla gorilla's Avatar
 
Drives: 2012 45th Edition 2LT RS,2005 Tahoe
Join Date: Mar 2012
Location: Henderson Nevada
Posts: 1,202
8600 miles and no issues. It's been a fun 8600 miles so far. Hope it stays this way
Magilla gorilla is offline   Reply With Quote
Old 08-13-2012, 07:49 PM   #24
Rhyno81
 
Drives: Summit White 2012 1LT M6
Join Date: Feb 2012
Location: Pittsburgh
Posts: 145
Had to take it back to have the passenger seat sensor recalibrated. Had the car for about 3 weeks at this point and it never worked. ( wouldnt arm the passenger side airbag) 10 min fix but still had to waste an hr at the dealer.
Rhyno81 is offline   Reply With Quote
Old 08-13-2012, 08:07 PM   #25
69supersport396
Rick
 
69supersport396's Avatar
 
Drives: 2012 IBM RS 'Vert
Join Date: Feb 2012
Location: Peoria, AZ
Posts: 1,703
Onstar emailed me about a "hardware issue" with the Onstar system. They assisted with setting up an appointment, but the dealer never got to it.

Other than a weeping master cylinder cap and a free oil change, haven't had a reason to return to the dealer.
__________________
69supersport396 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.