Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums -
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - > Marketplace > Vendor and Seller review / feedback / experiences

Thread Tools
Old 08-27-2012, 01:01 AM   #1
Drives: 2010 CGM SS
Join Date: Jun 2012
Posts: 147
thanks AAC

well i posted a while back about a bad bulb that i got from aac. so i sent it off on saturday last week and got a new one yesterday. i installed them both today and they both worked perfectly. lately theres been some aac bashing but i gotta give em props for fixin my problem pretty quick.

rickv16 is offline   Reply With Quote
Old 08-27-2012, 05:21 PM   #2
Lil' Nasty
[COTW 4/13/15]
Lil' Nasty's Avatar
Drives: Supercharged V6
Join Date: Jul 2010
Location: Florida
Posts: 5,366
Good for you Ricky, yeah I don't know every case but people that don't even have AAC products bash them like they were treated poorly Now my license plate LEDs and one of my footwells are defective. They have a lifetime warranty which is nice and no reason to b*tch about

That being said I can't wait to get my side markers
Lil' Nasty is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.