Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 08-28-2012, 01:50 PM   #1
FresnoStateDogs
 
FresnoStateDogs's Avatar
 
Drives: 2012 2SS/RS LS3
Join Date: Mar 2012
Location: Burbank, CA
Posts: 272
Suspension Buckling

I added a one inch drop with new springs. I thought I was being conservative by only going one inch. I was forced to remove my front splitter because when I took it home I couldn't get in my driveway. No big deal. But now I'm noticing a loud buckling sound when taking turns 30mph or faster. I took the car to the dealership after adding springs because I figured they would do the best job. Asked them to re-time my bushing (I left them loose), full suspension check, etc. Is the buckling considered normal for a one inch drop?
__________________


Spiral Ported TB, K&N Typhoon, JBA Performance Cat-back, RX catch can and Oil Breather.
FresnoStateDogs is offline   Reply With Quote
Old 08-28-2012, 03:41 PM   #2
justa25thTA

 
justa25thTA's Avatar
 
Drives: 2011 Camaro SS/RS LS3
Join Date: Aug 2010
Location: Texas
Posts: 1,632
no
__________________
Yeah, I'll get around to it...
justa25thTA is offline   Reply With Quote
Old 08-28-2012, 04:10 PM   #3
Rob@WretchedMS

 
Rob@WretchedMS's Avatar
 
Drives: His Wife Crazy Phone:860-880-0486
Join Date: Jan 2008
Location: Silas Deane Auto,CT Name: Rob Anderson
Posts: 1,646
no, you should have no noises.
Haddad Motorsports is in Inglewood, maybe you should take it over there to get it looked at.
Rob@WretchedMS is offline   Reply With Quote
Old 08-28-2012, 04:16 PM   #4
FresnoStateDogs
 
FresnoStateDogs's Avatar
 
Drives: 2012 2SS/RS LS3
Join Date: Mar 2012
Location: Burbank, CA
Posts: 272
Just noticed the sound only occurs when I turn to the left and consequently when straightening them again. The sound appears to be coming from the left front wheel. I wish it occurred when the car was stopped so that I can determine what is hitting. I don't think the top of the wheel is hitting since it appears to have just as much clearance as the right wheel.
__________________


Spiral Ported TB, K&N Typhoon, JBA Performance Cat-back, RX catch can and Oil Breather.
FresnoStateDogs is offline   Reply With Quote
Old 08-28-2012, 04:21 PM   #5
Rob@WretchedMS

 
Rob@WretchedMS's Avatar
 
Drives: His Wife Crazy Phone:860-880-0486
Join Date: Jan 2008
Location: Silas Deane Auto,CT Name: Rob Anderson
Posts: 1,646
Pull off the left front wheel, and go through everything with a wrench and make sure it's all tight.
Pay close attention to the sway bar end links,
Rob@WretchedMS is offline   Reply With Quote
Old 08-28-2012, 04:21 PM   #6
FresnoStateDogs
 
FresnoStateDogs's Avatar
 
Drives: 2012 2SS/RS LS3
Join Date: Mar 2012
Location: Burbank, CA
Posts: 272
Quote:
Originally Posted by Rob@WretchedMS View Post
no, you should have no noises.
Haddad Motorsports is in Inglewood, maybe you should take it over there to get it looked at.
Since I got an alignment at the dealership, shouldn't they be responsible for this issue?
__________________


Spiral Ported TB, K&N Typhoon, JBA Performance Cat-back, RX catch can and Oil Breather.
FresnoStateDogs is offline   Reply With Quote
Old 08-28-2012, 04:23 PM   #7
Rob@WretchedMS

 
Rob@WretchedMS's Avatar
 
Drives: His Wife Crazy Phone:860-880-0486
Join Date: Jan 2008
Location: Silas Deane Auto,CT Name: Rob Anderson
Posts: 1,646
hard to say, if it's an install issue then no,
if it's a matter of them leaving something loose, then yes.
It's not common for a car to be brought in to a shop with parts left loose on purpose, so it's possible that something was missed when they tightened it up.

If you can't get a resolution to the issue, Haddad is a Camaro Specialist.
Rob@WretchedMS is offline   Reply With Quote
Old 08-28-2012, 05:56 PM   #8
FresnoStateDogs
 
FresnoStateDogs's Avatar
 
Drives: 2012 2SS/RS LS3
Join Date: Mar 2012
Location: Burbank, CA
Posts: 272
Quote:
Originally Posted by Rob@WretchedMS View Post
hard to say, if it's an install issue then no,
if it's a matter of them leaving something loose, then yes.
It's not common for a car to be brought in to a shop with parts left loose on purpose, so it's possible that something was missed when they tightened it up.

If you can't get a resolution to the issue, Haddad is a Camaro Specialist.
Took your advice, thanks a billion. Left links were accidentally left loose by the dealership.
__________________


Spiral Ported TB, K&N Typhoon, JBA Performance Cat-back, RX catch can and Oil Breather.
FresnoStateDogs is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.