Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
SDPC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 10-01-2012, 07:02 AM   #1
tonyfred

 
tonyfred's Avatar
 
Drives: 2013 ZL1-Victory Red-Auto
Join Date: Mar 2010
Location: Jackson TN
Posts: 1,048
Mild to Wild...now check engine light is on

I have been using the Mild To Wild exhaust controller for about 5-6 weeks now. It is installed just like the directions specify.
This weekend my check engine light came on.
I punched the blue button and asked for them to run diagnostics. The tech said that there was a problem with the exhaust not performing properly and I need to carry it to the dealer to get it resolved.
Anyone else have any problems like this whether they use the controller or not? I am not saying it has anything to to do with the M2W controller, but I have to wonder since the diagnostics point to the exhaust.
I will disconnect the M2W unit today and see if it makes any difference.
Stay tuned.
__________________
Jannetty 75 RWHP Performance Package and Tune.
Rotofab Intake, Big Gulp and WW Relocation Kit.
MRR 228 Wheels on Continental DWS06 Extremes.

tonyfred is offline   Reply With Quote
Old 10-01-2012, 07:49 AM   #2
closs2sx
 
closs2sx's Avatar
 
Drives: 1970 chevelle
Join Date: Aug 2011
Location: Central NH
Posts: 560
i have had the fuse pulled on mine for 600 miles no light it may be another part of the exhaust did they give you the code? if not stop by an autozone and they will read it and give you the code then look it up and see what it refers to before you go to the dealer and they charge you because its related to the mild to wild. I wouldnt think it would be though
__________________
MY Car
2013 ZL1 Vin 555
Details
Crystal Red Tint Coat/ Black Wheels
Exposed Carbon Fiber Insert
6 Spd Manual
Dads Car
2013 ZL1 vin 963
Crystal Red Tint Coat/Black Wheels
Exposed Carbon Fiber Insert
6 Spd Manual
Road Trip To Buffalo complete shipment from MO has arrived
closs2sx is offline   Reply With Quote
Old 10-01-2012, 07:58 AM   #3
tonyfred

 
tonyfred's Avatar
 
Drives: 2013 ZL1-Victory Red-Auto
Join Date: Mar 2010
Location: Jackson TN
Posts: 1,048
They did not give a code, just said the exhaust was not performing as expected.
If I have to go to the dealer, there wont be any trace of the M2W to be found.
__________________
Jannetty 75 RWHP Performance Package and Tune.
Rotofab Intake, Big Gulp and WW Relocation Kit.
MRR 228 Wheels on Continental DWS06 Extremes.

tonyfred is offline   Reply With Quote
Old 10-01-2012, 08:05 AM   #4
htron50


 
htron50's Avatar
 
Drives: 2012 ZL1
Join Date: Feb 2009
Location: SC
Posts: 2,462
Quote:
Originally Posted by tonyfred View Post
They did not give a code, just said the exhaust was not performing as expected.
If I have to go to the dealer, there wont be any trace of the M2W to be found.


Except ONLINE
__________________
2012 CAMARO-ZL1
Sincere Thanks to City Chevrolet, Charlotte, NC http://www.citychevrolet.com/blog/ca...et-camaro-zl1/
htron50 is offline   Reply With Quote
Old 10-01-2012, 08:07 AM   #5
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,275
You could call Onstar and ask them transfer you to a tech. The tech will be able to tell you what codes are being thrown, if a code is being thrown that is.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 10-01-2012, 08:10 AM   #6
tonyfred

 
tonyfred's Avatar
 
Drives: 2013 ZL1-Victory Red-Auto
Join Date: Mar 2010
Location: Jackson TN
Posts: 1,048
Quote:
Originally Posted by htron50 View Post
[/B]

Except ONLINE
So you think the dealer will go to Camaro 5 and track my posts down? Really?
__________________
Jannetty 75 RWHP Performance Package and Tune.
Rotofab Intake, Big Gulp and WW Relocation Kit.
MRR 228 Wheels on Continental DWS06 Extremes.

tonyfred is offline   Reply With Quote
Old 10-01-2012, 08:18 AM   #7
htron50


 
htron50's Avatar
 
Drives: 2012 ZL1
Join Date: Feb 2009
Location: SC
Posts: 2,462
Quote:
Originally Posted by tonyfred View Post
So you think the dealer will go to Camaro 5 and track my posts down? Really?
You got me I know in this day and age some activities are monitored pretty well. Who knows if GM cross checks dealer repairs and if they know people are doing this?? It doesn't sound major. I am curious if the exhaust code could be more specific to the oxygen sensors, catalytic conv, or just improperly working flaps. All I am saying is ... "there is a trace".... and I say it with compassion intended.
__________________
2012 CAMARO-ZL1
Sincere Thanks to City Chevrolet, Charlotte, NC http://www.citychevrolet.com/blog/ca...et-camaro-zl1/
htron50 is offline   Reply With Quote
Old 10-01-2012, 08:23 AM   #8
tonyfred

 
tonyfred's Avatar
 
Drives: 2013 ZL1-Victory Red-Auto
Join Date: Mar 2010
Location: Jackson TN
Posts: 1,048
Quote:
Originally Posted by htron50 View Post
You got me I know in this day and age some activities are monitored pretty well. Who knows if GM cross checks dealer repairs and if they know people are doing this?? It doesn't sound major. I am curious if the exhaust code could be more specific to the oxygen sensors, catalytic conv, or just improperly working flaps. All I am saying is ... "there is a trace".... and I say it with compassion intended.
I understand. Appreciate the input.
I will disconnect the battery today when I get home and let her set and see if I can get a reset.
That also made me think....I hit 1500 miles last week and did the fuse pull to reset the computer. The first time I drove it after putting the fuses back in is when the light came on. I was getting down on it pretty good when the light came on.
__________________
Jannetty 75 RWHP Performance Package and Tune.
Rotofab Intake, Big Gulp and WW Relocation Kit.
MRR 228 Wheels on Continental DWS06 Extremes.

tonyfred is offline   Reply With Quote
Old 10-01-2012, 08:36 AM   #9
Speedforhire
 
Speedforhire's Avatar
 
Drives: 2013 GRAND SPORT (aka: EREBUS)
Join Date: Sep 2012
Location: Arkansas
Posts: 137
Simple way to test it:

Remove the M-2-W, clear the code by disconnecting the battery, then wait to see if it reappears. If so, you know the M-2-W was not the culprit.
Speedforhire is offline   Reply With Quote
Old 10-01-2012, 08:47 AM   #10
BonestockZL1
 
BonestockZL1's Avatar
 
Drives: 2012 ZL1 Camaro
Join Date: May 2012
Location: PA
Posts: 181
I bought the M2W and before I installed it I pulled the fuse. I like the way it sounds so the M2W is just sitting on my bench. Doubt I will ever put it in now.
__________________
BonestockZL1 is offline   Reply With Quote
Old 10-01-2012, 09:01 AM   #11
Speedforhire
 
Speedforhire's Avatar
 
Drives: 2013 GRAND SPORT (aka: EREBUS)
Join Date: Sep 2012
Location: Arkansas
Posts: 137
Quote:
Originally Posted by BonestockZL1 View Post
I bought the M2W and before I installed it I pulled the fuse. I like the way it sounds so the M2W is just sitting on my bench. Doubt I will ever put it in now.

...........didn't buy the M2W here......I like the "always on" feature of the fuse pull......

That's a damn funny sig pic Bone.............
Speedforhire is offline   Reply With Quote
Old 10-01-2012, 10:03 AM   #12
zfuzz
 
zfuzz's Avatar
 
Drives: 69 Z28 / 12 ZL1
Join Date: Nov 2011
Location: Tennessee
Posts: 381
The M2W box is just emulating an open fuse. Which should not throw a code, if it did there would be hundreds if not thousands of us with our check engine lights on. I have been running my Exhaust Commander for about 1300 miles now.

Sounds like when you were getting on it after taking it easy for the break in period you dislodged some soot onto a sensor. Just my guess,,, I bet another round of "spirited" driving would probably clear it
__________________
zfuzz is offline   Reply With Quote
Old 10-01-2012, 10:15 AM   #13
hognutz


 
hognutz's Avatar
 
Drives: 2013 ZL1
Join Date: Oct 2011
Location: tangent or
Posts: 2,978
all the MILD to WILD is, is just a relay. it sources 12v and turns is on an off. you can test the mild to wild box with a simple test light. to see if it is functioning correclty. on will be 12V supplied, off there will be no voltage. that is all it does.

Now I can not comment if the circuit that controls the exhaust flaps iselft has any codes it can throw I have never looked into it. I would get the code number and google it.
__________________
2017 zl1 or GT350 hmmmm
2015 Hellcat-sold
2013 ZL1 -sold
2013 Dart
2013 Megacab 8" lift 38"mt's
hognutz is offline   Reply With Quote
Old 10-01-2012, 10:34 AM   #14
Normagene


 
Normagene's Avatar
 
Drives: 2013 Ashen Gray M6 ZL1
Join Date: Sep 2012
Location: South Eastern, Mass
Posts: 2,611
Name:  ImageUploadedByTapatalk1349105324.096011.jpg
Views: 1266
Size:  128.5 KB

Don't have my ZL1 yet, about two more weeks of waiting. The fuse pull for the exhaust baffles is F8, is that correct? I'm learning so much from this site. I plan on pulling mine out so that ground shaking rumble is always on.
Normagene is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:28 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.