Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Fabberge
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 06-23-2013, 03:05 PM   #26
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,824
Quote:
Originally Posted by Fast1 View Post
I have the exact same problem. It sounds like something's coming apart every time I drive over a small bump.
Hi Fast1,

Really sorry to hear about that. By all means, let me know if there are any concerns you'd like to get diagnosed. You are more than welcome to message me at anytime with questions or concerns!

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote
Old 06-23-2013, 06:26 PM   #27
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by Fast1 View Post
I have the exact same problem. It sounds like something's coming apart every time I drive over a small bump.
Is your suspension stock?
How many miles are on your Camaro?
__________________
JusticePete is offline   Reply With Quote
Old 07-11-2013, 08:39 AM   #28
Fast1
 
Fast1's Avatar
 
Drives: 2010 Summit White SS
Join Date: Oct 2008
Location: Salt Lake City
Posts: 159
Sorry it took me so long to get back to you. Stock suspension, with 14000 miles.
Fast1 is offline   Reply With Quote
Old 07-15-2013, 01:42 PM   #29
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by Fast1 View Post
Sorry it took me so long to get back to you. Stock suspension, with 14000 miles.
Shine some light up into the strut tower and get a good look at the insulator between the top of the spring and the upper spring seat / bearing plate. If you see black rubber replacing it with a urethane and steel insulator may resolve your noise.



Before you go down that road, try tightening things up per our instructions.
__________________
JusticePete is offline   Reply With Quote
Old 07-15-2013, 02:30 PM   #30
DuskSS
Bayou City Muscle Cars
 
DuskSS's Avatar
 
Drives: 2013 2SS Dusk Edition
Join Date: Jan 2013
Location: Houston Texas
Posts: 1,471
Quote:
Originally Posted by Fast1 View Post
I have the exact same problem. It sounds like something's coming apart every time I drive over a small bump.
same here but sometimes it's fine and other times sounds like the right front shock is going to pop through the damn car it is so loud.

6 month old 9k mile 13..
driving me nuts.
__________________
2013 2SS Dusk Edition
Dual Mode Exhaust CAI Inc CAI
Lethal Racing Stage IV
510.7rwhp 477fpt
Oracle Lighting throughout
DuskSS is offline   Reply With Quote
Old 07-16-2013, 06:45 PM   #31
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by DuskSS View Post
same here but sometimes it's fine and other times sounds like the right front shock is going to pop through the damn car it is so loud.

6 month old 9k mile 13..
driving me nuts.
For those of you with 13s, there is a TSB for strut replacement due to a manufacturing defect in the strut. Have your dealer run your VIN.
__________________
JusticePete is offline   Reply With Quote
Old 08-20-2013, 05:31 PM   #32
mostknownunknown
 
Drives: 2010 Chevy Camaro SS
Join Date: Aug 2013
Location: Shreveport
Posts: 5
I also have the same problem on the front right side...This is ridiculous there is no exact fix for this problem...I'm very disappointed & just purchased my 2010 SS Camaro
mostknownunknown is offline   Reply With Quote
Old 08-21-2013, 10:28 PM   #33
lakersftbl69

 
lakersftbl69's Avatar
 
Drives: 2010 camaro 1ss/rs
Join Date: Mar 2009
Location: kingston ma.
Posts: 1,379
I just installed pfadt lowering spring and sways with full bMR bushing kit when I turn going forward or reverse I have I lil weird noise too. Maybe it's normal after changing everything?
__________________
ordered dec 15 2008 picked up on june 8 2009.
upgrades kooks 1 3/4" LTH w/ high flow cats, roto fab cai, corsa exhaust, rx catch can, hurst short throw shifter. stage 3 comp cam, 3.91 gears 445rwhp 410 rwtq all installed and dyno tuned from slowhawk performance.
lakersftbl69 is offline   Reply With Quote
Old 08-21-2013, 11:12 PM   #34
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by lakersftbl69 View Post
I just installed pfadt lowering spring and sways with full bMR bushing kit when I turn going forward or reverse I have I lil weird noise too. Maybe it's normal after changing everything?
After installing new suspension parts, unless they include spherical rod ends, there should be no wired noises. Lay a wrench on every nut and make sue they are tight.
__________________
JusticePete is offline   Reply With Quote
Old 08-21-2013, 11:58 PM   #35
lakersftbl69

 
lakersftbl69's Avatar
 
Drives: 2010 camaro 1ss/rs
Join Date: Mar 2009
Location: kingston ma.
Posts: 1,379
The endlink upgrades are the same zl spec ones along with the upgraded lower control arm I got them from the Chevy dealer cuz my car is a 2010
__________________
ordered dec 15 2008 picked up on june 8 2009.
upgrades kooks 1 3/4" LTH w/ high flow cats, roto fab cai, corsa exhaust, rx catch can, hurst short throw shifter. stage 3 comp cam, 3.91 gears 445rwhp 410 rwtq all installed and dyno tuned from slowhawk performance.
lakersftbl69 is offline   Reply With Quote
Old 08-21-2013, 11:59 PM   #36
lakersftbl69

 
lakersftbl69's Avatar
 
Drives: 2010 camaro 1ss/rs
Join Date: Mar 2009
Location: kingston ma.
Posts: 1,379
Quote:
Originally Posted by JusticePete View Post
After installing new suspension parts, unless they include spherical rod ends, there should be no wired noises. Lay a wrench on every nut and make sue they are tight.
I will thank you
__________________
ordered dec 15 2008 picked up on june 8 2009.
upgrades kooks 1 3/4" LTH w/ high flow cats, roto fab cai, corsa exhaust, rx catch can, hurst short throw shifter. stage 3 comp cam, 3.91 gears 445rwhp 410 rwtq all installed and dyno tuned from slowhawk performance.
lakersftbl69 is offline   Reply With Quote
Old 08-25-2013, 11:31 PM   #37
mostknownunknown
 
Drives: 2010 Chevy Camaro SS
Join Date: Aug 2013
Location: Shreveport
Posts: 5
I have everything stock under the hood on my 2010 Chevy Camaro SS...I had everything re-checked & tightened and the noise was almost the same...So should I try purchasing the Strut mounts and replacing the rubber strut mounts...Just tryna start some where however I do have warranty...I have 44,000 miles on my vehicle.......Please help
mostknownunknown is offline   Reply With Quote
Old 08-26-2013, 12:58 AM   #38
mostknownunknown
 
Drives: 2010 Chevy Camaro SS
Join Date: Aug 2013
Location: Shreveport
Posts: 5
2010 Chevy Camaro SS

I have a 2010 Chevy Camaro SS with suspension problems of course...I wanted to know if purchasing the newly modeled Strut Mounts would make a difference in making the noise go away... I had all bolts tightened today only to have the same result with front suspension noise mainly on the passenger side...I hear a lot of complaints but hardly a few resolutions... If someone could give some insight please let me know...Thanks
mostknownunknown is offline   Reply With Quote
Old 08-26-2013, 11:46 AM   #39
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,824
Hey JusticePete- Thanks for all the info and pictures!

If y'all are having the clunking concern and want me to run your VIN for open service related items, I am here to help! PM your VIN and mileage.

Hey Blackswan- Are you clunk free?

Thanks!

Kelly J.
Chevrolet Customer Care

Last edited by Chevrolet Customer Svc; 08-26-2013 at 11:54 AM. Reason: mistake
Chevrolet Customer Svc is offline   Reply With Quote
Old 09-03-2013, 10:10 AM   #40
mostknownunknown
 
Drives: 2010 Chevy Camaro SS
Join Date: Aug 2013
Location: Shreveport
Posts: 5
Thumbs up Problem fixed

Well for all,the front suspension noise I was hearing come to find out it was my brake caliper bolts were loose from a mechanic who previously installed some brake pads on my vehicle... Problem fixed no noise at all car ride really good & quiet now...so with people having front end suspension noise you might want the dealership or a mechanic check to ensure all bolts are completely tightened down all the way...Boy I'm glad this problem is finally fixed.....
mostknownunknown is offline   Reply With Quote
Old 09-10-2013, 11:03 PM   #41
lakersftbl69

 
lakersftbl69's Avatar
 
Drives: 2010 camaro 1ss/rs
Join Date: Mar 2009
Location: kingston ma.
Posts: 1,379
Found out my noise is coming from the back while turning after installing lower springs full bushings kit and sways any ideas what it could be it wouldn't be the diff would it?
__________________
ordered dec 15 2008 picked up on june 8 2009.
upgrades kooks 1 3/4" LTH w/ high flow cats, roto fab cai, corsa exhaust, rx catch can, hurst short throw shifter. stage 3 comp cam, 3.91 gears 445rwhp 410 rwtq all installed and dyno tuned from slowhawk performance.
lakersftbl69 is offline   Reply With Quote
Old 09-18-2013, 05:53 PM   #42
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by lakersftbl69 View Post
Found out my noise is coming from the back while turning after installing lower springs full bushings kit and sways any ideas what it could be it wouldn't be the diff would it?
The solution is very similar to the front. Lay a wrench on every nut and bolt to double check they are tight. This is especially true with the endlinks.
__________________
JusticePete is offline   Reply With Quote
Old 09-18-2013, 06:38 PM   #43
blackswan

 
blackswan's Avatar
 
Drives: Yes
Join Date: Oct 2011
Location: Nearby
Posts: 1,195
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Hey JusticePete- Thanks for all the info and pictures!

If y'all are having the clunking concern and want me to run your VIN for open service related items, I am here to help! PM your VIN and mileage.

Hey Blackswan- Are you clunk free?

Thanks!

Kelly J.
Chevrolet Customer Care
Nope and it's grown worse. Ay help appreciated, I would like to switch dealers,as well.
blackswan is offline   Reply With Quote
Old 09-19-2013, 10:48 AM   #44
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,824
Hi blackswan!

I would be happy to research further for you. I can also locate a new dealership to assist in a resolution. If you could send a private message with your name, address, phone number, VIN, vehicle mileage, and name of current dealership, I can create a case for you in my system. I can then schedule an appointment for you at another dealership so we can get this resolved! Thanks!

Jessica
Chevrolet Customer Care

Quote:
Originally Posted by blackswan View Post
Nope and it's grown worse. Ay help appreciated, I would like to switch dealers,as well.
Chevrolet Customer Svc is offline   Reply With Quote
Old 07-12-2014, 08:51 PM   #45
Rcfiddy1

 
Rcfiddy1's Avatar
 
Drives: 2010 Rally Yellow 2SS/RS #37115
Join Date: Oct 2009
Location: Manalapan, New Jersey
Posts: 1,923
Has anyone been able to find a solution to this clunking in front end? I had my car at the stealership for this problem but was told due to my heavily modified engine they can not replicate it. Whatever that means. I can replicate it just by turn hard or making a hard stop. I guess it was thier way of saying we don't want to look at it but thanks for the ride. I swapped out struts with new coilovers, new sways and new end links but I still have that loud clunk sound from just under passenger feet. Seems to be getting louder. I am at the point of getting rid of this car if I can not resolve this.
__________________
Build Thread
ECS Supercharged, LS3 conversion, Blower Cam, Alky Meth, 3:45 rear, BMR Suspension parts, 1LE Sways, Billy Boat ZL1 dual mode exhaust.

Last edited by Rcfiddy1; 07-12-2014 at 11:04 PM.
Rcfiddy1 is offline   Reply With Quote
Old 07-13-2014, 01:03 PM   #46
MTCobra
 
Drives: 2014 ZL1
Join Date: Dec 2013
Location: So Cal
Posts: 163
Front End Clunk Noise Recording

Quote:
Originally Posted by Rcfiddy1 View Post
Has anyone been able to find a solution to this clunking in front end? I had my car at the stealership for this problem but was told due to my heavily modified engine they can not replicate it. Whatever that means. I can replicate it just by turn hard or making a hard stop. I guess it was thier way of saying we don't want to look at it but thanks for the ride. I swapped out struts with new coilovers, new sways and new end links but I still have that loud clunk sound from just under passenger feet. Seems to be getting louder. I am at the point of getting rid of this car if I can not resolve this.

I replaced sway bars on a G8 GT and would get a clunk/noise when turning which was a combination of the aftermarket sway being allowed to move side to side (lack of solid retainer) and a lack of lubrication between the bar and the mounts. I'd look at the sway bar.


Sent from my iPad using Tapatalk
MTCobra is offline   Reply With Quote
Old 07-13-2014, 06:33 PM   #47
Rcfiddy1

 
Rcfiddy1's Avatar
 
Drives: 2010 Rally Yellow 2SS/RS #37115
Join Date: Oct 2009
Location: Manalapan, New Jersey
Posts: 1,923
Quote:
Originally Posted by MTCobra View Post
I replaced sway bars on a G8 GT and would get a clunk/noise when turning which was a combination of the aftermarket sway being allowed to move side to side (lack of solid retainer) and a lack of lubrication between the bar and the mounts. I'd look at the sway bar.


Sent from my iPad using Tapatalk
The sways are oem 1le sways I just installed while swapping struts with new ridetech coilovers. I was having this issue while still on stock suspension parts so I figured I'd start with the coilovers and sways with new end links to narrow the issue down. After having car aligned and taking it out for a spin I noticed I still had that clunk sound. So now I'm down to lca,radius arm engine mounts. If after that I still have this issue I am selling it.
__________________
Build Thread
ECS Supercharged, LS3 conversion, Blower Cam, Alky Meth, 3:45 rear, BMR Suspension parts, 1LE Sways, Billy Boat ZL1 dual mode exhaust.
Rcfiddy1 is offline   Reply With Quote
Old 07-13-2014, 07:36 PM   #48
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
I have yet to see an OEM front arm make a noise, unless the nuts were not tight.

To test the sway bar and endlinks for noise, disconnect and secure one end of one endlink so it will not foul as you drive. If there is no noise, you know where to look.
__________________
JusticePete is offline   Reply With Quote
Old 07-15-2014, 01:27 PM   #49
Rcfiddy1

 
Rcfiddy1's Avatar
 
Drives: 2010 Rally Yellow 2SS/RS #37115
Join Date: Oct 2009
Location: Manalapan, New Jersey
Posts: 1,923
SO i did a little recording of mine. Is yours the same sound?. You will notice as soon as I turn steering theres a clunk around 3,9,12sec,21-22-24-25-26sec mark.
__________________
Build Thread
ECS Supercharged, LS3 conversion, Blower Cam, Alky Meth, 3:45 rear, BMR Suspension parts, 1LE Sways, Billy Boat ZL1 dual mode exhaust.
Rcfiddy1 is offline   Reply With Quote
Old 07-15-2014, 09:09 PM   #50
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
That knock sounds like something in the tunnel. Motor or transmission mount is where I would start.
__________________
JusticePete is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.