Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
SNL Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics

Camaro ZL1 Forum - ZL1 Specific Topics Camaro ZL1 specific topics

Reply
 
Thread Tools
Old 10-07-2012, 08:17 AM   #1
JT3640
 
JT3640's Avatar
 
Drives: 2012 ZL1, 2012 QX56
Join Date: Mar 2012
Location: Ontario
Posts: 130
Paint Chips

Hi guys
Is anyone out there having any issues with their paint
I have approx. 16 stone chips on my car with 4,200 Km's on. I do not drive on a gravel road and yes there is some construction going on in the area which there always is in The GTA.
But really at this rate I will have to get the car painted in a year. I just can't believe that this is normal I've never had a vehicle in 25 years do this.
If anyone else is experiencing this I would like to know.
Thanks
JT3640 is offline   Reply With Quote
Old 10-07-2012, 09:08 AM   #2
Joebot8484
ZL1 # 1307
 
Joebot8484's Avatar
 
Drives: 2012 Camaro ZL1, 2008 Hummzilla H3
Join Date: Nov 2010
Location: Central New York
Posts: 1,788
I have some too brother (6000 miles about 10 chips), it's gonna happen. They don't paint these things like they use to. touch up the chips and put a clear bra on, that's what I'm gonna do.
__________________
Click on my signature for my build thread
Joebot8484 is offline   Reply With Quote
Old 10-07-2012, 09:58 AM   #3
JT3640
 
JT3640's Avatar
 
Drives: 2012 ZL1, 2012 QX56
Join Date: Mar 2012
Location: Ontario
Posts: 130
Ya I'm planning on doing it over the winter I just can't believe the quality of paint these days
They must be using environmentally friendly paints now which we know isn't as good as the paint in the past.
Classic should of, could of, would of done it at the start if I was smart.
I think there is some good chip repair products out there now.
JT3640 is offline   Reply With Quote
Old 10-07-2012, 10:02 AM   #4
Swacer


 
Drives: 2012 Camaro 2SS/RS
Join Date: Nov 2011
Location: Pittsburgh, PA
Posts: 2,339
Clear bra is your best option. Sadly, you will need all the chips filled before you can have one put on.

I have one on mine. 4,700 miles, not a single chip.
__________________
2012 2SS/RS Camaro
~Imperial Blue Metallic~LS3~M6~GM High Spoiler~GM Ground Effect~GM Tower Brace~Heritage Grill~Roto-Fab Cold Air Intake~Stainless Works Exhaust~Stainless Power Headers~VMAX Ported Throttle Body~Tuned By Frost~GEN5DYI Spare Clutch Reservior~Barton Short Throw~ShowStopper Side Markers~UMI Performance Trailing Arms~UMI Performance Tunnel Brace
Swacer is offline   Reply With Quote
Old 10-07-2012, 10:15 AM   #5
toml_pa
ʇuɐıʌǝp lɐıɔos
 
toml_pa's Avatar
 
Drives: 2011 2SS/RS LS3/M6
Join Date: Feb 2011
Location: Pennsylvania
Posts: 231
Paint chips have been an issue with Camaros since day one (search forum for "paint chip"). My 2011 SS had chips from the factory. When I took it to the dealer for touch up the body shop guy told me they had fixed several and had to completely re-paint the area behind the door on one. I was not happy.
I did a lot of research and went with 3m Scotchgard™ Paint Protection Film. It cost $1100 to do the front of the car including part of fenders and hood, A-pillars, roof above windshield, and mirrors. I also had them cut custom pieces for shark gill area behind the door. I had it done in April 2011 and have had no chips since. When I tell people I have it on the car, most still can't see it.
__________________

Way too many mods and way too much money. Wouldn't have it any other way.
toml_pa is offline   Reply With Quote
Old 10-09-2012, 08:08 AM   #6
Rizzo
 
Drives: 2010 Camaro SIM 2SS/RS
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 429
I put a clear bra on it within the first 50 miles. I am glad I did, because you can already see a few areas where this protected from rock chips.
__________________
=================================================
Rizzo is offline   Reply With Quote
Old 10-09-2012, 12:18 PM   #7
hognutz


 
hognutz's Avatar
 
Drives: 2013 ZL1
Join Date: Oct 2011
Location: tangent or
Posts: 2,661
Quote:
Originally Posted by JT3640 View Post
Hi guys
Is anyone out there having any issues with their paint
I have approx. 16 stone chips on my car with 4,200 Km's on. I do not drive on a gravel road and yes there is some construction going on in the area which there always is in The GTA.
But really at this rate I will have to get the car painted in a year. I just can't believe that this is normal I've never had a vehicle in 25 years do this.
If anyone else is experiencing this I would like to know.
Thanks
1. very sticky tires
2. rear fenders flare a bit

this issue is huge on Z06/Zr1's as well.
__________________
2013 ZL1 10%lower,rotfab,90mmtb,SP headers
(president of the tangent oregon trophy husband association, founding and only member)
2013 Dart
2013 Megacab 8" lift 38"mt's
hognutz is offline   Reply With Quote
Old 10-09-2012, 12:43 PM   #8
kbar4782
 
kbar4782's Avatar
 
Drives: 2012 ZL1, 00016
Join Date: Jan 2012
Location: Whitesville, NY
Posts: 265
I don't have any on the front, but I try not to tailgate people either. I do have a bunch on the gills in front of the rear tire. I have talked to my autobody guy and will get them fixed and then cover the area with clear bra material. As hognutz said. The front tires are wide, sticky and the body flares out in front of the rear tires. Its going to happen. Hate to see how bad your guys are because I only have 2,000 miles on mine and it makes me sick.
kbar4782 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.