Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-02-2009, 08:46 PM   #1
SS4PK
 
SS4PK's Avatar
 
Drives: 2010SS
Join Date: Apr 2009
Location: VA
Posts: 529
transmission cooling line leak-from factory

the guys at Champion Chevrolet did a great job going through our 1SS prior to us taking possession. they found a small leak where one of the transmission cooling lines go into the radiator. The line was cross threaded. The radiator is aluminum, and I suspect the line is steel, so the threads in the radiator are toast. it appears it came from the factory like this. They ordered a new radiator should have it tomorrow, God willing and the creek don't rise ( I crack myself up) and we hopefully will have the car tomorrow too. There are only 3 radiators available in the US. I hope others don't have other issues and can't get parts.

One other issue, at the top of the rear bumper -even with the taillights- the paint is "broken" still attached, where the bumper meets the metal. It will need painted.
__________________

Her Hot Rod.
SS4PK is offline   Reply With Quote
Old 06-02-2009, 08:53 PM   #2
Vash


 
Drives: 00 Blazer
Join Date: Aug 2008
Location: Texas
Posts: 5,104
Sounds like someone missed a defective fitting and tried to force it. You have to replace the fittings anytime you take the lines off (sidenote).
Vash is offline   Reply With Quote
Old 06-02-2009, 08:55 PM   #3
Andro
NOICE!!! ™
 
Andro's Avatar
 
Drives: Force Fed 427
Join Date: Jan 2009
Location: GOT BOOST?
Posts: 5,214
Hope everything works out
__________________
Andro is offline   Reply With Quote
Old 06-02-2009, 08:58 PM   #4
chevyridinghigh
The Bowtie Is Back
 
chevyridinghigh's Avatar
 
Drives: 2010 Silver Camaro SS/RS -Blk Int.
Join Date: May 2009
Location: Westchester County, NY
Posts: 655
Giving GM a good name... great
__________________
2SS RS SIM M6 with Polish Silver wheels
chevyridinghigh is offline   Reply With Quote
Old 06-02-2009, 08:59 PM   #5
x37e
 
x37e's Avatar
 
Drives: none
Join Date: Jun 2009
Location: anon
Posts: 28
Hope everything works out for the better.
__________________
Order#NJXPKK
1EH37 2LT(Manual baby) Black w/ white hockey stripes
IO Interior,and RS package
1100 = 5/1/09
2000 = 5/14/09
2500 = 5/22/09
3000 = 5/27/09
3300 = 6/6/09
3400 = 6/12/09
3800 = 6/23/09 2G1FG1EV7A9120829
x37e is offline   Reply With Quote
Old 06-02-2009, 09:01 PM   #6
spi
 
spi's Avatar
 
Drives: 2010 Black 2SS
Join Date: Feb 2009
Location: Pittsburg, KS/ Joplin, MO
Posts: 414
Send a message via MSN to spi Send a message via Yahoo to spi
I hope you get everything worked out and your car soon
__________________
2010 CAMARO 2SS
ORDERED OCT. 13,2008
DELIVERED JUNE 2, 2009

VIN# 2G1FK1EJ0A9106637
spi is offline   Reply With Quote
Old 06-02-2009, 09:03 PM   #7
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
Well, here's hoping the creek don't rise!
__________________


Number_9 is offline   Reply With Quote
Old 06-02-2009, 09:04 PM   #8
Jamie Mac
NCM-WINR
 
Jamie Mac's Avatar
 
Drives: 2010 SS/RS IOM 2014 2LT Stingray
Join Date: Mar 2009
Location: Pittsburgh
Posts: 2,324
At least you know it's there. May that be your only bad experience. Congrats
__________________
also drives a heavily modified Jeep Wrangler. It has LED headlights and wheel weights blacked out with Plasti Dip. It's Baller.
Jamie Mac is offline   Reply With Quote
Old 06-02-2009, 10:41 PM   #9
chevy dude
 
chevy dude's Avatar
 
Drives: 2010 1LT/RS IBM Camaro
Join Date: Jan 2009
Location: Michigan
Posts: 294
Actually their is a member on the 5th Gen forums with the same issue.I hope this isn't going to be another QC problem for GM?
__________________
Camaro nut!!!
chevy dude is offline   Reply With Quote
Old 06-02-2009, 11:01 PM   #10
KJS

 
KJS's Avatar
 
Drives: '10 RJT,'95&'14 Vette
Join Date: Feb 2009
Location: Cut Throat, NY
Posts: 1,695
Here's hoping that for the rest of your ownership those are the only issues that you ever have with this car. Ya paid 'yer dues!
Best of luck and enjoy.
__________________
"As ye sow, so shall ye reap" - Me

Mine at sunset
KJS is offline   Reply With Quote
Old 06-03-2009, 04:12 AM   #11
SleepWarz
Banned
 
Drives: 1991 New Yorker, 69 Tbird, ABM2SSRS
Join Date: May 2009
Location: BC Canada
Posts: 2,248
Quote:
Originally Posted by SS4PK View Post
the guys at Champion Chevrolet did a great job going through our 1SS prior to us taking possession. they found a small leak where one of the transmission cooling lines go into the radiator. The line was cross threaded. The radiator is aluminum, and I suspect the line is steel, so the threads in the radiator are toast. it appears it came from the factory like this. They ordered a new radiator should have it tomorrow, God willing and the creek don't rise ( I crack myself up) and we hopefully will have the car tomorrow too. There are only 3 radiators available in the US. I hope others don't have other issues and can't get parts.

One other issue, at the top of the rear bumper -even with the taillights- the paint is "broken" still attached, where the bumper meets the metal. It will need painted.


Why not just get a seperate tranny cooler installed? I would have done that had I ordered a automatic.
SleepWarz is offline   Reply With Quote
Old 06-03-2009, 08:52 AM   #12
SS4PK
 
SS4PK's Avatar
 
Drives: 2010SS
Join Date: Apr 2009
Location: VA
Posts: 529
it is the 6 speed.
__________________

Her Hot Rod.
SS4PK is offline   Reply With Quote
Old 06-03-2009, 09:01 AM   #13
MLL67RSSS

 
MLL67RSSS's Avatar
 
Drives: 67 Indy Pace Car
Join Date: May 2008
Location: Indianapolis
Posts: 1,468
Quote:
Originally Posted by SleepWarz View Post
Why not just get a seperate tranny cooler installed? I would have done that had I ordered a automatic.
When the Chevy Dealer put an auxillary tranny cooler on my car they still run it through the radiator. Said you need to to help bring the tranny up to operating temperature quicker, especially in the northern areas during winter. It can actually be bad for the transmission to run below operating temperature for long periods.
MLL67RSSS is offline   Reply With Quote
Old 06-03-2009, 09:03 AM   #14
SicSix6
The Demon Photographer
 
SicSix6's Avatar
 
Drives: 2010 1SS IOM Camaro
Join Date: May 2009
Location: Bristow, VA
Posts: 756
Sounds like they need to fix a few items for you, under warranty and or just because. Make sure it is noted and a We owe you card is filled out saying they will fix the stuff.
__________________

1SS IOM LS3, GM 4-pack guages, SLP SS Front Emblem, Roto-Fab CAI, Solo Performance Mach X Exhaust, Barton Industries Short Throw Shifter
SicSix6 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket cooling The_Stache Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 6 01-11-2010 05:40 AM
Camaro Manual Transmission LSxcellent 5th Gen Camaro SS LS LT General Discussions 17 08-01-2007 05:11 AM


All times are GMT -5. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.