Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
LSR Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics

Camaro ZL1 Forum - ZL1 Specific Topics Camaro ZL1 specific topics

Reply
 
Thread Tools
Old 10-26-2012, 08:30 AM   #1
black1105
 
Drives: 2013 Black ZL1
Join Date: Oct 2012
Location: Oakton, VA
Posts: 2
AAC's ZL1 Plasma LED Fog and DRL Bulbs

I just purchased the AAC's Plasma LED Fog & DRL bulbs for my ZL1 & I found out that some people had issue with their bulbs . It may have been regular LED bulb instead of Plasma type.

Anyway, I just want to confirm before the installation. Is there instruction how to install these bulbs? It's not same as regular Camaro due to Front Lip Spoiler.
black1105 is offline   Reply With Quote
Old 10-26-2012, 10:35 AM   #2
DangerZL1

 
Drives: Accord
Join Date: Oct 2009
Location: Memphis, TN Area
Posts: 1,910
I've heard the install is the same, by removing the Torx screws on the outer edge of the wheel well liner and pulling it back you should have access. This also requires removing the tire.
DangerZL1 is offline   Reply With Quote
Old 10-26-2012, 12:22 PM   #3
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,070
You do not have to remove the tire. Just turn the tire to the farthest it will go, depending on how big you are this should give you enough room to get your hands inside the liner.
__________________
I don't know where I belong.
I don't know where I went wrong
G-Oil Guy is offline   Reply With Quote
Old 10-26-2012, 02:58 PM   #4
Modern07
Mid-Florida Camaro Club
 
Modern07's Avatar
 
Drives: 2013 ZL1 #2303
Join Date: Jan 2011
Location: Heathrow, FL
Posts: 2,891
also note that the P13W leds will not fit securly as the fitting changed, so you will need to do a little modifcation to ensure they stay in correctly

I'm waiting for the correct fitting LEDs that will snap in securely before ordering
__________________
Modern07 is offline   Reply With Quote
Old 10-26-2012, 03:02 PM   #5
Deke736
COTW 12/3/12
 
Deke736's Avatar
 
Drives: 2012 Ashen Gray ZL1
Join Date: Aug 2011
Location: Glen Carbon, IL
Posts: 3,109
I have P13W's and mine fit perfectly. I have an early build though and I believe there was a change in fittings on later builds.
__________________
Deke736 is offline   Reply With Quote
Old 10-26-2012, 03:03 PM   #6
ZL1 Spoked

 
ZL1 Spoked's Avatar
 
Drives: 2013 Camaro ZL1 M6
Join Date: Aug 2012
Location: Bay Area CA
Posts: 1,021
Mine fit in perfect, no modification or anything just plug and play. Fits the exact same way as the stock ones, perfect fit and rid of that piss yellow look..
__________________
-2013 Camaro ZL1-Black Stripe Package-Ambient Light Kit-Subwoofer Package-Sunroof-Suede Package-NAV MYLINK-MANUAL BABY-Dual Vented Fenders-Exposed Carbon Fiber Insert
-Black 10 Spoke Wheels

604 RWHP 602 LBS/TQ
ZL1 Spoked is offline   Reply With Quote
Old 10-26-2012, 04:38 PM   #7
Modern07
Mid-Florida Camaro Club
 
Modern07's Avatar
 
Drives: 2013 ZL1 #2303
Join Date: Jan 2011
Location: Heathrow, FL
Posts: 2,891
Quote:
Originally Posted by ZL1 Spoked View Post
Mine fit in perfect, no modification or anything just plug and play. Fits the exact same way as the stock ones, perfect fit and rid of that piss yellow look..
Did they Snap into place or are they loose?

Late 2012's and 2013 have a different fitting than P13W - similar, but you have to break a tab before it will fit - maybe AAC did this for you first so you didn't notice, but regardless it wouldn't snap until place still
__________________
Modern07 is offline   Reply With Quote
Old 10-26-2012, 04:55 PM   #8
jameslk55

 
jameslk55's Avatar
 
Drives: 2012 2LT/RS, 2005 SLK55 AMG
Join Date: Jul 2012
Location: Falls Church, VA
Posts: 1,167
Quote:
Originally Posted by black1105 View Post
I just purchased the AAC's Plasma LED Fog & DRL bulbs for my ZL1 & I found out that some people had issue with their bulbs . It may have been regular LED bulb instead of Plasma type.

Anyway, I just want to confirm before the installation. Is there instruction how to install these bulbs? It's not same as regular Camaro due to Front Lip Spoiler.
No problems with my plasmas (knock on wood). The DRL bulb tab should already have been shaved by AAC. You can see where the tabs used to be. I would just turn the wheels all the way and loosen the wheel well bolts. I used 4 zip ties to secure each DRL bulb but I did a ZL1 front end conversion-everything was off the car for easy access.

Not sure about the 2013s...
jameslk55 is offline   Reply With Quote
Old 10-26-2012, 06:45 PM   #9
ZL1 Spoked

 
ZL1 Spoked's Avatar
 
Drives: 2013 Camaro ZL1 M6
Join Date: Aug 2012
Location: Bay Area CA
Posts: 1,021
Quote:
Originally Posted by Modern07 View Post
Did they Snap into place or are they loose?

Late 2012's and 2013 have a different fitting than P13W - similar, but you have to break a tab before it will fit - maybe AAC did this for you first so you didn't notice, but regardless it wouldn't snap until place still
They just snapped in perfectly, they had the same exact tabs as the stock ones. Nothing was done to them they were exact fits.
__________________
-2013 Camaro ZL1-Black Stripe Package-Ambient Light Kit-Subwoofer Package-Sunroof-Suede Package-NAV MYLINK-MANUAL BABY-Dual Vented Fenders-Exposed Carbon Fiber Insert
-Black 10 Spoke Wheels

604 RWHP 602 LBS/TQ
ZL1 Spoked is offline   Reply With Quote
Old 10-26-2012, 07:10 PM   #10
Modern07
Mid-Florida Camaro Club
 
Modern07's Avatar
 
Drives: 2013 ZL1 #2303
Join Date: Jan 2011
Location: Heathrow, FL
Posts: 2,891
Quote:
Originally Posted by ZL1 Spoked View Post
They just snapped in perfectly, they had the same exact tabs as the stock ones. Nothing was done to them they were exact fits.
Hmm...Well now I'm confused...I read all the threads about them not fitting the 2013s properly....only one way to find out though!
__________________
Modern07 is offline   Reply With Quote
Old 10-26-2012, 07:31 PM   #11
OVERPAR73
2013 CRT ZL1 convertible
 
OVERPAR73's Avatar
 
Drives: 2013 ZL1 vert
Join Date: May 2009
Location: Des Moines, IA
Posts: 1,020
I installed mine with no problems at all on my 2013 ZL1 convertible. All I did was remove the screws on the bottom outside lower valance, pull it down a little for my arm to fit up and remove the old ones and swapped them out with no problem. They look really nice! I will do the same procedure on the front sidemarker lights when I finally receive them from AAC (LED, ghosted, painted). I will take before and after pics.
OVERPAR73 is offline   Reply With Quote
Old 09-09-2013, 08:49 AM   #12
URBAN LEGEND
 
URBAN LEGEND's Avatar
 
Drives: 13 BMW M5/13 ZL1
Join Date: Jun 2013
Location: Houston
Posts: 730
Anyone have any pictures?
URBAN LEGEND is offline   Reply With Quote
Old 09-09-2013, 09:25 AM   #13
LuckyZL-1
Ragtop Rocket!!!
 
LuckyZL-1's Avatar
 
Drives: Black on Black Convertible
Join Date: Mar 2013
Location: Odessa Texas
Posts: 482
Quote:
Originally Posted by Modern07 View Post
Hmm...Well now I'm confused...I read all the threads about them not fitting the 2013s properly....only one way to find out though!
Mine didn't snap in either I had to southern engineer mine also.
__________________
ADM built 2013 Triple Black ZL-1 Convertible M6
ADM custom cam, LPE stage 2 heads with dual valve springs, LS-3 ported throttle body, LPE 2 piece pulley, LPE overdrive balancer, 10% overdrive pulley, ported supercharger inlet, ADM race intake system, stainless works 1-7/8 headers, Injector Dynamics injectors, ADM heat exchanger, ADM dual fuel pump system, ADM exhaust switch, ADM 3 tunes tuning package.
744rwhp 727rwtq
LuckyZL-1 is offline   Reply With Quote
Old 09-09-2013, 10:16 AM   #14
SamHouseIII
I Carry!
 
SamHouseIII's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2011
Location: Fletcher, Ok
Posts: 2,516
I had to modify the tab on mine too....have had no issues with them coming out, in fact I hit a bobcat and it broke the bulb loose from the housing (still worked, little quick steel, good as new), but never came out of the connector!!!
__________________
I am a Modaholic!! Please Help!! Do Not feed my addicition....See build...
http://www.camaro5.com/forums/showthread.php?t=261540

From Oklahoma, Join us on Facebook
https://www.facebook.com/groups/okcamaros/

SamHouseIII is offline   Reply With Quote
Old 09-12-2013, 09:05 AM   #15
TomF1
 
TomF1's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2012
Location: Ajax, Ontario
Posts: 162
Red face P13W SMD68

I installed my new LED DRL last night and did the mod to keep them on at night.
Not as easy as the instructions, the 3 screws on the fender liner turn into 10 on the ZL1
And snapping off the little white tab on the housing was easy.

Looks good, now I need the H11 LEDs to match
And might as well do side markers same time since its difficult to take appart
TomF1 is online now   Reply With Quote
Old 09-12-2013, 02:49 PM   #16
URBAN LEGEND
 
URBAN LEGEND's Avatar
 
Drives: 13 BMW M5/13 ZL1
Join Date: Jun 2013
Location: Houston
Posts: 730
Pictures of these bad boys installed and lit please. Thanks.
URBAN LEGEND is offline   Reply With Quote
Old 09-12-2013, 06:14 PM   #17
URBAN LEGEND
 
URBAN LEGEND's Avatar
 
Drives: 13 BMW M5/13 ZL1
Join Date: Jun 2013
Location: Houston
Posts: 730
Don't get caught up in next year. Manufacturers always change things here and there to keep interest in product. Unless you get a car every year then you won't keep up with them.

Buy now and worry about next year on next year.
URBAN LEGEND is offline   Reply With Quote
Old 09-13-2013, 12:10 AM   #18
SamHouseIII
I Carry!
 
SamHouseIII's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2011
Location: Fletcher, Ok
Posts: 2,516
Here's mine
Attached Images
 
__________________
I am a Modaholic!! Please Help!! Do Not feed my addicition....See build...
http://www.camaro5.com/forums/showthread.php?t=261540

From Oklahoma, Join us on Facebook
https://www.facebook.com/groups/okcamaros/

SamHouseIII is offline   Reply With Quote
Old 11-02-2013, 12:30 PM   #19
Msmall143

 
Msmall143's Avatar
 
Drives: Camaro
Join Date: Sep 2013
Location: NOVA
Posts: 1,731
Has anyone had issues after doing this. I upgraded mine an got a check engine light for some type of module loosing power. Dealership could t duplicate the error but said its probably tied back to the aftermarket light. I also had the harness connecting drl to halos so they are both on at the same time
Msmall143 is offline   Reply With Quote
Old 11-02-2013, 12:37 PM   #20
StealthZL1
 
StealthZL1's Avatar
 
Drives: 2013 Camaro ZL1
Join Date: Aug 2013
Location: Las Vegas, Nevada
Posts: 296


I haven't had any issues with mine.
StealthZL1 is offline   Reply With Quote
Old 11-02-2013, 02:06 PM   #21
Msmall143

 
Msmall143's Avatar
 
Drives: Camaro
Join Date: Sep 2013
Location: NOVA
Posts: 1,731
How long have you been runnin them?

It's hard for me to believe changing bulbs would trip codes that wouldn't allow the car to start.

Pic of mine
Attached Images
 
Msmall143 is offline   Reply With Quote
Old 11-02-2013, 03:36 PM   #22
Deke736
COTW 12/3/12
 
Deke736's Avatar
 
Drives: 2012 Ashen Gray ZL1
Join Date: Aug 2011
Location: Glen Carbon, IL
Posts: 3,109
Quote:
Originally Posted by Msmall143 View Post
Has anyone had issues after doing this. I upgraded mine an got a check engine light for some type of module loosing power. Dealership could t duplicate the error but said its probably tied back to the aftermarket light. I also had the harness connecting drl to halos so they are both on at the same time
I've had mine on since day 1 (April 2012) and had the DRL harness and I have not had any issues like yours. In fact, I have never heard of a problem like yours. I would have a hard time believing that the lights caused the engine light.
__________________
Deke736 is offline   Reply With Quote
Old 11-02-2013, 03:46 PM   #23
Msmall143

 
Msmall143's Avatar
 
Drives: Camaro
Join Date: Sep 2013
Location: NOVA
Posts: 1,731
Agreed, hopefully it was a one time thing. If it happens again its going back to the dealership,
Msmall143 is offline   Reply With Quote
Old 11-02-2013, 05:15 PM   #24
DJ-Silver 2SS
Ah DJ-IOM ZL1 haha
 
DJ-Silver 2SS's Avatar
 
Drives: 13 IOM ZL1 M6 & 10 SIM 2SS M6
Join Date: Jul 2009
Location: Augusta, GA
Posts: 519
Send a message via Yahoo to DJ-Silver 2SS
I had to make sure I got the PSX26W version for my ZL1.
Attached Images
 
__________________

2013 IOM ZL1 #002415 Born 09/13/12
2010 SIM 2SS/RS #005549 Born 05/02/09
DJ-Silver 2SS is offline   Reply With Quote
Old 11-02-2013, 05:17 PM   #25
FINALLYSATISFIED
Est.1775
 
FINALLYSATISFIED's Avatar
 
Drives: ZL1#206 (Sold) 6th Gen!?
Join Date: Sep 2009
Location: SoCal
Posts: 5,378
Quote:
Originally Posted by Deke736 View Post
I have P13W's and mine fit perfectly. I have an early build though and I believe there was a change in fittings on later builds.
He is correct. Early builds differ from later builds.
FINALLYSATISFIED is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.