Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BORLA
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 11-04-2012, 08:19 AM   #1
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,427
squawking noise coming from supercharger

just crossed 14k miles and im starting to hear loud a squawking noise coming from my supercharger mostly at startup but today its just not going away. sounds like some sort of bad bearing, going to dealer in morning
joes407 is offline   Reply With Quote
Old 11-04-2012, 08:26 AM   #2
DrkPhx

 
DrkPhx's Avatar
 
Drives: 2013 Triple Black ZL1 / 2006 TB SS
Join Date: Feb 2011
Location: St Michael, MN
Posts: 1,633
It's probably the spring insulator. Common on the LSA motor. More of a nuisance than anything. If they replace it with the stock piece it will come back again. A few aftermarket companies have a solid insulator which does minimize the noise, but doesn't completely eliminate it.
DrkPhx is online now   Reply With Quote
Old 11-04-2012, 09:44 AM   #3
4fbodys
 
4fbodys's Avatar
 
Drives: 3 3rd gens 1 4th gen
Join Date: Nov 2011
Location: wv
Posts: 82
At 8000 my superchager started howling at about 2500 to 3000 on part throttle went to the dealer they put on a new superchager hope the the new one holds up better want to put on a pulley but wont if this is going to be a problem
4fbodys is offline   Reply With Quote
Old 11-04-2012, 09:52 AM   #4
justindewoody
 
Drives: 2013 Camaro ZL1
Join Date: Sep 2012
Location: Spring, TX
Posts: 136
On my GT500, I had a Whipple 2.9L blower. I bought it used from a guy in Florida. He did NOT check the oil in the gear case, but I DID when I received it from him. It was low, so I drained it and replaced the oil before installing it on my motor. I just knew that this was going to be a problem down the road (him running the blower without enough oil in the gear case)...and sure enough, I started to hear some squawking too. It got worse and worse, and then failure. I sent it to Whipple in California for a repair job. The entire front gear case was ruined. They replaced all the internals. The entire blower was brand new except for the outside housing. That obviously fixed the problem. So, it sounds to me like your blower's gears are going out. Time to get it to the dealer. But don't worry, warranty will take care of everything.
__________________
2013 Camaro ZL1 Silver Ice #3187 TPW 10/22
1100 Preliminary Order Accepted 9/26/2012
1102 Preliminary Order Added Thru Web 9/26/2012
2000 Accepted by GM 10/01/2012
2500 Preferenced 10/02/2012
3000 Accepted by Production Control 10/02/2012
3100 Available to Sequence 10/11/2012
3300 Scheduled for Production 10/11/2012
3400 Broadcast 10/18/2012
3800 Produced 10/22/2012
4000 Available to Ship 10/23/2012
4150 Original Invoice 10/23/2012
4B00 Bayed 10/23/2012
4200 Shipped 10/26/2012
4800 Rail Ramp Unload 11/02/2012
5000/6000 Delivered 11/05/2012
justindewoody is offline   Reply With Quote
Old 11-04-2012, 10:21 AM   #5
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,427
im not worried just makes me question doin any mods that would kill the 100k mile warranty on the motor. is it safe to drive to the dealership like that or should i take off the supercharger belt then drive it there?
joes407 is offline   Reply With Quote
Old 11-04-2012, 10:27 AM   #6
FINALLYSATISFIED
Est.1775
 
FINALLYSATISFIED's Avatar
 
Drives: '15 Challenger Hellcat
Join Date: Sep 2009
Location: SoCal
Posts: 5,495
I wouldn't do any mods that would destroy your warranty, thats just me personally. Good thing you haven't hope your able to get your car up to speed!...
FINALLYSATISFIED is offline   Reply With Quote
Old 11-04-2012, 11:21 AM   #7
4fbodys
 
4fbodys's Avatar
 
Drives: 3 3rd gens 1 4th gen
Join Date: Nov 2011
Location: wv
Posts: 82
Don't take the belt off drive it or tow it the warranty should cover the tow I drove mine like 300 mile before I took it in you should be fine
4fbodys is offline   Reply With Quote
Old 11-04-2012, 12:31 PM   #8
ZEDL1
 
Drives: 2013 ZL1 Triple Black, 2015 2LT/RS
Join Date: Apr 2012
Location: Toronto, Canada
Posts: 394
Quote:
Originally Posted by justindewoody View Post
On my GT500, I had a Whipple 2.9L blower. I bought it used from a guy in Florida. He did NOT check the oil in the gear case, but I DID when I received it from him. It was low, so I drained it and replaced the oil before installing it on my motor. I just knew that this was going to be a problem down the road (him running the blower without enough oil in the gear case)...and sure enough, I started to hear some squawking too. It got worse and worse, and then failure. I sent it to Whipple in California for a repair job. The entire front gear case was ruined. They replaced all the internals. The entire blower was brand new except for the outside housing. That obviously fixed the problem. So, it sounds to me like your blower's gears are going out. Time to get it to the dealer. But don't worry, warranty will take care of everything.
You bring up an interesting point that I hadn't thought about. Is there a blower gear oil check area on a stock ZL1 supercharger? I don't remember it being mentioned in our forum before. Thanks.
ZEDL1 is offline   Reply With Quote
Old 11-04-2012, 12:35 PM   #9
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,427
Quote:
Originally Posted by 4fbodys View Post
Don't take the belt off drive it or tow it the warranty should cover the tow I drove mine like 300 mile before I took it in you should be fine
Dont drive it you say yet you put 300 miles on it that way? Ok then
joes407 is offline   Reply With Quote
Old 11-04-2012, 02:11 PM   #10
4fbodys
 
4fbodys's Avatar
 
Drives: 3 3rd gens 1 4th gen
Join Date: Nov 2011
Location: wv
Posts: 82
I said dont take off the belt the tech that may work on your car will say you are tampering with it I did not say dont drive it I am a tech at a dealer for another car brand and know that our cars run the a tvs style blower and we are filed for life so becareful what you do take it in and let the warranty deal with it thats what it's there for
4fbodys is offline   Reply With Quote
Old 11-04-2012, 03:14 PM   #11
justindewoody
 
Drives: 2013 Camaro ZL1
Join Date: Sep 2012
Location: Spring, TX
Posts: 136
Yes, you CAN take off the blower belt and still drive it. It will feel very slow, but drivable. I have done this very thing before. it will be like driving your car around very slowly where you don't get into boost. It will be OK though. Take it STRAIGHT TO THE DEALERSHIP.
__________________
2013 Camaro ZL1 Silver Ice #3187 TPW 10/22
1100 Preliminary Order Accepted 9/26/2012
1102 Preliminary Order Added Thru Web 9/26/2012
2000 Accepted by GM 10/01/2012
2500 Preferenced 10/02/2012
3000 Accepted by Production Control 10/02/2012
3100 Available to Sequence 10/11/2012
3300 Scheduled for Production 10/11/2012
3400 Broadcast 10/18/2012
3800 Produced 10/22/2012
4000 Available to Ship 10/23/2012
4150 Original Invoice 10/23/2012
4B00 Bayed 10/23/2012
4200 Shipped 10/26/2012
4800 Rail Ramp Unload 11/02/2012
5000/6000 Delivered 11/05/2012
justindewoody is offline   Reply With Quote
Old 11-04-2012, 03:26 PM   #12
Al C.
 
Al C.'s Avatar
 
Drives: ZL1 #529 "El-Jefe"
Join Date: Mar 2012
Location: Las Vegas, NV
Posts: 673
Quote:
Originally Posted by ZEDL1 View Post
You bring up an interesting point that I hadn't thought about. Is there a blower gear oil check area on a stock ZL1 supercharger? I don't remember it being mentioned in our forum before. Thanks.
+1 ?????
Al C. is offline   Reply With Quote
Old 11-04-2012, 03:35 PM   #13
ex-SS-ve
 

Join Date: Feb 2010
Posts: 581
There is no oil check or fluid replacement on the tvs 1900 these cars come with . Its a sealed bearing design. Same for the tvs 2300 on the zr1.
ex-SS-ve is offline   Reply With Quote
Old 11-04-2012, 04:24 PM   #14
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,427
How long of a repair is that?
joes407 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:32 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.