Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-09-2009, 08:08 PM   #1
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
I Have NO POWER!

Took delivery of my 2010 Camaro L99 about 3 weeks ago and now it has a little over 1000 miles on it. I sold a bone stock 2005 GTO to get it. I was pleased to see the tests show that the New Camaro was 3 tenths quicker in the quarter mile then the GTO. I got the car and it did feel slower than my GTO, but it also felt smoother. I did not want to push it until I got a few miles on it. My son has a 2000 Trans Am with 325 horsepower. We raced several times when I had the GTO and I would beat him by about 4 car lengths. The power just did not seem to be there in the new Camaro so I had my son meet me at our favorite racing spot within the the last hour. Sure enough he pulled me out of the hole and beat me by almost 4 car lengths. The engine is defiantly not producing 400 ponies and the shifts are weak.

Does anyone know what the problem could be? I will be calling the dealer in the morning. Any help would be appreciated.
rpepka is offline   Reply With Quote
Old 06-09-2009, 08:12 PM   #2
stovt001


 
stovt001's Avatar
 
Drives: 2006 Cobalt, 2004 Taurus wagon
Join Date: Oct 2007
Location: California
Posts: 3,817
How many miles on it? Could still be tight and needs a couple thousand more miles to break in.
__________________
"It's kind of fun to do the impossible" - Walt Disney

There's a great big beautiful tomorrow
shining at the end of every day
There's a great big beautiful tomorrow
Just a dream away
stovt001 is offline   Reply With Quote
Old 06-09-2009, 08:12 PM   #3
CamaroSpike23
Mr. Nitpicky
 
CamaroSpike23's Avatar
 
Drives: anything I can get my hands on
Join Date: Sep 2006
Location: anywhere and everywhere
Posts: 22,930
Send a message via Yahoo to CamaroSpike23
you launching with traction control on? are you shifting using the paddles? if you are using the paddles are you making sure you are in 1st gear (and not 2nd) when you launch?
__________________
Never race anything you can't afford to light on fire and push off a cliff
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.

Quote:
Originally Posted by Bulldogwinters View Post
Read that link that Spike posted, it'll tell you everything you need to know.
Quote:
Originally Posted by WheelmanSS View Post
Post count is truly an accurate measure of how cool someone is on the Internet.
Quote:
Originally Posted by Greg Norris View Post
I piss excellence
and fart awesomeness
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.
"You can think I'm wrong, but that's no reason to quit thinking.”
Quote:
Originally Posted by Overflow View Post
But not all people were born awesome like you, Spike.
CamaroSpike23 is offline   Reply With Quote
Old 06-09-2009, 08:14 PM   #4
Scott@Bjorn3D


 
Scott@Bjorn3D's Avatar
 
Drives: Kami, 2013 2SS LS3 Luvin
Join Date: Oct 2008
Location: Eufaula, Alabama
Posts: 6,161
Send a message via MSN to Scott@Bjorn3D
Yeah miles please. I am at 1500 and today was able to get a nice burn off of her. Held the brake with left foot, floored it with the right and left of the brake. She smoked them good. But it has been said the LS Engines are not really broke in and giving you good HP till about 5000 miles.
__________________
2013 2SS, GM Strut Tower Brace, CAI Intake Black, VMAX TB, Elite Catch Can, Hotchkis Chassis Brace, Hurst Shifter, 3.91 1LE Complete Rear End, NPP, 1LE Track Pack,Factory Reproductions Style 41 ZL1 Fitment Wheels 10" on all 4 corners
Scott@Bjorn3D is offline   Reply With Quote
Old 06-09-2009, 08:15 PM   #5
Indpowr
Account Suspended
 
Drives: Corvette C6
Join Date: May 2008
Location: Florida
Posts: 7,028
I have owned an 06 GTO as well but have not driven our new Camaro yet since its getting worked on. But, the Camaro looks a lot better and with the LS99/LS3 motor there is a lot more potential so do not worry about it.
Indpowr is offline   Reply With Quote
Old 06-09-2009, 08:23 PM   #6
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by CamaroSpike23 View Post
you launching with traction control on? are you shifting using the paddles? if you are using the paddles are you making sure you are in 1st gear (and not 2nd) when you launch?
I launched several ways, on, off, paddle shift, automatic shift, my kid beat me with 320hp! The car does not seem powerful at all compared to my GTO.
rpepka is offline   Reply With Quote
Old 06-09-2009, 08:25 PM   #7
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by Scott@Bjorn3D View Post
Yeah miles please. I am at 1500 and today was able to get a nice burn off of her. Held the brake with left foot, floored it with the right and left of the brake. She smoked them good. But it has been said the LS Engines are not really broke in and giving you good HP till about 5000 miles.
I try doing that with mine and I get some mild scratch, I do have the 21 inch wheels though.
rpepka is offline   Reply With Quote
Old 06-09-2009, 08:35 PM   #8
LabRat
 
Drives: Wheeled Vehicles
Join Date: May 2009
Location: St Paul,MN
Posts: 285
Quote:
Originally Posted by rpepka View Post
I launched several ways, on, off, paddle shift, automatic shift, my kid beat me with 320hp! The car does not seem powerful at all compared to my GTO.
If your fuel management system is upderscrewed, you may have been driving a six all this time.

LabRat
LabRat is offline   Reply With Quote
Old 06-09-2009, 08:40 PM   #9
The_Blur
Jayhawk USN
 
The_Blur's Avatar
 
Drives: 6.2L of AWESOME! 2011 L99 2SS
Join Date: Nov 2007
Location: NAS Whiting Field
Posts: 14,306
Send a message via AIM to The_Blur
With the automatic, you start in second. You need to downshift using the paddles in order to get the ideal launch. I'm fairly certain that that is your problem, although getting a dyno done would be the best way to verify its power.
The_Blur is offline   Reply With Quote
Old 06-09-2009, 08:42 PM   #10
1GTEC
 
1GTEC's Avatar
 
Drives: GMC Sierra
Join Date: Jun 2008
Location: San Antonio
Posts: 23
I would have kept the GTO over the Camaro.
1GTEC is offline   Reply With Quote
Old 06-09-2009, 08:43 PM   #11
gotpball44
Boost Is Your Friend
 
gotpball44's Avatar
 
Drives: 2010 Black 1SS Camaro
Join Date: Oct 2008
Location: La Mirada CA
Posts: 1,194
Send a message via AIM to gotpball44
You might have the same problem as me. Has your check engine light came on? Cause it doesn't come on every time you floor it. It comes on every once in a while. You should put your car on a dyno and test your power, plus hook up a diagnostics thing to your computer to read the knock retard. Because my car is 100rwhp less than it should. The computer happened to be faulty and retard timing every time you floor it. Making the horsepower level drop. So thats maybe why you lost

Here is a link to my problem:
http://www.camaro5.com/forums/showthread.php?t=25857
gotpball44 is offline   Reply With Quote
Old 06-09-2009, 08:44 PM   #12
DeathChill

 
Drives: 2010 Hyundai Genesis Coupe 2.0T
Join Date: Dec 2008
Location: Mission, BC
Posts: 864
I thought that there were different modes for the automatic that let it perform a little better?
DeathChill is offline   Reply With Quote
Old 06-09-2009, 08:48 PM   #13
logan1080
 
logan1080's Avatar
 
Drives: 2003 Crew Cab Duramax
Join Date: Aug 2008
Location: canada
Posts: 693
I wouldnt worry about the trans am beating you. My buddy had a trans am with the 6 speed and 325 hp engine in it. He ran a 12.4 1/4 mile bone stock. They are fast as hell. Most guys are running 13.5ish in there new camaros.
logan1080 is offline   Reply With Quote
Old 06-09-2009, 08:53 PM   #14
gotpball44
Boost Is Your Friend
 
gotpball44's Avatar
 
Drives: 2010 Black 1SS Camaro
Join Date: Oct 2008
Location: La Mirada CA
Posts: 1,194
Send a message via AIM to gotpball44
Quote:
Originally Posted by logan1080 View Post
I wouldnt worry about the trans am beating you. My buddy had a trans am with the 6 speed and 325 hp engine in it. He ran a 12.4 1/4 mile bone stock. They are fast as hell. Most guys are running 13.5ish in there new camaros.
but he has raced his son many times in in his gto. So he knows his sons car. He used to beat him by 4 cars, now he is losing by 4. So he is giving up 8 car lengths with his new camaro from his gto? I think there might be something wrong there.

He probably has the same problem as me, cause my car felt slow and its a manual
gotpball44 is offline   Reply With Quote
Old 06-09-2009, 08:56 PM   #15
logan1080
 
logan1080's Avatar
 
Drives: 2003 Crew Cab Duramax
Join Date: Aug 2008
Location: canada
Posts: 693
Hmm I am starting to worry haha. I hope these aren't going to be slower than expected cars.
logan1080 is offline   Reply With Quote
Old 06-09-2009, 09:02 PM   #16
JSOC_MQ1
 
Drives: 2010 IBM 2SS
Join Date: Jan 2009
Location: Missouri
Posts: 116
I would suspect that you may have the same problem as gotpball44 from above. Dyno your car and or go back to your dealership.
JSOC_MQ1 is offline   Reply With Quote
Old 06-09-2009, 09:04 PM   #17
SSRider
 
SSRider's Avatar
 
Drives: Black 2SS RS M6
Join Date: May 2009
Location: Arizona
Posts: 85
Quote:
Originally Posted by rpepka View Post
Took delivery of my 2010 Camaro L99 about 3 weeks ago and now it has a little over 1000 miles on it. I sold a bone stock 2005 GTO to get it. I was pleased to see the tests show that the New Camaro was 3 tenths quicker in the quarter mile then the GTO. I got the car and it did feel slower than my GTO, but it also felt smoother. I did not want to push it until I got a few miles on it. My son has a 2000 Trans Am with 325 horsepower. We raced several times when I had the GTO and I would beat him by about 4 car lengths. The power just did not seem to be there in the new Camaro so I had my son meet me at our favorite racing spot within the the last hour. Sure enough he pulled me out of the hole and beat me by almost 4 car lengths. The engine is defiantly not producing 400 ponies and the shifts are weak.

Does anyone know what the problem could be? I will be calling the dealer in the morning. Any help would be appreciated.
Did you check under the hood? Maybe "they" accidentally installed the 6cyl engine???

But seriously, I know you are concerned, I have had my fair share of problems like this and there is always a plausable explaination. I would have to agree with a previous post that suggested you are starting off in second gear. If you rule out the previous suggestion then take it to your dealer and have them scan it.
__________________
Black 2SS/RS M6
VIN# 2G1FT1EW4A9121666 (Bayed)
SSRider is offline   Reply With Quote
Old 06-09-2009, 09:05 PM   #18
CamaroSpike23
Mr. Nitpicky
 
CamaroSpike23's Avatar
 
Drives: anything I can get my hands on
Join Date: Sep 2006
Location: anywhere and everywhere
Posts: 22,930
Send a message via Yahoo to CamaroSpike23
Quote:
Originally Posted by rpepka View Post
I launched several ways, on, off, paddle shift, automatic shift, my kid beat me with 320hp! The car does not seem powerful at all compared to my GTO.
but did you ensure you were in 1st when you started?

also, 320rwhp in a 3500lb car compared to ~370rwhp in a 4000lb car
__________________
Never race anything you can't afford to light on fire and push off a cliff
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.

Quote:
Originally Posted by Bulldogwinters View Post
Read that link that Spike posted, it'll tell you everything you need to know.
Quote:
Originally Posted by WheelmanSS View Post
Post count is truly an accurate measure of how cool someone is on the Internet.
Quote:
Originally Posted by Greg Norris View Post
I piss excellence
and fart awesomeness
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.
"You can think I'm wrong, but that's no reason to quit thinking.”
Quote:
Originally Posted by Overflow View Post
But not all people were born awesome like you, Spike.
CamaroSpike23 is offline   Reply With Quote
Old 06-09-2009, 09:15 PM   #19
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by LabRat View Post
If your fuel management system is upderscrewed, you may have been driving a six all this time.

LabRat
That Makes Sence
rpepka is offline   Reply With Quote
Old 06-09-2009, 09:16 PM   #20
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by CamaroSpike23 View Post
but did you ensure you were in 1st when you started?

also, 320rwhp in a 3500lb car compared to ~370rwhp in a 4000lb car
Oh YES!
rpepka is offline   Reply With Quote
Old 06-09-2009, 09:19 PM   #21
bballr4567
 
Drives: 2006 GTO
Join Date: Aug 2008
Location: Evansville, IN
Posts: 718
Quote:
Originally Posted by logan1080 View Post
I wouldnt worry about the trans am beating you. My buddy had a trans am with the 6 speed and 325 hp engine in it. He ran a 12.4 1/4 mile bone stock. They are fast as hell. Most guys are running 13.5ish in there new camaros.
Did you mean 13.4 instead of 12.4? If not, that is the FASTEST stock Fbody in the world.

OP, just give it time to break in. Plus, youll learn how to launch it to get it going better.
bballr4567 is offline   Reply With Quote
Old 06-09-2009, 09:21 PM   #22
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by gotpball44 View Post
but he has raced his son many times in in his gto. So he knows his sons car. He used to beat him by 4 cars, now he is losing by 4. So he is giving up 8 car lengths with his new camaro from his gto? I think there might be something wrong there.

He probably has the same problem as me, cause my car felt slow and its a manual
This makes sence, thank you for taking the time to read and understand
rpepka is offline   Reply With Quote
Old 06-09-2009, 09:26 PM   #23
SSRS2010
SS/RSVIN04274
 
SSRS2010's Avatar
 
Drives: 2010 CAMARO.
Join Date: Apr 2009
Location: Las Cruces NM
Posts: 1,363
[QUOTE=Scott@Bjorn3D;569020]Yeah miles please. I am at 1500 and today was able to get a nice burn off of her. Held the brake with left foot, floored it with the right and left of the brake. She smoked them good. But it has been said the LS Engines are not really broke in and giving you good HP till about 5000 miles.[/QUOT MY FAMILY WILL PRAY FOR YOUR FAMILY
SSRS2010 is offline   Reply With Quote
Old 06-09-2009, 09:56 PM   #24
SicSix6
The Demon Photographer
 
SicSix6's Avatar
 
Drives: 2010 1SS IOM Camaro
Join Date: May 2009
Location: Bristow, VA
Posts: 758
There could actually be a problem. have you taken it to the dealer to have them assess posible problems?
__________________

1SS IOM LS3, GM 4-pack guages, SLP SS Front Emblem, Roto-Fab CAI, Solo Performance Mach X Exhaust, Barton Industries Short Throw Shifter
SicSix6 is offline   Reply With Quote
Old 06-09-2009, 10:00 PM   #25
rpepka

 
rpepka's Avatar
 
Drives: 2013 ZL1 # 2195
Join Date: Jun 2009
Location: Bradenton, FL
Posts: 965
Quote:
Originally Posted by SicSix6 View Post
There could actually be a problem. have you taken it to the dealer to have them assess posible problems?
no i just raced him this evening.
rpepka is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody Spray'n their SS yet - nitrous ? WeeZee Forced Induction - V8 37 12-29-2012 10:56 PM
Nitrous System ?????s PoleCat2SSRS2010 Forced Induction - V8 29 12-08-2010 06:55 PM
Well sunroof question answered (PIC) Black5thgen 5th Gen Camaro SS LS LT General Discussions 152 08-29-2009 11:23 PM
Turbocharge your way to efficiency.....and power! Mr. Wyndham Forced Induction - V8 20 07-06-2008 01:46 PM
JD Power survey: Younger Buyers Avoiding Domestics Scotsman General Automotive + Other Cars Discussion 6 12-04-2007 02:31 AM


All times are GMT -5. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.