Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics

Camaro ZL1 Forum - ZL1 Specific Topics Camaro ZL1 specific topics

Reply
 
Thread Tools
Old 05-31-2013, 03:01 AM   #1
Vroom
 
Drives: 2013 Camaro ZL1
Join Date: Oct 2012
Location: SF Bay Area
Posts: 226
Exclamation Supercharger has noise - gets replaced [VID]

Hi! This post is for posterity incase anybody experiences the same thing.

I've had just reached 26000 miles when my supercharger took a crap and started making the noises in the videos below.

There wasn't any loss in power/boost and except for a very slight surging when accelerating. Noise was worst on cold start and was over shadowed by the isolator rattle when warm. I doubt its related, but I had just replaced the air filter before the noise showed up.

GM replaced under warranty in 2 days. They shipped it overnight and had it installed in half a day.




Noise at around 35 seconds:

__________________
  • 2013 Victory Red ZL1 - 68k+ miles. Mods: Who needs mods...its a freaking ZL1 - Last car: 2006 GTO
Vroom is offline   Reply With Quote
Old 05-31-2013, 03:50 AM   #2
BAD ZL1
BAD ZL1
 
BAD ZL1's Avatar
 
Drives: 2013 VIN 48 Victory Red ZL1!
Join Date: Jan 2012
Location: California
Posts: 696
Is that a typo, do you really have 26K on the car? I am curious, I have 3,400 miles and wonder if your issue is something that comes that late in mileage.
BAD ZL1 is offline   Reply With Quote
Old 05-31-2013, 03:58 AM   #3
Vroom
 
Drives: 2013 Camaro ZL1
Join Date: Oct 2012
Location: SF Bay Area
Posts: 226
no typo. its 26000 and some change
And I hope its just an anomaly. It'd suck to replace the supercharger every 25k miles...
__________________
  • 2013 Victory Red ZL1 - 68k+ miles. Mods: Who needs mods...its a freaking ZL1 - Last car: 2006 GTO
Vroom is offline   Reply With Quote
Old 05-31-2013, 04:25 AM   #4
BAD ZL1
BAD ZL1
 
BAD ZL1's Avatar
 
Drives: 2013 VIN 48 Victory Red ZL1!
Join Date: Jan 2012
Location: California
Posts: 696
Yeah it sure would suck. I wonder how many people out there have 26K on their cars. I am glad you posted this. happy to hear GM fixed it so quick for you.
BAD ZL1 is offline   Reply With Quote
Old 05-31-2013, 04:26 AM   #5
TRC-SS
TIM "COTW 2-25-13"
 
TRC-SS's Avatar
 
Drives: 2011 SuperCharged 567RWHP SS/RS LS3
Join Date: Aug 2010
Location: Shrewsbury Massachusetts
Posts: 4,604
That is an ugly sound!!!
__________________
View Build HERE>>>>>MY 2011 2SS/RS JOURNAL
TRC-SS is offline   Reply With Quote
Old 05-31-2013, 05:12 AM   #6
NightmareZL1
Can't stop ***ifying
 
NightmareZL1's Avatar
 
Drives: Ashen 2013 Gray ZL1
Join Date: Dec 2012
Location: Honolulu, HI
Posts: 273
Did they say whether it was the rotors Rubbing or the bearings growling? All stock?
NightmareZL1 is offline   Reply With Quote
Old 05-31-2013, 05:22 AM   #7
Vroom
 
Drives: 2013 Camaro ZL1
Join Date: Oct 2012
Location: SF Bay Area
Posts: 226
They didn't say. They said there wasn't any metal floating around in the intake and everything looked clean. It sounded like the noise was in the snout so I'm guessing the drive assembly or something.
I'm 100% stock. I was going to get a roto-fab CAI, but held off this time. Next filter change I'll replace it.
__________________
  • 2013 Victory Red ZL1 - 68k+ miles. Mods: Who needs mods...its a freaking ZL1 - Last car: 2006 GTO
Vroom is offline   Reply With Quote
Old 05-31-2013, 06:13 AM   #8
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
mine did the exact same thing at 8k miles. they replaced the whole supercharger as well and no problems since.
joes407 is offline   Reply With Quote
Old 05-31-2013, 06:24 AM   #9
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,124
Could this be the infamous isolator rattle that the CTS-V's experienced? If I remember they replaced the snout with a solid isolator instead of a spring loaded one that the CTS-Vs and ZL1s came with stock.

However since I've never heard the noise I'm wondering if anyone else can chime in.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 05-31-2013, 06:29 AM   #10
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
Quote:
Originally Posted by G-Oil Guy View Post
Could this be the infamous isolator rattle that the CTS-V's experienced? If I remember they replaced the snout with a solid isolator instead of a spring loaded one that the CTS-Vs and ZL1s came with stock.

However since I've never heard the noise I'm wondering if anyone else can chime in.
I was told that's what the noise was and that the new supercharger they put on had the issue fixed. Im not completely sure that is the case so I am still waiting to mod or tune just in case.
joes407 is offline   Reply With Quote
Old 05-31-2013, 11:02 AM   #11
VegasZL1
 
Drives: 2012 ZL1 #412
Join Date: Sep 2012
Location: Las Vegas, NV
Posts: 111
A buddy of mine has a 2012 CTS-V with about 12k on it. He had the exact same noise and GM replaced his SC as well.

My Z has 18k on it and no signs of this as of yet...
VegasZL1 is offline   Reply With Quote
Old 05-31-2013, 12:37 PM   #12
KKreme15

 
KKreme15's Avatar
 
Drives: C6 Z06
Join Date: Jan 2010
Location: Dayton, MD
Posts: 1,638
Quote:
Originally Posted by SC2150 View Post
What we see is if a proper catchcan is not installed when new, the oil ingestion that is present backs a residue on to the rotors and throws them off balance which takes out the bearings (as well as clogs up the intercooler)


These rotors are so finely balanced even a few grams of build up can cause failure over time.

Check out joeZL1 pictures of his.
Is 10,000 miles too late? Is my supercharger going to die?
KKreme15 is offline   Reply With Quote
Old 05-31-2013, 01:27 PM   #13
KKreme15

 
KKreme15's Avatar
 
Drives: C6 Z06
Join Date: Jan 2010
Location: Dayton, MD
Posts: 1,638
Can I clean it?
KKreme15 is offline   Reply With Quote
Old 05-31-2013, 01:45 PM   #14
PWRHSEZL1
 
PWRHSEZL1's Avatar
 
Drives: 2013 Camaro ZL1 #2419
Join Date: Jan 2013
Location: Keller, Tx
Posts: 206
OEM ISOLATOR WEAR

Here is a pic showing the wear from the OEM spring loaded isolator coupling at 3500 miles! Not sure if it may have been part of the noise but something that others should be aware of!
Attached Images
 
PWRHSEZL1 is offline   Reply With Quote
 
Reply

Tags
supercharger noise rattle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.