Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Hines Performance (HPE)
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V6

Forced Induction - V6 V6 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 01-19-2013, 01:39 AM   #1
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
IPF Supercharger steering concern

Hi! Still sorta new to this forum but I just got my IPF installed on Tuesday and so far the power has been awesome!! More than enough to give you a permagrin

Although I just have a question to the other IPF users. Did you guys notice any stiffness in the steering? I can barely make a u turn. I basically have to use all my strength to turn the steering wheel and I don't know if that's normal or what should I do? thanks for the help in advance
jessepang is offline   Reply With Quote
Old 01-19-2013, 01:47 AM   #2
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 9,746
I know you have to bleed the power steering for the install of the supercharger so do you know if it was done right? That might be your problem
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
Old 01-19-2013, 02:09 AM   #3
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
Hmm I'm not too sure if he did that. I will try that myself if need be. Thanks!!
jessepang is offline   Reply With Quote
Old 01-19-2013, 02:46 AM   #4
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 9,746
that's what I had heard, I'd double check though
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
Old 01-19-2013, 03:33 AM   #5
ASH@IPF-TUNING

 
ASH@IPF-TUNING's Avatar
 
Drives: 4x4 Turbo
Join Date: Jun 2012
Location: Germany
Posts: 132
Hi !

Please check the level in the power steering oil reservoir !!

regards ASH@IPF-TUNING
ASH@IPF-TUNING is offline   Reply With Quote
Old 01-19-2013, 07:55 AM   #6
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2012 Camaro LS "Hot Blown Six"
Join Date: May 2012
Location: Katy, Texas
Posts: 2,689
Also make sure the power steering hose to the resovoir is routed correctly, if not it can cause it to collapse and starve the system. The IPF instructions are very good in this description, they are right on the money.
__________________

2012 LS M6,ZL1Brakes, OEM Foglights (BCM Flashed for Fogs),4 Pack Guages, Factory Reproduction Wheels,Nitto NT05 tires 275/315 stagger, Leather OEM Steering Wheel,Hurst Shifter, GM Hurst Leather Shifter knob,OEM Leather Console top,Carbon Fiber Stripe Package,Emblems with Carbon overlays, ZL1 Grill,LSR Stage 4 susp,1LE Strut Brace, SOLO Cats and Exhaust, 1LE Struts/shocks, IPF Supercharger-Redline Motorsports, FSP Tuning
sycraft is online now   Reply With Quote
Old 01-19-2013, 09:28 AM   #7
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 902
Quote:
Originally Posted by sycraft View Post
Also make sure the power steering hose to the resovoir is routed correctly, if not it can cause it to collapse and starve the system. The IPF instructions are very good in this description, they are right on the money.
check for this! mine did this during install, it was noticed and fixed before it was a problem, but yours may have done it after it was all back together.
blackTT600 is offline   Reply With Quote
Old 01-19-2013, 02:02 PM   #8
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
I'll check ASAP. Thanks guys! I'll keep you updated!
jessepang is offline   Reply With Quote
Old 01-20-2013, 01:45 PM   #9
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
So I checked the level in the power steering resorvoir and it was at the minimum. Checked the hoses also and everything seemed routed correctly
jessepang is offline   Reply With Quote
Old 01-20-2013, 02:23 PM   #10
Matt @ FSP

 
Matt @ FSP's Avatar
 
Drives: 2011 Camaro SS
Join Date: Dec 2012
Location: Bradenton, FL
Posts: 2,500
Quote:
Originally Posted by jessepang View Post
So I checked the level in the power steering resorvoir and it was at the minimum. Checked the hoses also and everything seemed routed correctly

You may need to bleed the system also.. Best way to do so is to have the car on a lift or jackstands to remove the load from the front tires. If you cannot raise the vehicle, you can do it on the ground.

1 - OPEN power steering reservoir cap.

2 - Rotate LOCK to LOCK (Left all way, to right all way) MULTIPLE times (At least 3-5 times to start with -- Then you will repeat this process multiple times thereafter).

3 - Keep checking fluid and add as necessary.

** You are basically looking for air bubbles to come up through the system, you'll see the fluid look "foamy" when the air bubbles are still present**

Sounds like this should solve the issue.
Matt @ FSP is online now   Reply With Quote
Old 01-20-2013, 03:35 PM   #11
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
Tried it and no change.. now I'm worried, but I'm going to take it back to the installers and see if they can fix it. I hope they can do it!
jessepang is offline   Reply With Quote
Old 01-20-2013, 03:40 PM   #12
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 902
Have them check to see if the pump is producing any Presure.
blackTT600 is offline   Reply With Quote
Old 01-20-2013, 03:45 PM   #13
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
Will do, thanks!
jessepang is offline   Reply With Quote
Old 01-20-2013, 04:13 PM   #14
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,385
How much fluid did you drain?
Sikoriko is offline   Reply With Quote
Old 01-21-2013, 10:56 AM   #15
IPF-Tuning

 
IPF-Tuning's Avatar
 
Drives: 2012 Camaro LFX - IPF Supercharged
Join Date: Nov 2011
Location: Tempe, AZ
Posts: 457
Jesse,

Yeah call Mike at Hillbank and he will be glad to look it over for you. He's a great guy!

Thanks,

Jesse!
IPF-Tuning is offline   Reply With Quote
Old 01-21-2013, 12:40 PM   #16
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
I'm on my way to orange where they installed it. I hope he can fix it!


Thanks,
Jesse
jessepang is offline   Reply With Quote
Old 01-21-2013, 02:00 PM   #17
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,385
Hope it's just a simple fix. or fluid level,
Sikoriko is offline   Reply With Quote
Old 01-21-2013, 03:19 PM   #18
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
Just got back and unfortunately he sees nothing wrong with it and has no idea what the problem is! :(
jessepang is offline   Reply With Quote
Old 01-21-2013, 03:40 PM   #19
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2012 Camaro LS "Hot Blown Six"
Join Date: May 2012
Location: Katy, Texas
Posts: 2,689
We need pictures of the install, especially where the resovoir is and the line from the pump to the resovoir...
__________________

2012 LS M6,ZL1Brakes, OEM Foglights (BCM Flashed for Fogs),4 Pack Guages, Factory Reproduction Wheels,Nitto NT05 tires 275/315 stagger, Leather OEM Steering Wheel,Hurst Shifter, GM Hurst Leather Shifter knob,OEM Leather Console top,Carbon Fiber Stripe Package,Emblems with Carbon overlays, ZL1 Grill,LSR Stage 4 susp,1LE Strut Brace, SOLO Cats and Exhaust, 1LE Struts/shocks, IPF Supercharger-Redline Motorsports, FSP Tuning
sycraft is online now   Reply With Quote
Old 01-21-2013, 03:49 PM   #20
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 902
Did he check the pressure it was producing? maybe there is a blockage some where in there.
blackTT600 is offline   Reply With Quote
Old 01-21-2013, 03:51 PM   #21
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2012 Camaro LS "Hot Blown Six"
Join Date: May 2012
Location: Katy, Texas
Posts: 2,689
Its gotta be something simple..... Pics can hopefully tell all....
__________________

2012 LS M6,ZL1Brakes, OEM Foglights (BCM Flashed for Fogs),4 Pack Guages, Factory Reproduction Wheels,Nitto NT05 tires 275/315 stagger, Leather OEM Steering Wheel,Hurst Shifter, GM Hurst Leather Shifter knob,OEM Leather Console top,Carbon Fiber Stripe Package,Emblems with Carbon overlays, ZL1 Grill,LSR Stage 4 susp,1LE Strut Brace, SOLO Cats and Exhaust, 1LE Struts/shocks, IPF Supercharger-Redline Motorsports, FSP Tuning
sycraft is online now   Reply With Quote
Old 01-21-2013, 03:52 PM   #22
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2012 Camaro LS "Hot Blown Six"
Join Date: May 2012
Location: Katy, Texas
Posts: 2,689
Check the belt routing, make sure the belt is correct over the p/s pump pully, not reversed.
Attached Images
 
__________________

2012 LS M6,ZL1Brakes, OEM Foglights (BCM Flashed for Fogs),4 Pack Guages, Factory Reproduction Wheels,Nitto NT05 tires 275/315 stagger, Leather OEM Steering Wheel,Hurst Shifter, GM Hurst Leather Shifter knob,OEM Leather Console top,Carbon Fiber Stripe Package,Emblems with Carbon overlays, ZL1 Grill,LSR Stage 4 susp,1LE Strut Brace, SOLO Cats and Exhaust, 1LE Struts/shocks, IPF Supercharger-Redline Motorsports, FSP Tuning
sycraft is online now   Reply With Quote
Old 01-21-2013, 04:02 PM   #23
willhe64

 
willhe64's Avatar
 
Drives: 2012 45th Vert, 2011 4x4, 9sec Vega
Join Date: Mar 2012
Location: Canada
Posts: 1,880
Quote:
Originally Posted by jessepang View Post
Just got back and unfortunately he sees nothing wrong with it and has no idea what the problem is! :(
What kind of low rent outfit is this? They took an eyeball and sent you on your way? Idiots.

"My steering is not working"?

"Hmmmmm, dunno. Bye Bye". "Hope you don't crash".
__________________
I feel it only fair to warn you, I have a black belt in CAPS LOCK.
willhe64 is offline   Reply With Quote
Old 01-21-2013, 05:15 PM   #24
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,385
If you turn your wheels lock to lock you should hear the power steering pump squeeling? or at least some kind of noise. Is this steering unit the same as the V8 having wire issues. mine is a little tight but not a complete failure.
Sikoriko is offline   Reply With Quote
Old 01-21-2013, 05:23 PM   #25
jessepang
 
jessepang's Avatar
 
Drives: 2012 LFX CAMARO
Join Date: May 2012
Location: CA
Posts: 35
I will be putting pics up soon...hopefully that will help you guys notice a problem if any. But he did check the belt, checked the hoses and everything. He's stumped.
jessepang is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.