Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Sponsors Classifieds Marketplace > Exterior Parts & Accessories

Exterior Parts & Accessories All exterior parts and accessories.

View our official forum sponsors list.

Reply
 
Thread Tools
Old 04-13-2013, 10:55 AM   #351
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
Quote:
Originally Posted by Dega Man View Post
I think 3M make a VHB tape in Black or Dark Gray possibly would work better than the clips. VHB double sided tape is very adhesive, will be very difficult to remove once installed. ShopStopper what are you thoughts about that method?
Just using 3m double sided tape will last a few hours. The best bet is applying the 3m clear film before installing and using the supplied clips. I am working with a supplier right now to cut us thin strips if the protective film to send with orders.

Sent from my HTC Sensation 4G using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-13-2013, 11:12 AM   #352
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,688
Send a message via MSN to redleader
Are these just for ZL1 or any Camaro5?
Sorry, not read all 18 pages here :-O
__________________
redleader is offline   Reply With Quote
Old 04-13-2013, 11:14 AM   #353
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
Quote:
Originally Posted by redleader View Post
Are these just for ZL1 or any Camaro5?
Sorry, not read all 18 pages here :-O
Lol. They will work for any Camaro5.

Sent from my HTC Sensation 4G using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-14-2013, 10:19 AM   #354
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
We finished up about 25 sets this weekend. So everyone's order should be fulfilled this week. If you have any questions just PM me.
__________________
showstopper is offline   Reply With Quote
Old 04-16-2013, 08:07 PM   #355
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
Shipped a bunch out today.



Sent from my HTC Sensation 4G using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-17-2013, 09:26 AM   #356
RoadMonkey
that's how we do it
 
RoadMonkey's Avatar
 
Drives: '02 Camaro SS /6spd
Join Date: Oct 2010
Location: South Carolina
Posts: 341
Quote:
Originally Posted by showstopper View Post
We finished up about 25 sets this weekend. So everyone's order should be fulfilled this week. If you have any questions just PM me.
__________________
..."It's All Good" -Todd formerly maddog360
-drives: '02 Camaro SS/6spd, SLP
-rides: Harley-Davidson FLHRSE5 110ci-aka Road King
'86 Buick Grand National...mine since '99..a few mod's and never "finished"but I love her...
'13 ZL1/A6 - SOLD
RoadMonkey is offline   Reply With Quote
Old 04-18-2013, 06:20 PM   #357
Monchy36
ZLT!!! COTW (8/5/13)
 
Drives: 2011 IOM 1LT RS M6
Join Date: Mar 2012
Location: Slatington, PA
Posts: 4,661
Today I got Showstopper rock guards... Well let me said I'm very impress with the quality of this guards! Who ever say go to pep boys and buy the $10 ones and cut it they don't know what they talking about!!! I'm Really happy! Thank You Showstopper for a amazing job!!!

PS: Is raining here! Car is dirty!
Attached Images
   
Monchy36 is offline   Reply With Quote
Old 04-18-2013, 07:02 PM   #358
terryd
 
terryd's Avatar
 
Drives: 2012 Camaro ZL1 Victory Red
Join Date: Mar 2013
Location: Sudbury Ontario
Posts: 26
Quote:
Originally Posted by Monchy36 View Post
Today I got Showstopper rock guards... Well let me said I'm very impress with the quality of this guards! Who ever say go to pep boys and buy the $10 ones and cut it they don't know what they talking about!!! I'm Really happy! Thank You Showstopper for a amazing job!!!

PS: Is raining here! Car is dirty!
How long did it take to get? I ordered mine two weeks ago and have not heard anything, I would think it might take a little longer to get up here north of your boarder.
__________________
Terry
terryd is offline   Reply With Quote
Old 04-18-2013, 07:08 PM   #359
Monchy36
ZLT!!! COTW (8/5/13)
 
Drives: 2011 IOM 1LT RS M6
Join Date: Mar 2012
Location: Slatington, PA
Posts: 4,661
Quote:
Originally Posted by terryd View Post
How long did it take to get? I ordered mine two weeks ago and have not heard anything, I would think it might take a little longer to get up here north of your boarder.
I order April 2... no notification just show up today...
Monchy36 is offline   Reply With Quote
Old 04-20-2013, 07:49 AM   #360
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
Just installed a set on a non ZL1. Flows very nicely.




Sent from my Nexus 4 using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-20-2013, 01:22 PM   #361
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Finally installed them as I got them in the mail on Thursday. I wrapped the clips in tape so they would not grab into the paint and also used a pair or needle nose pliers to flatten out the spikes that are on the clips. I put the spikes on the flaps instead of on the fender side. I also took pictures of green tape of the outer edge of the flap and show how the much coverage area this helps. Here are the pictures:
Attached Images
    
__________________
AMCBimmer is offline   Reply With Quote
Old 04-20-2013, 02:29 PM   #362
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Yep, just confirmed the barbed ends will scratch the underside of the fender. Now I gotta get that fixed.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-20-2013, 02:36 PM   #363
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,871
Quote:
Originally Posted by AMCBimmer View Post
Finally installed them as I got them in the mail on Thursday. I wrapped the clips in tape so they would not grab into the paint and also used a pair or needle nose pliers to flatten out the spikes that are on the clips. I put the spikes on the flaps instead of on the fender side. I also took pictures of green tape of the outer edge of the flap and show how the much coverage area this helps. Here are the pictures:
I like the tape demo. It really shows the coverage area clearly.

Sent from my Nexus 4 using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-20-2013, 04:11 PM   #364
agent2594
 
Drives: '13 ZL1 Convertible
Join Date: Apr 2013
Location: Warren, MI
Posts: 15
Quote:
Originally Posted by AMCBimmer View Post
Finally installed them as I got them in the mail on Thursday. I wrapped the clips in tape so they would not grab into the paint and also used a pair or needle nose pliers to flatten out the spikes that are on the clips. I put the spikes on the flaps instead of on the fender side. I also took pictures of green tape of the outer edge of the flap and show how the much coverage area this helps. Here are the pictures:
Thanks for the pics! Just ordered a set.
__________________


DISCLAIMER: I am an employee of General Motors. Any views and/or opinions I express on this website are solely my own.
agent2594 is offline   Reply With Quote
Old 04-20-2013, 07:04 PM   #365
CalebZL1
 
CalebZL1's Avatar
 
Drives: 2013 VR M6 ZL1 #489.
Join Date: Apr 2013
Location: Capron, Illinois
Posts: 32
Quote:
Originally Posted by AMCBimmer View Post
Finally installed them as I got them in the mail on Thursday. I wrapped the clips in tape so they would not grab into the paint and also used a pair or needle nose pliers to flatten out the spikes that are on the clips. I put the spikes on the flaps instead of on the fender side. I also took pictures of green tape of the outer edge of the flap and show how the much coverage area this helps. Here are the pictures:
Did you have a hard time getting the clips on? I'm having a hell of a time getting them on, I've tried both ways with the spikes touching the inside of the fender and touching the guards.Would it help to use some pliers and spread them open a bit and then pinch them shut when you have the guard and the fender in-between the clip?
CalebZL1 is offline   Reply With Quote
Old 04-20-2013, 07:20 PM   #366
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Quote:
Originally Posted by CalebZL1 View Post
Did you have a hard time getting the clips on? I'm having a hell of a time getting them on, I've tried both ways with the spikes touching the inside of the fender and touching the guards.Would it help to use some pliers and spread them open a bit and then pinch them shut when you have the guard and the fender in-between the clip?
It takes a little bit of force to get them on. I would do what AC did put the barbs on the plastic.

After I fix my scratches I'm going to put them back on that way. But first I'm going to put some 3M Automotive Molding tape in between to "seal" the interface between the guard and the paint, then I'm going to wrap the back side of the clip (that will touch the fender) with electrical tape.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-20-2013, 07:30 PM   #367
CalebZL1
 
CalebZL1's Avatar
 
Drives: 2013 VR M6 ZL1 #489.
Join Date: Apr 2013
Location: Capron, Illinois
Posts: 32
Quote:
Originally Posted by G-Oil Guy View Post
It takes a little bit of force to get them on. I would do what AC did put the barbs on the plastic.

After I fix my scratches I'm going to put them back on that way. But first I'm going to put some 3M Automotive Molding tape in between to "seal" the interface between the guard and the paint, then I'm going to wrap the back side of the clip (that will touch the fender) with electrical tape.
I think I may go the same route also, I was having a hard time getting the guard and the fender in between the clip and then sliding the clip on but I was being careful so I didn't slip and scratch the paint. I'll have another go at it. Thanks.
CalebZL1 is offline   Reply With Quote
Old 04-20-2013, 07:43 PM   #368
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Quote:
Originally Posted by CalebZL1 View Post
I think I may go the same route also, I was having a hard time getting the guard and the fender in between the clip and then sliding the clip on but I was being careful so I didn't slip and scratch the paint. I'll have another go at it. Thanks.
I should note that I'm only going to use the clips if the tape doesn't completely hold it.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-20-2013, 09:18 PM   #369
AquaSSRS
 
AquaSSRS's Avatar
 
Drives: 2013 Ashen Gray ZL1
Join Date: Jan 2010
Location: Allentown, PA
Posts: 371
I just installed mine tonight. Great product. I had a set of splash guards on my SS and wish i had them on from day 1. So i knew that i needed something once I got my Z. Picked up the car yesterday and I already have some small chips all on the fenders and gills. GM fail.

I didn't use the clips. I used super strength 3M double sided trim tape. This is similar to what is used on the GM splash guards. Clean the lip, measure to fit, cut and trim. Then install the guard and use some heat for good adhesion. Seems strong. I will try to post some pics tomorrow.

I had 1/2" trim tape on hand already. I think 1/4" would be easier because you might not need to trim it down to fit the lip.
__________________
Roto-fab, Vmax, Pfadt headers, JRE tuned.

Last edited by AquaSSRS; 04-20-2013 at 09:22 PM. Reason: Add tape size
AquaSSRS is offline   Reply With Quote
Old 04-20-2013, 09:21 PM   #370
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Quote:
Originally Posted by AquaSSRS View Post
I just installed mine tonight. Great product. I had a set of splash guards on my SS and wish i had them on from day 1. So i knew that i needed something once I got my Z. Picked up the car yesterday and I already have some small chips all on the fenders and gills. GM fail.

I didn't use the clips. I used super strength 3M double sided trim tape. This is similar to what is used on the GM splash guards. Clean the lip, measure to fit, cut and trim. Then install the guard and use some heat for good adhesion. Seems strong. I will try to post some pics tomorrow.
Awesome!
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-20-2013, 10:06 PM   #371
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Quote:
Originally Posted by CalebZL1 View Post
Did you have a hard time getting the clips on? I'm having a hell of a time getting them on, I've tried both ways with the spikes touching the inside of the fender and touching the guards.Would it help to use some pliers and spread them open a bit and then pinch them shut when you have the guard and the fender in-between the clip?
I did but I just put them as far as I could. They aren't going to come off. The clips would not sit flush.
__________________
AMCBimmer is offline   Reply With Quote
Old 04-20-2013, 10:08 PM   #372
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Quote:
Originally Posted by G-Oil Guy View Post
It takes a little bit of force to get them on. I would do what AC did put the barbs on the plastic.

After I fix my scratches I'm going to put them back on that way. But first I'm going to put some 3M Automotive Molding tape in between to "seal" the interface between the guard and the paint, then I'm going to wrap the back side of the clip (that will touch the fender) with electrical tape.
Good idea but I will tell you as someone that uses double side tape it will not hold up to the elements. My clear bra is wrapped in the fender but I put painters tape in between that.
__________________
AMCBimmer is offline   Reply With Quote
Old 04-20-2013, 10:11 PM   #373
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Quote:
Originally Posted by AMCBimmer View Post
Good idea but I will tell you as someone that uses double side tape it will not hold up to the elements. My clear bra is wrapped in the fender but I put painters tape in between that.
This is the same 3M automotive tape that's used to hold our emblems and bowties on. I think it, combined with one tab should do the trick.

Additionally, I don't drive my car in the rain and usually only wash it a few times in a driving season.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-20-2013, 10:16 PM   #374
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Quote:
Originally Posted by G-Oil Guy View Post
This is the same 3M automotive tape that's used to hold our emblems and bowties on. I think it, combined with one tab should do the trick.

Additionally, I don't drive my car in the rain and usually only wash it a few times in a driving season.
Then you should be good!
__________________
AMCBimmer is offline   Reply With Quote
Old 04-20-2013, 10:20 PM   #375
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,105
Quote:
Originally Posted by AMCBimmer View Post
Then you should be good!
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.