Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Sponsors Classifieds Marketplace > Exterior Parts & Accessories

Exterior Parts & Accessories All exterior parts and accessories.

View our official forum sponsors list.

Reply
 
Thread Tools
Old 04-20-2013, 11:48 PM   #376
CalebZL1
 
CalebZL1's Avatar
 
Drives: 2013 VR M6 ZL1 #489.
Join Date: Apr 2013
Location: Capron, Illinois
Posts: 32
Quote:
Originally Posted by AMCBimmer View Post
I did but I just put them as far as I could. They aren't going to come off. The clips would not sit flush.
I finally got all 4 clips on after about 20 minutes but like you said, mine do not sit completely flush but they're not going anywhere.
CalebZL1 is offline   Reply With Quote
Old 04-21-2013, 08:36 AM   #377
AquaSSRS
 
AquaSSRS's Avatar
 
Drives: 2013 Ashen Gray ZL1
Join Date: Jan 2010
Location: Allentown, PA
Posts: 387
Name:  IMG_0442.jpg
Views: 752
Size:  161.2 KB

Name:  IMG_0443.jpg
Views: 756
Size:  116.6 KB

Name:  IMG_0444.jpg
Views: 751
Size:  117.0 KB

Here are some pictures of mine with the 3M trim tape. Considering my car will never see snow and only sees the rain occassionally, I think this will hold if not, then I can always just add the clips. But personally I would probably just drill one hole half way up and use a OEM torx screw and tape to hold it. I just don't like the look of those clips.
__________________
Roto-fab, Vmax, Pfadt headers, 10% pulley, JRE tuned.
AquaSSRS is offline   Reply With Quote
Old 04-21-2013, 10:04 AM   #378
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 3,032
Quote:
Originally Posted by AMCBimmer View Post
Finally installed them as I got them in the mail on Thursday. I wrapped the clips in tape so they would not grab into the paint and also used a pair or needle nose pliers to flatten out the spikes that are on the clips. I put the spikes on the flaps instead of on the fender side. I also took pictures of green tape of the outer edge of the flap and show how the much coverage area this helps. Here are the pictures:
Mind if i use a couple of those pics?
__________________
showstopper is offline   Reply With Quote
Old 04-21-2013, 05:07 PM   #379
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Quote:
Originally Posted by showstopper View Post
Mind if i use a couple of those pics?
Nope go for it! I think they give a better idea for coverage area.
__________________
AMCBimmer is offline   Reply With Quote
Old 04-22-2013, 05:24 AM   #380
PWRHSEZL1
 
PWRHSEZL1's Avatar
 
Drives: 2013 Camaro ZL1 #2419
Join Date: Jan 2013
Location: Keller, Tx
Posts: 248
Just ordered me a set! Should've got these much sooner!
PWRHSEZL1 is offline   Reply With Quote
Old 04-22-2013, 09:18 PM   #381
Combover
 
Combover's Avatar
 
Drives: 2013 ZL1
Join Date: Nov 2012
Location: Georgia
Posts: 493
Quote:
Originally Posted by AquaSSRS View Post

Here are some pictures of mine with the 3M trim tape. Considering my car will never see snow and only sees the rain occassionally, I think this will hold if not, then I can always just add the clips. But personally I would probably just drill one hole half way up and use a OEM torx screw and tape to hold it. I just don't like the look of those clips.
Looks nicely done. What length of tape did you use per side?
Combover is offline   Reply With Quote
Old 04-22-2013, 10:56 PM   #382
AquaSSRS
 
AquaSSRS's Avatar
 
Drives: 2013 Ashen Gray ZL1
Join Date: Jan 2010
Location: Allentown, PA
Posts: 387
Quote:
Originally Posted by GAZL1 View Post
Looks nicely done. What length of tape did you use per side?
I just put the guard in place with the screws how I wanted it and just used some electrical tape to mark the topmost part. Then removed the guard and started the tape at that point and went to the bottom of the metal fender lip. It seemed easier that way than trying to measure it.
__________________
Roto-fab, Vmax, Pfadt headers, 10% pulley, JRE tuned.
AquaSSRS is offline   Reply With Quote
Old 04-23-2013, 03:52 PM   #383
Mooseknuckle
 
Drives: 2013 ZL1
Join Date: Mar 2013
Location: Shelby Twp, MI
Posts: 9
I did not use the supplied clips. I used 3M VHB pressure sensative tape from my work and the rock guards are firmly in place. I will keep an eye on them as more miles are added. Installation was fast and simple.
Mooseknuckle is offline   Reply With Quote
Old 04-24-2013, 02:14 PM   #384
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,135
Any update from anyone else who used tape?

I fixed my one fender lip last night and will fix the other today.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-24-2013, 11:31 PM   #385
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 3,032
Just did another install today. Crystal red.




Sent from my Nexus 4 using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-25-2013, 03:17 PM   #386
RoadMonkey
that's how we do it
 
RoadMonkey's Avatar
 
Drives: '02 Camaro SS /6spd
Join Date: Oct 2010
Location: South Carolina
Posts: 362
mine arrived in the mail! Thank you!!! Now I just need to go put them on =)
__________________
..."It's All Good" -Todd formerly maddog360
-drives: '02 Camaro SS/6spd, SLP
-rides: Harley-Davidson FLHRSE5 110ci-aka Road King
'86 Buick Grand National...mine since '99..a few mod's and never "finished"but I love her...
'13 ZL1/A6 - SOLD.. but miss her often
..currently looking at a '15 ZL1
RoadMonkey is offline   Reply With Quote
Old 04-25-2013, 08:15 PM   #387
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 3,032
Quote:
Originally Posted by maddog360 View Post
mine arrived in the mail! Thank you!!! Now I just need to go put them on =)
Git r done.

Sent from my Nexus 4 using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-25-2013, 08:48 PM   #388
AquaSSRS
 
AquaSSRS's Avatar
 
Drives: 2013 Ashen Gray ZL1
Join Date: Jan 2010
Location: Allentown, PA
Posts: 387
Quote:
Originally Posted by G-Oil Guy View Post
Any update from anyone else who used tape?

I fixed my one fender lip last night and will fix the other today.
Mine are still solidly attached with the tape.
__________________
Roto-fab, Vmax, Pfadt headers, 10% pulley, JRE tuned.
AquaSSRS is offline   Reply With Quote
Old 04-26-2013, 10:27 PM   #389
PWRHSEZL1
 
PWRHSEZL1's Avatar
 
Drives: 2013 Camaro ZL1 #2419
Join Date: Jan 2013
Location: Keller, Tx
Posts: 248
Just got mine in today! Very nice product and well made! Will install this weekend and post pics!
PWRHSEZL1 is offline   Reply With Quote
Old 04-26-2013, 10:39 PM   #390
agent2594
 
Drives: '13 ZL1 Convertible
Join Date: Apr 2013
Location: Warren, MI
Posts: 15
Just installed mine earlier this evening, and they look awesome! Only put 1 clip on for now because I'm going to try to put some 3M film on it tomorrow. Went out on Woodward anyway and it didn't budge. If you're on the fence about these, trust me: they're worth it.
__________________


DISCLAIMER: I am an employee of General Motors. Any views and/or opinions I express on this website are solely my own.
agent2594 is offline   Reply With Quote
Old 04-27-2013, 10:37 PM   #391
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,135
Just re-installed mine after repairing the scratches from the clips. I used some 3M automotive tape that's intended for cladding/emblems etc and so far it's holding. I've heard you need to let the tape cure for 72 hours so I'll report back then but seems to be holding so far. The bonus of the tape is that acts as a seal between the guard and the fender which prevents rocks/dirt getting stuck in between.
__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-28-2013, 08:29 AM   #392
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,757
Send a message via MSN to redleader
Is there a source for the clips so I can get some spares?
__________________

Last edited by redleader; 04-28-2013 at 08:54 AM.
redleader is offline   Reply With Quote
Old 04-28-2013, 08:46 AM   #393
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,675
Quote:
Originally Posted by redleader View Post
Is there a source for the clips do I can get some spares?
I wish. I've been needing two of them for like a year. RPI never responds when I ask about them.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 04-28-2013, 08:56 AM   #394
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,757
Send a message via MSN to redleader
Tried eBay but I'm not sure which ones we want for this product ...
__________________
redleader is offline   Reply With Quote
Old 04-28-2013, 08:58 AM   #395
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 3,032
Quote:
Originally Posted by redleader View Post
Is there a source for the clips so I can get some spares?
EBay will not have them. If you would like some extras shoot me a pm

Sent from my Nexus 4 using Tapatalk 2
__________________
showstopper is offline   Reply With Quote
Old 04-28-2013, 09:00 AM   #396
RoadMonkey
that's how we do it
 
RoadMonkey's Avatar
 
Drives: '02 Camaro SS /6spd
Join Date: Oct 2010
Location: South Carolina
Posts: 362
I got mine installed with the clips yesterday. I'm planning to reinstall them and go with the tape method. So, I will have 4 clips if someone wants them.
__________________
..."It's All Good" -Todd formerly maddog360
-drives: '02 Camaro SS/6spd, SLP
-rides: Harley-Davidson FLHRSE5 110ci-aka Road King
'86 Buick Grand National...mine since '99..a few mod's and never "finished"but I love her...
'13 ZL1/A6 - SOLD.. but miss her often
..currently looking at a '15 ZL1
RoadMonkey is offline   Reply With Quote
Old 04-28-2013, 11:29 AM   #397
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,135
Here are mine with the 3M automotive tape. Going on 13 hours and still holding strong.

I'm keeping my clips just in case they start to give and if I have to use them, I'm putting the barbs on the plastic side and wrapping the flat part of the clip in electrical tape.







__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-28-2013, 11:50 AM   #398
AMCBimmer
 
Drives: 2002 BMW M5
Join Date: Jun 2011
Location: Aldie, VA
Posts: 242
Where did you get the tape idea and the barn on the plastic side
Quote:
Originally Posted by G-Oil Guy View Post
Here are mine with the 3M automotive tape. Going on 13 hours and still holding strong.

I'm keeping my clips just in case they start to give and if I have to use them, I'm putting the barbs on the plastic side and wrapping the flat part of the clip in electrical tape.







__________________
AMCBimmer is offline   Reply With Quote
Old 04-28-2013, 12:00 PM   #399
G-Oil Guy
Where am I?
 
G-Oil Guy's Avatar
 
Drives: Zoe the ZL1, 2012 Frontier
Join Date: Apr 2011
Location: Mars, PA
Posts: 6,135
Quote:
Originally Posted by AMCBimmer View Post
Where did you get the tape idea and the barn on the plastic side
All credit where credit due. Thanks man.









__________________
FOR SALE: 2013 ZL1 Message me if interested
G-Oil Guy is offline   Reply With Quote
Old 04-28-2013, 12:02 PM   #400
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,675
Quote:
Originally Posted by G-Oil Guy View Post
Here are mine with the 3M automotive tape. Going on 13 hours and still holding strong.

I'm keeping my clips just in case they start to give and if I have to use them, I'm putting the barbs on the plastic side and wrapping the flat part of the clip in electrical tape.







Genius. Totally doing that when I get home
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.