Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
River City Camaro Customs
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-15-2009, 09:17 AM   #1
Embalmer
2G1FT1EWXA9103351
 
Embalmer's Avatar
 
Drives: 2SS RS, SIM, 6pd, 20"Alum
Join Date: Oct 2008
Location: Canton, Michigan
Posts: 608
Issues With My Camaro - We Need a Forum Here

I know it's somewhat of a "negative" discussion, but I think it's time the mod's create an "Issues" forum.

Since owning my Camaro I've had a few issues with it and I'm wondering who else is having the same problems.

Below is my list so far:

1) RPM Gauge
The RPM gauge was "sticking" when it was coming back down from around 3k to 4k RPM. It would stutter as it came back down. (I have video of it).

I took it to the dealer for service and they had to remove the entire cluster and send it back in for repair. I got it back last friday - and the issue appears to be fixed.

HOWEVER: The dealer scuffed up my dash pretty good and dinged the silver ring that goes over the instrument cluster. They are replacing both now

2) Exhaust Noise
The dealer identified a "baffle" inside the rear driver's side muffler that is vibrating against the wall of the muffler. It is making a very high pitched ringing vibration noise and it's LOUD.

The guy at the dealership is waiting to hear back from his director on this one since it's a $2500 replacement of the exhaust apparently... go figure.

3) I have two issues with the stereo - these are minor and only 1 is a bug - I posted those issues here:
http://www.camaro5.com/forums/showthread.php?t=25156

So anyone else have these issues? I'd be very curious to see what problems you guys are having - and what you are doing to get them fixed.
Embalmer is offline   Reply With Quote
Old 06-15-2009, 10:01 AM   #2
2010SSRS

 
2010SSRS's Avatar
 
Drives: 2000 Silverado
Join Date: Apr 2009
Location: Southern WI
Posts: 1,246
lemme just start by saying that thus far, 7553 has been flawless. yes the usb options for the stereo aren't perfect............but big deal.

now, Embalmer..........for an R6P code VIN in the 3000's such as yours, on a new design run.............c'mon man. it's to be expected.

if you search, you'll see that other vins near urs have had the speedo/tach issue as well as the exhaust issue.

think about what would happen if there were a "defect/issue" sticky........

no disrespect, but these are simply 1st production run bugs! not something any forum needs to dwell on! now go enjoy her............i'm enjoying mine..
__________________
IOM 2SSRS LS3 R6P - VIN 7553 Delivered 5/22/2009 Kooks, Corsa and Roto-Fab - SOLD 9/2010

VR 2SSRS LS3 - Borla, SLP CAI
2010SSRS is offline   Reply With Quote
Old 06-15-2009, 10:07 AM   #3
2010 2-Tone


 
2010 2-Tone's Avatar
 
Drives: 2010 RY 2SS with Custom Stripes
Join Date: Mar 2009
Location: Jennings, La.
Posts: 2,287
I am sure the good outweights the bad by miles and miles!!! That does suck that they scratched you dash up.
2010 2-Tone is offline   Reply With Quote
Old 06-15-2009, 10:25 AM   #4
myold88


 
myold88's Avatar
 
Drives: SUMMIT WHITE 2SS/RS CAMARO
Join Date: Feb 2008
Location: Ct.
Posts: 5,259
I think this is an excellent thread. When problems pop up I would like to know if its just my Camaro or a common occurance. Sounds informative and interesting.
myold88 is offline   Reply With Quote
Old 06-15-2009, 10:46 AM   #5
rcphotography
Photographer Chick
 
rcphotography's Avatar
 
Drives: '10 SS IOM- SOUL SHAKER
Join Date: Jan 2009
Location: Middle GA
Posts: 168
I will add just one little issue- I use the crap out of my trunk and sometimes it doesn't want to pop open and the other day on the way home from the trip, I couldn't get it closed without using the key fob to make the actuator flip a few times. It's fine now but if it does it again I guess I have to take it in. Other than that- no other issues.
__________________
*ROBIN*
Visit- NEW WEBSITE!! Robin Cook Photography - Middle GA Photographer with a fresh perspective!
rcphotography is offline   Reply With Quote
Old 06-15-2009, 10:47 AM   #6
2010SLVRBULIT


 
2010SLVRBULIT's Avatar
 
Drives: G5 & C6
Join Date: Apr 2009
Location: MARS
Posts: 6,731
..I think it's called 'Camaro complaint thread'..
2010SLVRBULIT is offline   Reply With Quote
Old 06-15-2009, 10:54 AM   #7
live2well
 
Drives: 2010 VR 2SS/RS A6
Join Date: Oct 2008
Location: Odenton, MD
Posts: 690
Quote:
Originally Posted by rcphotography View Post
I will add just one little issue- I use the crap out of my trunk and sometimes it doesn't want to pop open and the other day on the way home from the trip, I couldn't get it closed without using the key fob to make the actuator flip a few times. It's fine now but if it does it again I guess I have to take it in. Other than that- no other issues.

I had the same issue. But I found I hadnt closed the trunk completely. The problem was solved once I pushed the trunk down all the way. Mine was OE.....( Operator Error )
__________________
Intelligence plus character that is the goal of true education.
BrianC. :flag2:
live2well is offline   Reply With Quote
Old 06-15-2009, 11:17 AM   #8
O2BQIK
 
Drives: 1991 Camaro RS
Join Date: Mar 2009
Location: Dallas area
Posts: 596
Quote:
Originally Posted by Embalmer View Post
The guy at the dealership is waiting to hear back from his director on this one since it's a $2500 replacement of the exhaust apparently... go figure.
Not exactly on-topic, but FYI, if I were you I would use that quote to my advantage...as in, the SLP loudmouth exhaust is less than that. I don't know the price but let's say it's $1500...ask them to cover the cost of that and install it. That way they save money and you get an upgraded exhaust.

Unless you prefer the stock exhaust.
__________________
2010 Camaro SS in black/beige: Sold. | '91 Camaro RS: Still the dream car!
'98 Camaro SS: Incon twin turbo. Sold | '99 Camaro SS: Heads/cam/bolt-ons. Sold.
O2BQIK is offline   Reply With Quote
Old 06-15-2009, 11:27 AM   #9
Embalmer
2G1FT1EWXA9103351
 
Embalmer's Avatar
 
Drives: 2SS RS, SIM, 6pd, 20"Alum
Join Date: Oct 2008
Location: Canton, Michigan
Posts: 608
Quote:
Originally Posted by 2010SSRS View Post
lemme just start by saying that thus far, 7553 has been flawless. yes the usb options for the stereo aren't perfect............but big deal.

now, Embalmer..........for an R6P code VIN in the 3000's such as yours, on a new design run.............c'mon man. it's to be expected.

if you search, you'll see that other vins near urs have had the speedo/tach issue as well as the exhaust issue.

think about what would happen if there were a "defect/issue" sticky........

no disrespect, but these are simply 1st production run bugs! not something any forum needs to dwell on! now go enjoy her............i'm enjoying mine..

I guess you may be missing the point.

I'm not complaining. I want an informative thread just as "myold88" suggested so we can hammer out issues with cars that are common or one-time type things.

NOW granted, I LOVE my new car - so much so that I've been out driving it and I haven't been on the forums to even see the tach issue OR the exhaust issue that you say is common with earlier builds.

Now the question becomes.... Did they actually replace the exhaust of those early cars or what? Because I seem to be getting some flack from the dealer.

THESE are the questions a thread like this can help answer... I don't want a thread where everyone simply bitches about their issues...but something that is easy to see and is actually helpful to us Camaro owners.
Embalmer is offline   Reply With Quote
Old 06-15-2009, 11:27 AM   #10
Embalmer
2G1FT1EWXA9103351
 
Embalmer's Avatar
 
Drives: 2SS RS, SIM, 6pd, 20"Alum
Join Date: Oct 2008
Location: Canton, Michigan
Posts: 608
Quote:
Originally Posted by O2BQIK View Post
Not exactly on-topic, but FYI, if I were you I would use that quote to my advantage...as in, the SLP loudmouth exhaust is less than that. I don't know the price but let's say it's $1500...ask them to cover the cost of that and install it. That way they save money and you get an upgraded exhaust.

Unless you prefer the stock exhaust.
Not a bad idea there
Embalmer is offline   Reply With Quote
Old 06-15-2009, 11:33 AM   #11
Georgie

 
Georgie's Avatar
 
Drives: Camaro... soon
Join Date: Aug 2008
Location: Chicago
Posts: 1,217
every forum has a warranty / problems section. its probably time to add it to this forum
__________________
2011 IOM or CGM 1SS
Georgie is offline   Reply With Quote
Old 06-15-2009, 11:37 AM   #12
trm0002
VIN #2G1FT1EW6A9100074
 
trm0002's Avatar
 
Drives: 2010 CAMARO 2SS/RS RJT VIN 00074
Join Date: Oct 2008
Location: Buffalo,NY 'burbs
Posts: 4,209
Send a message via AIM to trm0002
Quote:
Originally Posted by O2BQIK View Post
Not exactly on-topic, but FYI, if I were you I would use that quote to my advantage...as in, the SLP loudmouth exhaust is less than that. I don't know the price but let's say it's $1500...ask them to cover the cost of that and install it. That way they save money and you get an upgraded exhaust.

Unless you prefer the stock exhaust.
While it would be nice, they simply can't do that since they'll be sending the system back to the manufacturer for credit and the manufacturer will simply send them an extra one in the next shipment. It would be nice ( and actually smart ) to have the option- which is exactly why it won't be done.
__________________
trm0002 is offline   Reply With Quote
Old 06-15-2009, 11:47 AM   #13
CamaroHutch
 
CamaroHutch's Avatar
 
Drives: 2010 Camaro 2SS RJT
Join Date: Feb 2009
Location: Southern Indiana (Louisville Area)
Posts: 357
Whenever my RPMs are above about 2.5k, I have the strange rattling sound coming from around the dash, glovebox area... its not that loud, and only really hear it when not accelerating quickly, and when the stereo is down.... anyone else notice this... or have an idea of what it may be? It never rattles over bumps or anything else.
__________________
Ordered Jan 09

2SS RS RJT

Delivery?? 5/27/09 #10630

AFTERMARKET:
Hurst STS
Borla ATAK Catback
CamaroHutch is offline   Reply With Quote
Old 06-15-2009, 12:47 PM   #14
Embalmer
2G1FT1EWXA9103351
 
Embalmer's Avatar
 
Drives: 2SS RS, SIM, 6pd, 20"Alum
Join Date: Oct 2008
Location: Canton, Michigan
Posts: 608
Quote:
Originally Posted by CamaroHutch View Post
Whenever my RPMs are above about 2.5k, I have the strange rattling sound coming from around the dash, glovebox area... its not that loud, and only really hear it when not accelerating quickly, and when the stereo is down.... anyone else notice this... or have an idea of what it may be? It never rattles over bumps or anything else.
I've heard this when I'm going down a dirt road or over some bumps.... but not from the Engine ....

Almost sounds like a door stop twanging....
Embalmer is offline   Reply With Quote
Old 06-15-2009, 01:04 PM   #15
Ranger 75
 
Ranger 75's Avatar
 
Drives: 2010 Camaro 2SS IBM
Join Date: Apr 2009
Location: Florida
Posts: 286
Weather Strip in the trunh on the bottom of the rear window has come loose, but an easy fix.
Airbag repair light came on once with DIC warning to have it fixed, but has not returned.
Drivers side factory installed white rally stripe peeling but going to have them painted on anyway.
Oil filler cap not secured on delivery. Found it at 490 mile oil change. My fault for not checking, checked the fluid levels but not the cap.

Minor stuff (so far)
Ranger 75 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Think about this and the Z28 5th gen 13F20 Camaro ZL1 Forum - ZL1 Specific Topics 41 09-04-2010 12:59 AM
Official Camaro Convertible CONCEPT Press Release Tran Camaro Convertible Forum 12 11-18-2009 07:05 PM
Pedderizing the Nickey Camaro! Pedders coilovers / suspension fitted & tested. DallasMike Wheels and Tires Talk Sponsored by The Tire Rack 57 06-15-2009 04:36 PM
The Camaro, what it has come to mean for me Number 3 5th Gen Camaro SS LS LT General Discussions 23 04-13-2009 09:31 PM
4 SEMA CAMAROS finally unveiled by GM! (hi-res images & details) FenwickHockey65 Camaro Photos | Spyshots | Video | Media Gallery 237 11-03-2008 10:39 PM


All times are GMT -5. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.