Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-15-2009, 03:40 PM   #1
lakers171
SoCal MAYHEM
 
lakers171's Avatar
 
Drives: 2010 2LT/RS IBM
Join Date: Feb 2009
Location: Hawthorne, Ca
Posts: 2,834
Exclamation Help with an interior panel.

i have had my car for about a week and a half and everytime its a warm day outside i have noticed that the interior panel pops out. now maybe i just noticed it on warm sunny days but it bugs me that it pops out. what should i do? take it back to the dealer? hopefully no one else has the same problem. Now please no bashing on the assembling team in Oshawa im sure they didn't know.

Name:  clip_image001.jpg
Views: 448
Size:  95.6 KB
__________________
lakers171 is offline   Reply With Quote
Old 06-15-2009, 03:42 PM   #2
efpardo
Deep6
 
efpardo's Avatar
 
Drives: 2010 Camaro# 8212 | 2LT | RS | CGM
Join Date: Apr 2009
Location: Lansing, MI
Posts: 1,048
Send a message via Skype™ to efpardo
Take it to the dealer - Mine did the same on the passanger side. They will order a new clip and install it for you.
efpardo is offline   Reply With Quote
Old 06-15-2009, 03:42 PM   #3
Supermans
Camaro & Stang Enthusiast
 
Supermans's Avatar
 
Drives: 2011 Mustang 5.0 in Kona Blue
Join Date: Mar 2008
Location: Miami
Posts: 4,757
I really don't know if GM has acknowledged this to be an issue or not. I know you are not the only one with this issue.
__________________
Bought my Camaro from Eric Hall(817) 421-7266
Supermans is offline   Reply With Quote
Old 06-15-2009, 03:42 PM   #4
2010SSRS

 
2010SSRS's Avatar
 
Drives: 2000 Silverado
Join Date: Apr 2009
Location: Southern WI
Posts: 1,246
search................it's been covered!
__________________
IOM 2SSRS LS3 R6P - VIN 7553 Delivered 5/22/2009 Kooks, Corsa and Roto-Fab - SOLD 9/2010

VR 2SSRS LS3 - Borla, SLP CAI
2010SSRS is offline   Reply With Quote
Old 06-15-2009, 03:43 PM   #5
canadian ss
Psycho on day pass
 
canadian ss's Avatar
 
Drives: 2010 yellow 1ss m6 -GM tech
Join Date: Apr 2009
Location: grimsby, ont.
Posts: 436
A few other members have experienced the same problem and are currently getting an update part to fix it. Take it to the dealer for your updated fastener. Not a big problem at all.
canadian ss is offline   Reply With Quote
Old 06-15-2009, 03:43 PM   #6
nards444

 
nards444's Avatar
 
Drives: 1SS/RS Black
Join Date: May 2009
Location: New york
Posts: 2,128
its nothing against the workers. Its the cheap shit that GM and others are putting into cars these days
__________________
2010 1SS/RS Black, CGM stripes, polished Rims, Tinted windows, Hurst shifter
nards444 is offline   Reply With Quote
Old 06-15-2009, 03:44 PM   #7
lakers171
SoCal MAYHEM
 
lakers171's Avatar
 
Drives: 2010 2LT/RS IBM
Join Date: Feb 2009
Location: Hawthorne, Ca
Posts: 2,834
yeah i didn't think it was a problem at all i just wanted to know if anyone else had the same problem i guess we can close this thread and not cause any problems
__________________
lakers171 is offline   Reply With Quote
Old 06-15-2009, 03:45 PM   #8
lawdogg149
 
lawdogg149's Avatar
 
Drives: Corvette ZO6 CSR edition #47
Join Date: Apr 2009
Location: Calhoun, GA
Posts: 741
Needs a better clip return to dealer
lawdogg149 is offline   Reply With Quote
Old 06-15-2009, 03:59 PM   #9
KK2010SS
Budafinger
 
KK2010SS's Avatar
 
Drives: 2010 Camaro SS
Join Date: Feb 2009
Location: Buda, TX
Posts: 191
Quote:
Originally Posted by lakers171 View Post
i have had my car for about a week and a half and everytime its a warm day outside i have noticed that the interior panel pops out. now maybe i just noticed it on warm sunny days but it bugs me that it pops out. what should i do? take it back to the dealer? hopefully no one else has the same problem. Now please no bashing on the assembling team in Oshawa im sure they didn't know.

Attachment 32355
I had the same issue with my passenger side A-pillar. Dealer tried multiple times to fix it but it always came loose again. He finally ordered a new one and replaced it; it has been perfect ever since. I think some of the trim pieces might have had a slight bow in them causing them to keep coming undone. Just ask your dealer to order a new one.
__________________
2010 2SS/RS, LS3, IBM, Silver Rally Stripes, Black Interior, 20" Polished, Doug Thorley Shorties, Flowmaster Catback, Hurst Shifter, K&N Filter, Vararam on order.

KK2010SS is offline   Reply With Quote
Old 06-15-2009, 04:32 PM   #10
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,527
A mouse turd in the drivers side mirror?

-Funk
pnyklr is offline   Reply With Quote
Old 06-19-2009, 11:22 AM   #11
mando51
 
Drives: 1LT/RS CGM
Join Date: May 2009
Location: 90032
Posts: 3
I have the same issue. I going to take it back to the dealer tomorrow..
__________________
1100 Order Placed at Dealership 5/27/09
mando51 is offline   Reply With Quote
Old 06-26-2009, 02:36 AM   #12
rickerda
 
rickerda's Avatar
 
Drives: 2010 Camaro 2LT RS
Join Date: May 2009
Location: Chester VA
Posts: 513
I have the same issue with the passenger side. The dealer ordered the replacement parts. It does appear to be heat related, it will be fine for a few cool days then as soon as it turn hot again and it pops off.
rickerda is offline   Reply With Quote
Old 06-26-2009, 03:17 AM   #13
FNKNSTN
Banned
 
Drives: A Black Car
Join Date: Mar 2009
Location: Los Angeles, CA
Posts: 818
Looks just like mine. I need to get it taken care of.
FNKNSTN is offline   Reply With Quote
Old 06-26-2009, 10:32 AM   #14
CamaroKitty
 
Drives: 2010 Silver Ice 2LT RS V6
Join Date: Jun 2009
Location: Echo, Louisiana
Posts: 12
I have been having the same problem on my passenger side for a month. the dealer ordered a whole new panel. After waiting a week or better to get it in, they said they replaced it. Two days later, it popped loose again!!!! I looked closer at it only to find out that it was the same trim post that I had from the start!!! It was easy to tell since my husband had left some scratches behind from his pinky ring when he had tried to make it fasten back after only having the car for a week.

Very upset about the whole situation. Now they have ordered another clip!!
CamaroKitty is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.