Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 02-21-2013, 07:49 PM   #1
SOLOJM
 
Drives: 2012 2SS 45th Aniversary Edition,
Join Date: Mar 2012
Location: Haslet, TX
Posts: 43
Corsa owners

I just installed the corsa 14952 automatic version and wanted to know how much room should be between the center pipe and tunnel brace? I believe a have a rattle come from center of car and looking at the brace there seems to be less than 1/8".
SOLOJM is offline   Reply With Quote
Old 02-21-2013, 08:13 PM   #2
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,606
Did you install the spacers for the tunnel brace that come with the kit and also raise the center pipe (resonator) to touch the top of the car (per the instructions) when you tightened? If you did you should have close to an inch gap. You also need to ensure the center pipe is installed with the bottom down as the front of the pipe is slightly angled. To make sure you have this right, make sure the 2 little holes on the resonator are facing down. Having anyone of these wrong will lead to clearance issues.
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 02-21-2013, 08:45 PM   #3
SOLOJM
 
Drives: 2012 2SS 45th Aniversary Edition,
Join Date: Mar 2012
Location: Haslet, TX
Posts: 43
Quote:
Originally Posted by nyrfan View Post
Did you install the spacers for the tunnel brace that come with the kit and also raise the center pipe (resonator) to touch the top of the car (per the instructions) when you tightened? If you did you should have close to an inch gap. You also need to ensure the center pipe is installed with the bottom down as the front of the pipe is slightly angled. To make sure you have this right, make sure the 2 little holes on the resonator are facing down. Having anyone of these wrong will lead to clearance issues.
I had a local corsa dealer install it so not sure about pipe wholes. The spacers are on I will be taking back tommorw because I cannot see any gap between the two.
SOLOJM is offline   Reply With Quote
Old 02-22-2013, 05:42 AM   #4
Denis


 
Denis's Avatar
 
Drives: 2010 SS
Join Date: May 2012
Location: Lexington Park, MD
Posts: 5,725
Yea I had the same issue. Even with the spacers provided. I'm currently not even running the brace.
__________________
Denis is offline   Reply With Quote
Old 02-22-2013, 06:02 AM   #5
KICKER

 
KICKER's Avatar
 
Drives: 2010 CAMARO 2SS/RS WHITE
Join Date: Jan 2011
Location: PENSACOLA FLORIDA
Posts: 919
Yep. Took the brace off. Clickety-Clack went away!
__________________
KICKER is offline   Reply With Quote
Old 02-22-2013, 10:48 AM   #6
2PitbullSS
 
2PitbullSS's Avatar
 
Drives: 2010 Camaro SS & 2003 Z71 w/6" lift
Join Date: Jun 2009
Location: New Orleans, La
Posts: 89
Simple fix...with the car on jackstands, loosen the clamps on the x pipe/resonator. Then take a jack and carefully lift the xpipe all the way up into the tunnel. Retighten the clamps at this point and then release the pressure on the jack which will allow the xpipe to sag just enough to not touch the tunnel, but not enough to hit the tunnel brace. I started out with the same issue, had it fixed in under an hour. For me, the tunnel brace is there for a reason, so i did what i had to do to keep it there.
__________________
416ci VVT Stroker built by LETHAL RACING
2PitbullSS is offline   Reply With Quote
Old 02-22-2013, 01:12 PM   #7
GMTool

 
GMTool's Avatar
 
Drives: AGM 2012 Camaro 2SS/RS L99
Join Date: Mar 2012
Location: Southwest Illinois
Posts: 1,249
My 2 cent advice to anyone thinking about the corsa 14952 catback on an L99 is to. Research and read about the increased AFM noises on the L99 after an exhaust upgrade. Then seriously think about tuning your car. Then just get the 14951 Corsa system without the resonator. The resonator does not hide AFM noises. If you look down inside the resonator you will see 4 cutouts in the rear of the 2.5" tubes that opens it up to the larger 4" diameter of the resonator. I guess this is suppose to muffle the AFM noises. From experience, is does not work. As far as the tunnel brace is concerned. Myself I would not permanently remove the tunnel brace.
__________________
CAI Cold Air Kit. Dynatech Headers. High Flow Cats. Corsa Catback. JRE Tune. OEM Strut Tower Brace
GMTool is offline   Reply With Quote
Old 02-22-2013, 02:13 PM   #8
SOLOJM
 
Drives: 2012 2SS 45th Aniversary Edition,
Join Date: Mar 2012
Location: Haslet, TX
Posts: 43
It was the tunnel brace the shop that installed it corrected the issue. He showed me the issue under the car and stated he had seen it with many 14952's. My car has been tuned recently my JRE I guess I could of gone with the 14951 but its good now so on to the next project.
SOLOJM is offline   Reply With Quote
Old 02-22-2013, 02:16 PM   #9
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,606
Quote:
Originally Posted by SOLOJM View Post
It was the tunnel brace the shop that installed it corrected the issue. He showed me the issue under the car and stated he had seen it with many 14952's. My car has been tuned recently my JRE I guess I could of gone with the 14951 but its good now so on to the next project.
What did he do to fix it?
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 02-22-2013, 03:36 PM   #10
Denis


 
Denis's Avatar
 
Drives: 2010 SS
Join Date: May 2012
Location: Lexington Park, MD
Posts: 5,725
Quote:
Originally Posted by GMTool View Post
My 2 cent advice to anyone thinking about the corsa 14952 catback on an L99 is to. Research and read about the increased AFM noises on the L99 after an exhaust upgrade. Then seriously think about tuning your car. Then just get the 14951 Corsa system without the resonator. The resonator does not hide AFM noises. If you look down inside the resonator you will see 4 cutouts in the rear of the 2.5" tubes that opens it up to the larger 4" diameter of the resonator. I guess this is suppose to muffle the AFM noises. From experience, is does not work. As far as the tunnel brace is concerned. Myself I would not permanently remove the tunnel brace.
I find it hard to believe that stamped steel piece is really helping that much. Worse comes to worse ill grab the BMR piece.

http://www.bmrsuspension.com/?page=p...&productid=513
__________________
Denis is offline   Reply With Quote
Old 02-23-2013, 01:11 AM   #11
1sikRS

 
Drives: chevy
Join Date: Jan 2011
Location: cleveland ohio
Posts: 860
its there for side impact crash structure i wouldnt not run it either im running three inch all the way back with no issue
1sikRS is offline   Reply With Quote
Old 02-25-2013, 07:16 AM   #12
biggerisbetter
lll
 
biggerisbetter's Avatar
 
Drives: 2010 camaro ss L99
Join Date: Jan 2013
Location: new orleans
Posts: 1,189
keep the brace loosen the bolts and put a 2x4 between the resanator and brace and retighten. after all is tight take 2x4 out and there will b a perfect gap.
biggerisbetter is offline   Reply With Quote
Old 02-25-2013, 07:37 AM   #13
mlee
H-Town Camaro Club
 
mlee's Avatar
 
Drives: Number Twenty-Three
Join Date: Oct 2008
Location: Conroe, TX
Posts: 24,207
Quote:
Originally Posted by KICKER View Post
Yep. Took the brace off. Clickety-Clack went away!
Good because that clickety-clack can cause the knock sensors to falsely detect knock and pull timing. You definitely don't want the pipes to rattle like that.
__________________
.
mlee is offline   Reply With Quote
Old 02-25-2013, 08:47 AM   #14
SOLOJM
 
Drives: 2012 2SS 45th Aniversary Edition,
Join Date: Mar 2012
Location: Haslet, TX
Posts: 43
Quote:
Originally Posted by nyrfan View Post
What did he do to fix it?

The front clamp near both cats was a little loose causing the middle pipe to sag and hit the tunnel brace. The tighten everything to corsa specs so far so good for 3 days.
SOLOJM is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.