Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
B&M
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Regional Forums > International Regions > UK

UK United Kingdom

Reply
 
Thread Tools
Old 02-28-2013, 04:35 PM   #1
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
More Chips than Harry Ramsden's

Had a quick clean of the car tonight and was a bit concerned at the number of chips on the front end (+ 1 on the passenger side ribs just in front of the rear wheel - thank you to the ignoramus who has opened a car door on me). Maybe the yellow colour shows them up more than the mostly black cars I've had in recent years but certainly wouldn't expect so many after just 5 months and 4,000 miles. Anyone else experienced this.
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 02-28-2013, 04:53 PM   #2
DWEW
 
Drives: 2013 IOM UK Camaro
Join Date: May 2012
Location: Cumbria UK
Posts: 44
Touch wood I have not found any stone chips yet but I cringe every time I drive hearing all the stones and gravel on the road at the moment. I got the splash guards when I got my Camaro so that maybe helps a bit. I think the Gtechniq C1 & Exo coatings I had applied probably helps to.

On my previous car, a black 300C, it chipped like crazy, as did the front end on my old SLK. The best way to fix them, if you have the time and nerve, is to touch them in, wet sand, then polish them out.

My car did get egged when I had it for about 4 weeks and that has damaged the paint. I think I'll probably get a detailer to fix this for me though.
DWEW is offline   Reply With Quote
Old 03-01-2013, 10:04 AM   #3
stray bullitt

 
Drives: Bentley Continental GT.
Join Date: Aug 2010
Location: Boston, Lincolnshire, England
Posts: 1,021
I've seen on the US forum, that a lot of people have had stone chip issues with this car, and, yes particularly the yellow. I have a tiny chip on my front fascia, but I usually try to stay well back from other drivers anyway, for safety's sake. The incidence of chips on the side gills, can be reduced, by the fitment of GM splashguards....or as we would say...mudflaps. I had a "Williams F1" ceramic coating applied to my car before collection. This allegedly negates polishing for 5 years. I have to say, after 2 years, I have never polished my car, and it still looks good with only a swill over with clear water and a chamois.
stray bullitt is offline   Reply With Quote
Old 03-01-2013, 01:05 PM   #4
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by stray bullitt View Post
The incidence of chips on the side gills, can be reduced, by the fitment of GM splashguards....or as we would say...mudflaps..
Unfortunately mine is definitely from some b*ggers door !

Underneath the yellow is a black basecoat which makes them stand out even more. Photos are from the front spoiler and top of the letterbox.

I'll do a bit of research on the Williams F1 coating although I've got Superguard on a car (from new) and to be honest not sure that it has done anything to protect or preserve.
Attached Images
  
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-01-2013, 02:54 PM   #5
stray bullitt

 
Drives: Bentley Continental GT.
Join Date: Aug 2010
Location: Boston, Lincolnshire, England
Posts: 1,021
Yikes! Those are pretty evil chips. I don't think even the ceramic coating would've stopped whatever did those, nor indeed prevent the stupidity of other people opening their doors onto you. I bought the ceramic coating as an add on, when I got the car new from David Boatwrights in Essex, and although it stops swirling, and light scuffs, it's not going to act like a bullet proof layer. Do W.H. Brands do touch up pots , I wonder?
stray bullitt is offline   Reply With Quote
Old 03-01-2013, 03:08 PM   #6
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Sadly there are quite a few more smaller ones also. It's worth having a chat with Adam at Brands or maybe Luke (Lukiep) will know if he reads this !
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-02-2013, 03:14 AM   #7
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,749
Send a message via MSN to redleader
FM !

RickGM, I'm thinking bad paint job or vandalism ... unless you are thrapping it round your country roads passing agricultural trucks ?

:-( #hug

I just tootle along city roads and quite motorways.
redleader is offline   Reply With Quote
Old 03-02-2013, 03:53 AM   #8
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Mmmmm. Too random for malicious (and just doesn't look like that). Now those agri vehicles ..... ;-)

Paint everywhere else is fine, it's just on the front and to be honest isn't that noticeable until you scrutinize (which as owners/lovers we obviously do)
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-03-2013, 05:31 AM   #9
lukiep
 
Drives: chevy's
Join Date: May 2012
Location: lincolnshire, UK
Posts: 32
Quote:
Originally Posted by RickGM View Post
Sadly there are quite a few more smaller ones also. It's worth having a chat with Adam at Brands or maybe Luke (Lukiep) will know if he reads this !
We can get the touch up pens for them, but i don't know how much they are or how long they take to get.
lukiep is offline   Reply With Quote
Old 03-03-2013, 01:50 PM   #10
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,749
Send a message via MSN to redleader
Searched my whole body! :-O
I don't have any chips like that RickGM.
I only have a few scuffs under the very front end where I grounded it on a high kerb once :-(
P.S. I changed subject after the first line BTW.

I do have a poor colour retouch job about 25mm round on offside rear window arch :-(

Did notice today a new bullet-like hit on my front number plate :-(
And I've never been to Bradford in it :-O !

#lovingittoomuchhurts
redleader is offline   Reply With Quote
Old 03-03-2013, 02:23 PM   #11
stray bullitt

 
Drives: Bentley Continental GT.
Join Date: Aug 2010
Location: Boston, Lincolnshire, England
Posts: 1,021
It's weird that the undercoat showing through the stone chip on my 2011 Rally Yellow seems to be white, and Rick's is black.
stray bullitt is offline   Reply With Quote
Old 03-03-2013, 02:40 PM   #12
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by lukiep View Post
We can get the touch up pens for them, but i don't know how much they are or how long they take to get.

I shall have a word with Adam tomorrow to see how much and how long to get. In my experience touch ups always look just like that but still should be better than not using it.
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-03-2013, 02:45 PM   #13
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by stray bullitt View Post
It's weird that the undercoat showing through the stone chip on my 2011 Rally Yellow seems to be white, and Rick's is black.
The scuff from a door on the ribs (gills) looks white underneath but isn't as deep as the front ones.
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-03-2013, 02:55 PM   #14
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by redleader View Post
Did notice today a new bullet-like hit on my front number plate
Have you upset anyone recently?

Can't wait for the spray and chipping works start in the early summer !
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-04-2013, 08:06 AM   #15
DWEW
 
Drives: 2013 IOM UK Camaro
Join Date: May 2012
Location: Cumbria UK
Posts: 44
I got some touch up paint from WH Brand when I got my Camaro. Can't remember how much it was though.

Oh and of course I found a couple of chips when I washed the car on Saturday. I'll leave it until the Summer to sort out though.
DWEW is offline   Reply With Quote
Old 03-04-2013, 02:50 PM   #16
lukiep
 
Drives: chevy's
Join Date: May 2012
Location: lincolnshire, UK
Posts: 32
Rick, i did have a thought today about your chips, once they have been touched in have you thought about applying a paint protection film to the front bumper.
i heard good reports about these guys http://www.paintshield.co.uk
lukiep is offline   Reply With Quote
Old 03-05-2013, 02:28 AM   #17
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by lukiep View Post
Rick, i did have a thought today about your chips, once they have been touched in have you thought about applying a paint protection film to the front bumper.
i heard good reports about these guys http://www.paintshield.co.uk
Certainly worth a trip to Peterborough to look at it in the flesh.
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-05-2013, 06:57 PM   #18
Phatz
Phatz
 
Drives: V8 SS
Join Date: Jun 2012
Location: Surrey, UK
Posts: 64
Wow Rick - really sorry to see your damage!
Phatz is offline   Reply With Quote
Old 03-06-2013, 04:28 AM   #19
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by Phatz View Post
Wow Rick - really sorry to see your damage!
It's not that bad, just annoying. You have to look close to see the chips but when you know that they are there then that's where your eye goes to. I'll just have to drive in to parking spaces rather than reversing !
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-07-2013, 03:23 AM   #20
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,749
Send a message via MSN to redleader
Quote:
Originally Posted by RickGM View Post
I'll just have to drive in to parking spaces rather than reversing !
1/ What's 'reverse' mean :-)
2/ Parking? ... near other ... people ?!?! :-O
3/ Fill the chips with a Halfords touch up pen Now before they get condensation, even if it's just clear lacquer.
4/ You can always put some Graphics over them too! :-)
redleader is offline   Reply With Quote
Old 03-07-2013, 04:05 AM   #21
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by redleader View Post
1/ What's 'reverse' mean :-)
2/ Parking? ... near other ... people ?!?! :-O
3/ Fill the chips with a Halfords touch up pen Now before they get condensation, even if it's just clear lacquer.
4/ You can always put some Graphics over them too! :-)
1 The thing that makes the Tele come on - mine only works though going backwards
2 Not a problem I encounter. Just make sure your car is down the middle of a parking bay line - that's what I now do and sod 'em. If they don't want me taking up 2 bays then make them wider than 2.4 metres!
3 Ordered some yellow touch up from WH Brands
4 Flames perhaps !!!
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-07-2013, 05:27 AM   #22
redleader
redleader
 
redleader's Avatar
 
Drives: 2010 V6 3.6L Auto 1LT
Join Date: Mar 2012
Location: UK
Posts: 1,749
Send a message via MSN to redleader
Quote:
Originally Posted by RickGM View Post
4 Flames perhaps !!!
redleader is offline   Reply With Quote
Old 03-07-2013, 05:49 AM   #23
RickGM
 
RickGM's Avatar
 
Drives: 2013 SS V8 Auto
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 543
Quote:
Originally Posted by redleader View Post
Mmmm, nice
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 03-09-2013, 01:59 PM   #24
DNAudus
 
DNAudus's Avatar
 
Drives: Bumblebee Camaro SS
Join Date: Dec 2012
Location: Cambridge
Posts: 76
Hi Rick, I have the Rally Yellow and I'm experiencing the same problem. I have driven the car 3,000 miles and noticed about 10-12 more stone chips (it had 2 originally). Obviously thin paint not helped by winter weather, gritters and general dirt on the East Anglian roads.

Stone chips on the plastic show black underneath and stonechips on the metal show white undercoat. I've also had a few chips go through the black strips :'( Guess I'll just need to respray it every 3 years.
DNAudus is offline   Reply With Quote
Old 03-09-2013, 03:23 PM   #25
stray bullitt

 
Drives: Bentley Continental GT.
Join Date: Aug 2010
Location: Boston, Lincolnshire, England
Posts: 1,021
You could always do this:
. And dazzle everyone else on the road, when the sun shines (one day).
stray bullitt is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.